summaryrefslogtreecommitdiffstats
path: root/abs/core/windowmaker
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/windowmaker')
-rw-r--r--abs/core/windowmaker/PKGBUILD14
-rw-r--r--abs/core/windowmaker/WindowMaker-0.95.4.tar.gzbin0 -> 17063436 bytes
-rw-r--r--abs/core/windowmaker/__changelog1
-rw-r--r--abs/core/windowmaker/wmaker.install37
4 files changed, 46 insertions, 6 deletions
diff --git a/abs/core/windowmaker/PKGBUILD b/abs/core/windowmaker/PKGBUILD
index e9a9853..61c2b65 100644
--- a/abs/core/windowmaker/PKGBUILD
+++ b/abs/core/windowmaker/PKGBUILD
@@ -1,9 +1,9 @@
-# $Id: PKGBUILD 150208 2012-02-14 20:50:29Z daniel $
+# $Id: PKGBUILD 159727 2012-05-26 10:06:04Z daniel $
# Maintainer: Daniel Isenmann <daniel@archlinux.org>
# Contributor: Judd Vinet <jvinet@zeroflux.org>
pkgname=windowmaker
-pkgver=0.95.2
-pkgrel=1
+pkgver=0.95.4
+pkgrel=5
pkgdesc="An X11 window manager with a NEXTSTEP look and feel"
arch=(i686 x86_64)
url="http://www.windowmaker.org/"
@@ -11,12 +11,12 @@ license=('GPL' 'custom')
depends=('libxinerama' 'libxrandr' 'libxmu' 'libpng' 'libxpm' 'libxft' 'libtiff' 'giflib')
options=('!libtool')
source=(http://windowmaker.org/pub/source/release/WindowMaker-$pkgver.tar.gz wmaker.desktop)
-md5sums=('ae62bad9c4dee504066e0f172b565ff0'
- '2fba97bebfd691836b92b8f0db79ff13')
-
+#source=(WindowMaker-$pkgver.tar.gz wmaker.desktop)
+install=wmaker.install
build() {
cd $srcdir/WindowMaker-$pkgver
[ -z "$LINGUAS" ] && export LINGUAS="`ls po/*.po | sed 's:po/\(.*\)\.po$:\1:'`"
+# sh ./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --enable-xinerama \
--with-nlsdir=/usr/share/locale --with-gnustepdir=/usr/lib/GNUstep \
--enable-usermenu --enable-modelock --enable-xrandr
@@ -31,3 +31,5 @@ package() {
install -D -m644 $srcdir/wmaker.desktop $pkgdir/usr/share/xsessions/wmaker.desktop
}
+md5sums=('81d7138ea89618b2c7093f6ecff7d603'
+ '2fba97bebfd691836b92b8f0db79ff13')
diff --git a/abs/core/windowmaker/WindowMaker-0.95.4.tar.gz b/abs/core/windowmaker/WindowMaker-0.95.4.tar.gz
new file mode 100644
index 0000000..252aadd
--- /dev/null
+++ b/abs/core/windowmaker/WindowMaker-0.95.4.tar.gz
Binary files differ
diff --git a/abs/core/windowmaker/__changelog b/abs/core/windowmaker/__changelog
new file mode 100644
index 0000000..7f6a831
--- /dev/null
+++ b/abs/core/windowmaker/__changelog
@@ -0,0 +1 @@
+wmaker.install
diff --git a/abs/core/windowmaker/wmaker.install b/abs/core/windowmaker/wmaker.install
new file mode 100644
index 0000000..c646e13
--- /dev/null
+++ b/abs/core/windowmaker/wmaker.install
@@ -0,0 +1,37 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+## arg 1: the new package version
+#pre_install() {
+ # do something here
+#}
+
+## arg 1: the new package version
+post_install() {
+ ln -s /usr/share/WindowMaker /usr/local/share/WindowMaker 2>/dev/null
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ post_install
+}
+
+## arg 1: the old package version
+#pre_remove() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#post_remove() {
+ # do something here
+#}
+
+# vim:set ts=2 sw=2 et: