summaryrefslogtreecommitdiffstats
path: root/abs/core/xcb-proto/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/xcb-proto/PKGBUILD')
-rw-r--r--abs/core/xcb-proto/PKGBUILD22
1 files changed, 17 insertions, 5 deletions
diff --git a/abs/core/xcb-proto/PKGBUILD b/abs/core/xcb-proto/PKGBUILD
index d305cd4..8fd6a62 100644
--- a/abs/core/xcb-proto/PKGBUILD
+++ b/abs/core/xcb-proto/PKGBUILD
@@ -3,15 +3,22 @@
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=xcb-proto
-pkgver=1.11
-pkgrel=1
+pkgver=1.12
+pkgrel=3
pkgdesc="XML-XCB protocol descriptions"
arch=(any)
-url="http://xcb.freedesktop.org/"
+url="https://xcb.freedesktop.org/"
license=('custom')
makedepends=('python2' 'libxml2')
-source=($url/dist/$pkgname-$pkgver.tar.bz2)
-sha256sums=('b4aceee6502a0ce45fc39b33c541a2df4715d00b72e660ebe8c5bb444771e32e')
+source=($url/dist/$pkgname-$pkgver.tar.bz2
+ python-35x-fixes.patch)
+sha256sums=('5922aba4c664ab7899a29d92ea91a87aa4c1fc7eb5ee550325c3216c480a4906'
+ '1802aec973b6bf5836c1b2d65aaf5fb18051323f47826df6a95cf6621cb3282a')
+
+prepare() {
+ cd $pkgname-$pkgver
+# patch -Np1 -i ../python-35x-fixes.patch
+}
build() {
cd $pkgname-$pkgver
@@ -19,6 +26,11 @@ build() {
make
}
+check() {
+ cd $pkgname-$pkgver
+ make -k check || /bin/true
+}
+
package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install