summaryrefslogtreecommitdiffstats
path: root/abs/core/xf86-video-unichrome
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/xf86-video-unichrome')
-rw-r--r--abs/core/xf86-video-unichrome/LICENSE23
-rw-r--r--abs/core/xf86-video-unichrome/PKGBUILD26
-rw-r--r--abs/core/xf86-video-unichrome/drm-include.patch11
3 files changed, 50 insertions, 10 deletions
diff --git a/abs/core/xf86-video-unichrome/LICENSE b/abs/core/xf86-video-unichrome/LICENSE
new file mode 100644
index 0000000..f400766
--- /dev/null
+++ b/abs/core/xf86-video-unichrome/LICENSE
@@ -0,0 +1,23 @@
+Copyright (c) 2004-2007 Luc Verhaegen. All Rights Reserved.
+Copyright (c) 2004-2005 The Unichrome Project. All Rights Reserved.
+Copyright (c) 1998-2003 VIA Technologies, Inc. All Rights Reserved.
+Copyright (c) 2001-2003 S3 Graphics, Inc. All Rights Reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the "Software"),
+to deal in the Software without restriction, including without limitation
+the rights to use, copy, modify, merge, publish, distribute, sub license,
+and/or sell copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice (including the
+next paragraph) shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/abs/core/xf86-video-unichrome/PKGBUILD b/abs/core/xf86-video-unichrome/PKGBUILD
index 7f3bc57..65e9338 100644
--- a/abs/core/xf86-video-unichrome/PKGBUILD
+++ b/abs/core/xf86-video-unichrome/PKGBUILD
@@ -1,23 +1,29 @@
-# $Id: PKGBUILD 22301 2008-12-25 18:28:12Z jgc $
+# $Id: PKGBUILD 79919 2010-05-09 14:20:58Z jgc $
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=xf86-video-unichrome
pkgver=0.2.7
-pkgrel=0.1
-_gitversion=1464eb9ecb178163af0e85443c3e591755c8c320
+pkgrel=3
+_gitversion=cd12cce88ff886031c23c743569fba97eccace4e
pkgdesc="Unichrome video drivers for X.Org"
arch=(i686 x86_64)
url="http://unichrome.sf.net/"
-depends=('unichrome-dri>=7.2')
-makedepends=('pkgconfig' 'xorg-server>=1.5.3' 'xorg-util-macros' 'xf86driproto' 'glproto' 'mesa>=7.2' 'autoconf' 'automake' 'libtool')
+license=('custom')
+depends=('unichrome-dri>=7.8.1')
+makedepends=('pkgconfig' 'xorg-server>=1.8.0' 'xorg-util-macros' 'xf86driproto' 'glproto' 'mesa>=7.8.1' 'autoconf' 'automake' 'libtool')
options=('!libtool')
-conflicts=('xf86-video-via' 'openchrome' 'xf86-video-openchrome' 'xorg-server<1.5.3')
-source=(http://cgit.freedesktop.org/~libv/${pkgname}/snapshot/${pkgname}-${_gitversion}.tar.bz2)
-md5sums=('dfef1e3b9ed24d50938ea5ee6f708457')
+conflicts=('xf86-video-via' 'openchrome' 'xf86-video-openchrome' 'xorg-server<1.8.0')
+source=(http://cgit.freedesktop.org/~libv/${pkgname}/snapshot/${pkgname}-${_gitversion}.tar.bz2
+ drm-include.patch
+ LICENSE)
+md5sums=('c64332e6c386ed9a580116e131f288f4'
+ '4a9bf2e3ef338c170a2f58988ebb97dc'
+ '6ea7d64c87c5c32201a1e38e3336e44a')
build() {
cd "${srcdir}/${pkgname}-${_gitversion}"
- ./autogen.sh --prefix=/usr \
- --enable-dri
+ patch -Np0 -i "${srcdir}/drm-include.patch" || return 1
+ ./autogen.sh --prefix=/usr --enable-dri || return 1
make || return 1
make DESTDIR="${pkgdir}" install || return 1
+ install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" || return 1
}
diff --git a/abs/core/xf86-video-unichrome/drm-include.patch b/abs/core/xf86-video-unichrome/drm-include.patch
new file mode 100644
index 0000000..edfe9a8
--- /dev/null
+++ b/abs/core/xf86-video-unichrome/drm-include.patch
@@ -0,0 +1,11 @@
+--- src/via_memory.h.orig 2010-05-09 16:17:00.143352805 +0200
++++ src/via_memory.h 2010-05-09 16:17:14.433351301 +0200
+@@ -30,7 +30,7 @@
+
+ /* don't include local via_drm.h when using modular */
+ #ifdef HAVE_CONFIG_H
+-#include "drm/via_drm.h"
++#include <via_drm.h>
+ #else
+ #include "via_drm.h"
+ #endif