summaryrefslogtreecommitdiffstats
path: root/abs/core/xproto/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/xproto/PKGBUILD')
-rw-r--r--abs/core/xproto/PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/abs/core/xproto/PKGBUILD b/abs/core/xproto/PKGBUILD
new file mode 100644
index 0000000..bdde6af
--- /dev/null
+++ b/abs/core/xproto/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id: PKGBUILD 3230 2008-06-21 15:50:01Z jgc $
+# Maintainer: Alexander Baldeck <alexander@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+pkgname=xproto
+pkgver=7.0.13
+pkgrel=1
+pkgdesc="X11 core wire protocol and auxiliary headers"
+arch=(i686 x86_64)
+license=('custom')
+url="http://xorg.freedesktop.org/"
+source=(${url}/releases/individual/proto/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('7d26f45dca52632712a696e0631dc17b')
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR=${startdir}/pkg install || return 1
+
+ install -D -m644 ${startdir}/src/${pkgname}-${pkgver}/COPYING \
+ ${startdir}/pkg/usr/share/licenses/${pkgname}/COPYING
+}