summaryrefslogtreecommitdiffstats
path: root/abs/core/yasm/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/yasm/PKGBUILD')
-rw-r--r--abs/core/yasm/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/core/yasm/PKGBUILD b/abs/core/yasm/PKGBUILD
new file mode 100644
index 0000000..fcbd935
--- /dev/null
+++ b/abs/core/yasm/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 18746 2008-11-08 22:44:05Z aaron $
+# Maintainer: Aaron Griffin <aaron@archlinux.org>
+# Contributor: Vinay S Shastry <vinayshastry@gmail.com>
+
+pkgname=yasm
+pkgver=0.7.2
+pkgrel=1
+pkgdesc="A rewrite of NASM to allow for multiple syntax supported (NASM, TASM, GAS, etc.)"
+arch=('i686' 'x86_64')
+license=('custom')
+url="http://www.tortall.net/projects/yasm/"
+depends=('glibc')
+source=(http://www.tortall.net/projects/yasm/releases/$pkgname-$pkgver.tar.gz)
+options=('!libtool')
+md5sums=('cc9360593de5625dca286f0bfcb27dd5')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+ install -Dm644 COPYING $startdir/pkg/usr/share/licenses/$pkgname/COPYING
+}