summaryrefslogtreecommitdiffstats
path: root/abs/core/zoneminder/Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/zoneminder/Makefile.patch')
-rw-r--r--abs/core/zoneminder/Makefile.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/abs/core/zoneminder/Makefile.patch b/abs/core/zoneminder/Makefile.patch
new file mode 100644
index 0000000..d033e72
--- /dev/null
+++ b/abs/core/zoneminder/Makefile.patch
@@ -0,0 +1,13 @@
+--- ZoneMinder-1.23.3.orig/Makefile 2008-03-13 17:41:47.000000000 -0700
++++ ZoneMinder-1.23.3/Makefile 2008-03-15 06:21:22.000000000 -0700
+@@ -687,8 +687,8 @@
+ # Yes, you are correct. This is a HACK!
+ install-data-hook:
+ ( cd $(DESTDIR)$(sysconfdir); chown $(webuser):$(webgroup) $(sysconf_DATA); chmod 600 $(sysconf_DATA) )
+- -( if ! test -e $(RUNDIR); then mkdir $(RUNDIR); fi )
+- ( if ! test -e $(ZM_RUNDIR); then mkdir $(ZM_RUNDIR); fi; chown $(webuser):$(webgroup) $(ZM_RUNDIR); chmod u+w $(ZM_RUNDIR) )
++ -( if ! test -e$(DESTDIR)$(RUNDIR); then mkdir -p $(DESTDIR)$(RUNDIR); fi )
++ ( if ! test -e $(DESTDIR)$(ZM_RUNDIR); then mkdir -p $(DESTDIR)$(ZM_RUNDIR); fi; chown $(webuser):$(webgroup) $(DESTDIR)$(ZM_RUNDIR); chmod u+w $(DESTDIR)$(ZM_RUNDIR) )
+
+ uninstall-hook:
+ @-( cd $(DESTDIR)$(webdir); rm -rf events graphics images sounds temp )