summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core')
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/remotes/run22
2 files changed, 11 insertions, 13 deletions
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index f324ee9..a4f87a2 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=8.6
-pkgrel=1
+pkgrel=2
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license=('BSD')
diff --git a/abs/core/runit-scripts/runitscripts/services/remotes/run b/abs/core/runit-scripts/runitscripts/services/remotes/run
index 9fbb16e..9c61daa 100755
--- a/abs/core/runit-scripts/runitscripts/services/remotes/run
+++ b/abs/core/runit-scripts/runitscripts/services/remotes/run
@@ -8,7 +8,7 @@ export TERM=linux
LOG=/tmp/remotes.log
MODPROBE="/usr/bin/modprobe"
-LIRCD="/usr/bin/lircd "
+LIRCD="/usr/bin/lircd"
SETSERIAL="/usr/bin/setserial"
@@ -112,7 +112,7 @@ else
if [ x$HostBlasterType = xCommandIR -o x$ReceiverType = xCommandIR ]
then
- CMD="$LIRCD-r -n --driver=commandir"
+ CMD="$LIRCD --release --nodaemon --driver=commandir"
printhl " Using commandir"
echo $CMD >>$LOG
$CMD >>$LOG 2>>$LOG
@@ -120,7 +120,7 @@ else
elif [ x$HostBlasterType = xiguanaIR-usb -o x$ReceiverType = xiguanaIR-usb ]
then
sv start igdaemon
- CMD="$LIRCD-r -n --driver=iguanaIR"
+ CMD="$LIRCD --release --nodaemon --driver=iguanaIR"
printhl " Using iguanaIR usb"
echo $CMD >>$LOG
$CMD >>$LOG 2>>$LOG
@@ -128,7 +128,7 @@ else
elif [ x$ReceiverType = "xSiliconDust_HDHR" ]
then
# if using the SiliconDust_HDHR as an I/R Receiver
- CMD="$LIRCD-H udp -d 5000 -n"
+ CMD="$LIRCD --nodaemon --driver=udp --device=5000"
printhl " Using SiliconDust on port 5000"
echo $CMD >>$LOG
$CMD >>$LOG 2>>$LOG
@@ -177,7 +177,7 @@ else
DEFINED_RECEIVER="False"
for i in `seq 1 $num_lirc`
do
- CMD="$LIRCD-r -d /dev/lirc$i --output=/var/run/lirc/lircd$i --pidfile=/var/run/lircd$i.pid --listen=876$i"
+ CMD="$LIRCD --release --device=/dev/lirc$i --driver=default --output=/var/run/lirc/lircd$i --pidfile=/var/run/lircd$i.pid --listen=876$i"
printhl " Device $i"
echo $CMD >>$LOG
$CMD >>$LOG 2>>$LOG
@@ -216,24 +216,24 @@ else
then
#start receiver
#start blaster chain
- CMD="$LIRCD-r -d $IRNODE --output=/var/run/lirc/lircd1 --pidfile=/var/run/lircd1.pid --listen=8761"
- LCMD="$LIRCD-r -n -d $BLASTERNODE --output /var/run/lirc/lircd $LASTCMD"
+ CMD="$LIRCD --release --device=$IRNODE --driver=default --output=/var/run/lirc/lircd1 --pidfile=/var/run/lircd1.pid --listen=8761"
+ LCMD="$LIRCD --release --nodaemon --device=$BLASTERNODE --driver=default --output=/var/run/lirc/lircd $LASTCMD"
echo $CMD >>$LOG
$CMD >>$LOG 2>>$LOG
elif [ x$USE_BLASTER = xTrue ]
then
#start only the blaster
- LCMD="$LIRCD-r -n -d $BLASTERNODE --output /var/run/lirc/lircd $LASTCMD"
+ LCMD="$LIRCD --release --nodaemon --device=$BLASTERNODE --driver=default --output=/var/run/lirc/lircd $LASTCMD"
elif [ x$DEFINED_RECEIVER = xTrue ]
then
#start reciever
- LCMD="$LIRCD-r -n -d $IRNODE --output /var/run/lirc/lircd"
+ LCMD="$LIRCD --release --nodaemon --device=$IRNODE --driver=default --output=/var/run/lirc/lircd"
else
#default case of /dev/lirc0
- LCMD="$LIRCD-r -n -d /dev/lirc0 --output /var/run/lirc/lircd $LASTCMD"
+ LCMD="$LIRCD --release --nodaemon --device=/dev/lirc0 --driver=default --output=/var/run/lirc/lircd $LASTCMD"
fi
echo $LASTCMD >>$LOG
@@ -242,10 +242,8 @@ else
-
echo "Starting remotes from $LCMD" >>$LOG
exec $LCMD >>$LOG 2>>$LOG
-
fi
fi
fi