summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/LinHES-system/myth_status.py15
-rw-r--r--abs/core/mythtv/stable-0.25/git_src/git_hash2
-rw-r--r--abs/core/python_modules/python-beautifulsoup4/PKGBUILD51
-rw-r--r--abs/core/python_modules/python-beautifulsoup4/__changelog2
-rw-r--r--abs/core/python_modules/python-libconcord/PKGBUILD22
5 files changed, 83 insertions, 9 deletions
diff --git a/abs/core/LinHES-system/myth_status.py b/abs/core/LinHES-system/myth_status.py
index b4f4375..da43679 100644
--- a/abs/core/LinHES-system/myth_status.py
+++ b/abs/core/LinHES-system/myth_status.py
@@ -92,14 +92,13 @@ print ""
print "Conflicted Recordings:"
print "----------------------"
a=be.getConflictedRecordings()
-try:
- if len(a) == 0:
- print " No conflicts"
- else:
- for i in a:
- title_chan="%s (%s)" %(i.title, i.channame)
- print " %s - %-50s " %(i.starttime,title_chan)
-except:
+c=0
+for i in a:
+ title_chan="%s (%s)" %(i.title, i.channame)
+ print " %s - %-50s " %(i.starttime,title_chan)
+ c=c+1
+
+if c == 0:
print " No conflicts"
print ""
diff --git a/abs/core/mythtv/stable-0.25/git_src/git_hash b/abs/core/mythtv/stable-0.25/git_src/git_hash
index 8e5da8e..fe72041 100644
--- a/abs/core/mythtv/stable-0.25/git_src/git_hash
+++ b/abs/core/mythtv/stable-0.25/git_src/git_hash
@@ -1 +1 @@
-d51927663b67c7c035108270a31bf14aed68bcdb
+0817eb2a6d5663c5dce770105b8350688f09e97e
diff --git a/abs/core/python_modules/python-beautifulsoup4/PKGBUILD b/abs/core/python_modules/python-beautifulsoup4/PKGBUILD
new file mode 100644
index 0000000..e5eba14
--- /dev/null
+++ b/abs/core/python_modules/python-beautifulsoup4/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id: PKGBUILD 73500 2012-07-08 17:25:45Z dwallace $
+# Maintainer: Daniel Wallace <danielwallace at gtmanfred dot com>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+
+pkgbase=python-beautifulsoup4
+pkgname=('python2-beautifulsoup4' 'python-beautifulsoup4')
+pkgver=4.1.1
+pkgrel=2
+pkgdesc="A Python HTML/XML parser designed for quick turnaround projects like screen-scraping"
+arch=('any')
+url="http://www.crummy.com/software/BeautifulSoup/index.html"
+license=('PSF')
+#makedepends=('python-distribute' 'python2-distribute')
+makedepends=('python2-distribute')
+source=("http://www.crummy.com/software/BeautifulSoup/bs4/download/${pkgver%\.*}/${pkgbase#*-}-${pkgver}.tar.gz")
+md5sums=('fccee58b4d914fb489385d672fe89f43')
+
+build() {
+ cd "${srcdir}"
+ cp -a beautifulsoup4-${pkgver}{,-python2}
+
+ # Build python 3 module
+ cd "${srcdir}/beautifulsoup4-${pkgver}"
+ python setup.py build
+
+ # Build python 2 module
+ cd "${srcdir}/beautifulsoup4-${pkgver}-python2"
+ python2 setup.py build
+}
+
+package_python2-beautifulsoup4() {
+ depends=('python2-distribute')
+ optdepends=('python2-chardet: universal encoding detector'
+ 'python2-lxml: pythonic binding for the libxml2 and libxslt libraries')
+
+ cd "${srcdir}/beautifulsoup4-${pkgver}-python2"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+
+ rm -rf ${pkgdir}/usr/lib/python2.7/site-packages/bs4/tests
+}
+
+package_python-beautifulsoup4() {
+# depends=('python-distribute')
+ optdepends=('python-chardet: universal encoding detector'
+ 'python-lxml: pythonic binding for the libxml2 and libxslt libraries')
+
+ cd "${srcdir}/beautifulsoup4-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+
+ rm -rf ${pkgdir}/usr/lib/python3.2/site-packages/bs4/{__pycache__,tests,builder/__pycache__}
+}
diff --git a/abs/core/python_modules/python-beautifulsoup4/__changelog b/abs/core/python_modules/python-beautifulsoup4/__changelog
new file mode 100644
index 0000000..1cdf6fa
--- /dev/null
+++ b/abs/core/python_modules/python-beautifulsoup4/__changelog
@@ -0,0 +1,2 @@
+9/3/12 - chw
+commented python-distribute as dep since we don't include python3. Built with mp.py --pkg=python2-beautisoup4.
diff --git a/abs/core/python_modules/python-libconcord/PKGBUILD b/abs/core/python_modules/python-libconcord/PKGBUILD
new file mode 100644
index 0000000..fb638f8
--- /dev/null
+++ b/abs/core/python_modules/python-libconcord/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id$
+# Maintainers:
+# Andreas Baumann <abaumann@yahoo.com>
+# Guillaume DUMOULIN <guillaume.dumoulin@gmail.com>
+# Contributor: elsixdiab
+pkgname=python-libconcord
+_pkgsrcname=concordance
+pkgver=0.23
+pkgrel=3
+pkgdesc="This software will allow you to program your Logitech Harmony universal remote control"
+url="http://www.phildev.net/harmony/index.shtml"
+license="GPL"
+arch=('any')
+depends=('libconcord=0.23' 'python2')
+source=("http://downloads.sourceforge.net/${_pkgsrcname}/${_pkgsrcname}-${pkgver}.tar.bz2")
+md5sums=('d7400d5b351b195b63adfafae68be3d8')
+build() {
+ cd $srcdir/${_pkgsrcname}-${pkgver}/libconcord/bindings/python/
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+