summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/autofs
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/autofs')
-rwxr-xr-xabs/extra-testing/autofs/Changelog6
-rwxr-xr-xabs/extra-testing/autofs/PKGBUILD50
-rw-r--r--abs/extra-testing/autofs/auto.master6
-rw-r--r--abs/extra-testing/autofs/auto.misc7
-rw-r--r--abs/extra-testing/autofs/autofs50
-rw-r--r--abs/extra-testing/autofs/autofs.conf.d4
-rw-r--r--abs/extra-testing/autofs/autofs.install5
-rwxr-xr-xabs/extra-testing/autofs/finish9
-rw-r--r--abs/extra-testing/autofs/heimdal.patch44
-rwxr-xr-xabs/extra-testing/autofs/log.run2
-rwxr-xr-xabs/extra-testing/autofs/run19
11 files changed, 0 insertions, 202 deletions
diff --git a/abs/extra-testing/autofs/Changelog b/abs/extra-testing/autofs/Changelog
deleted file mode 100755
index d8df4dc..0000000
--- a/abs/extra-testing/autofs/Changelog
+++ /dev/null
@@ -1,6 +0,0 @@
-5.0.4-5 4/29/09
-Cecil - Added run and finish files for runit.
-6/28/10
-Britney - Updated run to manage automount; removed finish and /etc/rc.d/autofs; added logger
-5.0.5-1 6/12/10
-Britney - Updated to 5.0.5 based on arch autofs 5.0.5 PKGBUILD and heimdal.patch with runit support added.
diff --git a/abs/extra-testing/autofs/PKGBUILD b/abs/extra-testing/autofs/PKGBUILD
deleted file mode 100755
index ae04100..0000000
--- a/abs/extra-testing/autofs/PKGBUILD
+++ /dev/null
@@ -1,50 +0,0 @@
-# $Id: PKGBUILD 75323 2010-04-01 10:16:24Z allan $
-# Maintainer: Andrea Scarpino <andrea@archlinux.org>
-# Contributor: Dale Blount <dale@archlinux.org>
-# Contributor: Manolis Tzanidakis
-
-pkgname=autofs
-pkgver=5.0.5
-pkgrel=3
-pkgdesc="A kernel-based automounter for Linux"
-arch=('i686' 'x86_64')
-url="http://wiki.autofs.net/FrontPage"
-license=('GPL2')
-depends=('libldap' 'libxml2' 'heimdal')
-backup=(etc/autofs/auto.master etc/autofs/auto.misc etc/conf.d/autofs)
-install=${pkgname}.install
-source=("http://www.kernel.org/pub/linux/daemons/${pkgname}/v5/${pkgname}-${pkgver}.tar.bz2"
- 'autofs' 'autofs.conf.d' 'auto.master' 'auto.misc'
- 'heimdal.patch')
-md5sums=('a1d262cb6ebef0c2dd0fe22232fb3d5a'
- 'e307bf6d2638e46eeb916cf42fe029b2'
- '47f597c870410055e0fdb66103daf928'
- 'a6cefb591e77b31b79dbb7243646c96b'
- 'd8a15ec9186c5c0b36e5cea1e2739e8a'
- 'efd46b6406b940cb48f7c6197790fb8e')
-
-build() {
- export MAKEFLAGS="-j1"
- cd ${srcdir}/${pkgname}-${pkgver}
-
- sed -i "s:SUBDIRS = lib daemon modules man samples:SUBDIRS = lib daemon modules man:" Makefile.rules
- patch -Np1 -i ${srcdir}/heimdal.patch
-
- ./configure --prefix=/usr \
- --sysconfdir=/etc/autofs \
- --with-mapdir=/etc/autofs \
- --without-hesiod
- make || return 1
-
- sed -i "s:/etc:/etc/autofs:g" man/auto.master.5
-}
-
-package(){
- cd ${srcdir}/${pkgname}-${pkgver}
- make INSTALLROOT=${pkgdir} install
-
- install -Dm644 ${srcdir}/auto.master ${pkgdir}/etc/autofs/auto.master || return 1
- install -Dm644 ${srcdir}/auto.misc ${pkgdir}/etc/autofs/auto.misc || return 1
- install -Dm755 ${srcdir}/autofs ${pkgdir}/etc/rc.d/autofs || return 1
- install -Dm644 ${srcdir}/autofs.conf.d ${pkgdir}/etc/conf.d/autofs || return 1
-}
diff --git a/abs/extra-testing/autofs/auto.master b/abs/extra-testing/autofs/auto.master
deleted file mode 100644
index be4ea73..0000000
--- a/abs/extra-testing/autofs/auto.master
+++ /dev/null
@@ -1,6 +0,0 @@
-# Sample auto.master file
-# Format of this file:
-# mountpoint map options
-# For details of the format look at autofs(5).
-
-#/media /etc/autofs/auto.media
diff --git a/abs/extra-testing/autofs/auto.misc b/abs/extra-testing/autofs/auto.misc
deleted file mode 100644
index 5691566..0000000
--- a/abs/extra-testing/autofs/auto.misc
+++ /dev/null
@@ -1,7 +0,0 @@
-# This is an automounter map and it has the following format
-# key [ -mount-options-separated-by-comma ] location
-# Details may be found in the autofs(5) manpage
-
-cdrom -fstype=iso9660,ro,nodev,nosuid :/dev/cdrom
-floppy -fstype=auto,async,nodev,nosuid,umask=000 :/dev/fl
-usbstick -fstype=auto,async,nodev,nosuid,umask=000 :/dev/sda1
diff --git a/abs/extra-testing/autofs/autofs b/abs/extra-testing/autofs/autofs
deleted file mode 100644
index 08bd3e1..0000000
--- a/abs/extra-testing/autofs/autofs
+++ /dev/null
@@ -1,50 +0,0 @@
-#!/bin/bash
-
-daemon_name=autofs
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-# source application-specific settings
-[ -f /etc/conf.d/autofs ] && . /etc/conf.d/autofs
-
-if [ ! -z "$TIMEOUT" ]; then
- daemonoptions="--timeout=$TIMEOUT $daemonoptions"
-fi
-
-PID=`cat /var/run/autofs-running 2> /dev/null`
-case "$1" in
- start)
- stat_busy "Starting $daemon_name daemon"
- [ -z "$PID" ] && /usr/sbin/automount $daemonoptions &> /dev/null
- if [ $? -gt 0 ]; then
- stat_fail
- else
- add_daemon $daemon_name
- stat_done
- fi
- ;;
- stop)
- stat_busy "Stopping $daemon_name daemon"
- [ ! -z "$PID" ] && kill $PID &> /dev/null
- if [ $? -gt 0 ]; then
- stat_fail
- else
- rm_daemon $daemon_name
- stat_done
- fi
- ;;
- restart)
- stat_busy "Restarting $daemon_name daemon"
- $0 stop
- sleep 1
- $0 start
- ;;
- status)
- stat_busy "Checking $daemon_name status";
- ck_status $daemon_name
- ;;
- *)
- echo "usage: $0 {start|stop|restart|status}"
-esac
-exit 0
diff --git a/abs/extra-testing/autofs/autofs.conf.d b/abs/extra-testing/autofs/autofs.conf.d
deleted file mode 100644
index bc82491..0000000
--- a/abs/extra-testing/autofs/autofs.conf.d
+++ /dev/null
@@ -1,4 +0,0 @@
-#localoptions='rsize=8192,wsize=8192'
-
-# e.g. --timeout=60
-daemonoptions=''
diff --git a/abs/extra-testing/autofs/autofs.install b/abs/extra-testing/autofs/autofs.install
deleted file mode 100644
index 7806efa..0000000
--- a/abs/extra-testing/autofs/autofs.install
+++ /dev/null
@@ -1,5 +0,0 @@
-post_install(){
- echo "#########################################################"
- echo "In autofs5 --ghost option isn't valid. In order to start autofs"
- echo "you must remove that option from your /etc/conf.d/autofs. "
-}
diff --git a/abs/extra-testing/autofs/finish b/abs/extra-testing/autofs/finish
deleted file mode 100755
index 40d2fdc..0000000
--- a/abs/extra-testing/autofs/finish
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-exec 2>&1
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-stat_runit "Stopping autofs4 kernel module" && echo ""
-set -e # barf if modprobe fails
-/sbin/modprobe -r autofs4
diff --git a/abs/extra-testing/autofs/heimdal.patch b/abs/extra-testing/autofs/heimdal.patch
deleted file mode 100644
index 4aa3218..0000000
--- a/abs/extra-testing/autofs/heimdal.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- autofs-5.0.5/modules/cyrus-sasl.c~ 2010-03-03 01:38:41.582901786 +0100
-+++ autofs-5.0.5/modules/cyrus-sasl.c 2010-03-03 01:41:32.313704755 +0100
-@@ -66,6 +66,15 @@
- #endif
- #endif
-
-+/**
-+ * The type of a principal is different for MIT Krb5 and Heimdal.
-+ * These macros are provided by Heimdal, and introduced here for MIT.
-+ */
-+#ifndef krb5_realm_length
-+#define krb5_realm_length(r) ((r).length)
-+#define krb5_realm_data(r) ((r).data)
-+#endif
-+
- /*
- * Once a krb5 credentials cache is setup, we need to set the KRB5CCNAME
- * environment variable so that the library knows where to find it.
-@@ -452,11 +452,11 @@
-
- /* setup a principal for the ticket granting service */
- ret = krb5_build_principal_ext(ctxt->krb5ctxt, &tgs_princ,
-- krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)->length,
-- krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)->data,
-+ krb5_realm_length(*krb5_principal_get_realm(ctxt->krb5ctxt, krb5_client_princ)),
-+ krb5_realm_data(*krb5_principal_get_realm(ctxt->krb5ctxt, krb5_client_princ)),
- strlen(KRB5_TGS_NAME), KRB5_TGS_NAME,
-- krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)->length,
-- krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)->data,
-+ krb5_realm_length(*krb5_principal_get_realm(ctxt->krb5ctxt, krb5_client_princ)),
-+ krb5_realm_data(*krb5_principal_get_realm(ctxt->krb5ctxt, krb5_client_princ)),
- 0);
- if (ret) {
- error(logopt,
---- autofs-5.0.5/modules/Makefile~ 2010-03-03 01:42:18.532868539 +0100
-+++ autofs-5.0.5/modules/Makefile 2010-03-03 01:42:35.360367371 +0100
-@@ -43,7 +43,7 @@
- ifeq ($(SASL), 1)
- SASL_OBJ = cyrus-sasl.o
- LDAP_FLAGS += $(SASL_FLAGS) $(XML_FLAGS) -DLDAP_THREAD_SAFE
-- LIBLDAP += $(LIBSASL) $(XML_LIBS)
-+ LIBLDAP += $(LIBSASL) $(XML_LIBS) -lkrb5
- endif
- endif \ No newline at end of file
diff --git a/abs/extra-testing/autofs/log.run b/abs/extra-testing/autofs/log.run
deleted file mode 100755
index d184328..0000000
--- a/abs/extra-testing/autofs/log.run
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-/usr/bin/logger -p info -i -t autofs
diff --git a/abs/extra-testing/autofs/run b/abs/extra-testing/autofs/run
deleted file mode 100755
index 342ade6..0000000
--- a/abs/extra-testing/autofs/run
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/bin/sh
-exec 2>&1
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-stat_runit "Starting autofs4 kernel module" && echo ""
-set -e # barf if modprobe fails
-/sbin/modprobe autofs4
-
-stat_runit "Starting autofs automount" && echo ""
-# source application-specific settings
-[ -f /etc/conf.d/autofs ] && . /etc/conf.d/autofs
-
-if [ ! -z "$TIMEOUT" ]; then
- daemonoptions="--timeout=$TIMEOUT $daemonoptions"
-fi
-
-exec /usr/sbin/automount -f $daemonoptions