summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/bmp
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/bmp')
-rw-r--r--abs/extra-testing/bmp/0.9.7-visualization.patch12
-rw-r--r--abs/extra-testing/bmp/0.9.7.1-visualization.patch12
-rw-r--r--abs/extra-testing/bmp/PKGBUILD25
-rw-r--r--abs/extra-testing/bmp/bmp-0.9.7.1-crossfade-0.3.9.patch108
4 files changed, 0 insertions, 157 deletions
diff --git a/abs/extra-testing/bmp/0.9.7-visualization.patch b/abs/extra-testing/bmp/0.9.7-visualization.patch
deleted file mode 100644
index ac03323..0000000
--- a/abs/extra-testing/bmp/0.9.7-visualization.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- beep/vis.c 2004-12-04 10:04:29.000000000 +0100
-+++ beep/vis.c 2005-02-17 12:02:25.391044008 +0100
-@@ -223,7 +223,8 @@ vis_draw(Widget * w)
- /* FIXME: The check "shouldn't" be neccessary? */
- /* if (GTK_IS_WINDOW(vis->vs_window)) { */
- GDK_THREADS_ENTER();
-- gdk_draw_indexed_image(vis->vs_window, vis->vs_widget.gc,
-+ if (GDK_IS_DRAWABLE(vis->vs_window))
-+ gdk_draw_indexed_image(vis->vs_window, vis->vs_widget.gc,
- vis->vs_widget.x, vis->vs_widget.y,
- vis->vs_widget.width, vis->vs_widget.height,
- GDK_RGB_DITHER_NORMAL, (guchar *) rgb_data,
diff --git a/abs/extra-testing/bmp/0.9.7.1-visualization.patch b/abs/extra-testing/bmp/0.9.7.1-visualization.patch
deleted file mode 100644
index ac03323..0000000
--- a/abs/extra-testing/bmp/0.9.7.1-visualization.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- beep/vis.c 2004-12-04 10:04:29.000000000 +0100
-+++ beep/vis.c 2005-02-17 12:02:25.391044008 +0100
-@@ -223,7 +223,8 @@ vis_draw(Widget * w)
- /* FIXME: The check "shouldn't" be neccessary? */
- /* if (GTK_IS_WINDOW(vis->vs_window)) { */
- GDK_THREADS_ENTER();
-- gdk_draw_indexed_image(vis->vs_window, vis->vs_widget.gc,
-+ if (GDK_IS_DRAWABLE(vis->vs_window))
-+ gdk_draw_indexed_image(vis->vs_window, vis->vs_widget.gc,
- vis->vs_widget.x, vis->vs_widget.y,
- vis->vs_widget.width, vis->vs_widget.height,
- GDK_RGB_DITHER_NORMAL, (guchar *) rgb_data,
diff --git a/abs/extra-testing/bmp/PKGBUILD b/abs/extra-testing/bmp/PKGBUILD
deleted file mode 100644
index ffcc1bf..0000000
--- a/abs/extra-testing/bmp/PKGBUILD
+++ /dev/null
@@ -1,25 +0,0 @@
-# $Id: PKGBUILD 9914 2008-08-21 00:36:16Z eric $
-# Maintainer: Kevin Piche <kevin@archlinux.org>
-# Contributor: Ben <contrasutra@myrealbox.com>
-
-pkgname=bmp
-pkgver=0.9.7.1
-pkgrel=4
-pkgdesc="gtk2 port of xmms"
-arch=(i686 x86_64)
-url="http://bmp.beep-media-player.org/"
-depends=('esd' 'id3lib' 'libglade' 'libsm' 'libvorbis' 'unzip')
-source=(http://voxel.dl.sourceforge.net/sourceforge/beepmp/bmp-$pkgver.tar.gz $pkgver-visualization.patch bmp-${pkgver}-crossfade-0.3.9.patch)
-md5sums=('c25d5a8d49cc5851d13d525a20023c4c' 'fa1bdf5a8d03e8539a6bed5caa471176'\
- '42ad4109ddb66024d4c6d1f3e572ab86')
-
-build() {
- cd $startdir/src/$pkgname-$pkgver
- patch -p0 -i ../${pkgver}-visualization.patch
- patch -p1 -i ../${pkgname}-${pkgver}-crossfade-0.3.9.patch
- ./configure --prefix=/usr
- /usr/bin/make || return 1
- /usr/bin/make DESTDIR=$startdir/pkg install
- find $startdir/pkg -name '*.la' -exec rm {} \;
-}
-# vim: ts=2 sw=2 et ft=sh
diff --git a/abs/extra-testing/bmp/bmp-0.9.7.1-crossfade-0.3.9.patch b/abs/extra-testing/bmp/bmp-0.9.7.1-crossfade-0.3.9.patch
deleted file mode 100644
index 4c1e46d..0000000
--- a/abs/extra-testing/bmp/bmp-0.9.7.1-crossfade-0.3.9.patch
+++ /dev/null
@@ -1,108 +0,0 @@
-Patch taken from xmms-crossfade 3.10 tarball. Required for crossfade to
-work. http://www.eisenlohr.org/xmms-crossfade/
-
-diff -ur bmp-0.9.7.1/beep/mainwin.c bmp-0.9.7.1.patched/beep/mainwin.c
---- bmp-0.9.7.1/beep/mainwin.c 2005-05-09 10:45:39.000000000 +0200
-+++ bmp-0.9.7.1.patched/beep/mainwin.c 2005-11-25 00:03:59.000000000 +0100
-@@ -655,9 +655,11 @@
- mainwin_set_shade(!cfg.player_shaded);
- }
-
-+gboolean is_quitting = FALSE;
- void
- mainwin_quit_cb(void)
- {
-+ is_quitting = TRUE;
- gtk_widget_hide(equalizerwin);
- gtk_widget_hide(playlistwin);
- gtk_widget_hide(mainwin);
-@@ -1318,7 +1320,7 @@
- change_song(guint pos)
- {
- if (bmp_playback_get_playing())
-- bmp_playback_stop();
-+ bmp_playback_stop_for_restart();
-
- playlist_set_position(pos);
- bmp_playback_initiate();
-diff -ur bmp-0.9.7.1/beep/playback.c bmp-0.9.7.1.patched/beep/playback.c
---- bmp-0.9.7.1/beep/playback.c 2005-01-26 06:56:15.000000000 +0100
-+++ bmp-0.9.7.1.patched/beep/playback.c 2005-11-25 00:03:59.000000000 +0100
-@@ -89,7 +89,7 @@
- return;
-
- if (bmp_playback_get_playing())
-- bmp_playback_stop();
-+ bmp_playback_stop_for_restart();
-
- vis_clear_data(mainwin_vis);
- vis_clear_data(playlistwin_vis);
-@@ -135,6 +135,15 @@
- get_current_input_plugin()->pause(ip_data.paused);
- }
-
-+gboolean input_stopped_for_restart = FALSE;
-+void
-+bmp_playback_stop_for_restart(void)
-+{
-+ input_stopped_for_restart = TRUE;
-+ bmp_playback_stop();
-+ input_stopped_for_restart = FALSE;
-+}
-+
- void
- bmp_playback_stop(void)
- {
-diff -ur bmp-0.9.7.1/beep/playback.h bmp-0.9.7.1.patched/beep/playback.h
---- bmp-0.9.7.1/beep/playback.h 2004-12-04 10:04:26.000000000 +0100
-+++ bmp-0.9.7.1.patched/beep/playback.h 2005-11-25 00:03:59.000000000 +0100
-@@ -26,6 +26,7 @@
- void bmp_playback_initiate(void);
- void bmp_playback_pause(void);
- void bmp_playback_stop(void);
-+void bmp_playback_stop_for_restart(void);
- gboolean bmp_playback_play_file(const gchar * filename);
- gboolean bmp_playback_get_playing(void);
- gboolean bmp_playback_get_paused(void);
-diff -ur bmp-0.9.7.1/beep/playlist.c bmp-0.9.7.1.patched/beep/playlist.c
---- bmp-0.9.7.1/beep/playlist.c 2005-08-11 09:25:51.000000000 +0200
-+++ bmp-0.9.7.1.patched/beep/playlist.c 2005-11-25 00:03:59.000000000 +0100
-@@ -817,7 +817,7 @@
- if (bmp_playback_get_playing()) {
- /* We need to stop before changing playlist_position */
- PLAYLIST_UNLOCK();
-- bmp_playback_stop();
-+ bmp_playback_stop_for_restart();
- PLAYLIST_LOCK();
- restart_playing = TRUE;
- }
-@@ -868,7 +868,7 @@
- if (bmp_playback_get_playing()) {
- /* We need to stop before changing playlist_position */
- PLAYLIST_UNLOCK();
-- bmp_playback_stop();
-+ bmp_playback_stop_for_restart();
- PLAYLIST_LOCK();
- restart_playing = TRUE;
- }
-@@ -1018,7 +1018,7 @@
- if (bmp_playback_get_playing()) {
- /* We need to stop before changing playlist_position */
- PLAYLIST_UNLOCK();
-- bmp_playback_stop();
-+ bmp_playback_stop_for_restart();
- PLAYLIST_LOCK();
- restart_playing = TRUE;
- }
-@@ -1047,7 +1047,10 @@
- {
- GList *plist_pos_list;
-
-- bmp_playback_stop();
-+ if (cfg.repeat)
-+ bmp_playback_stop_for_restart();
-+ else
-+ bmp_playback_stop();
-
- PLAYLIST_LOCK();
- plist_pos_list = find_playlist_position_list();