summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/ccache/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/ccache/PKGBUILD')
-rw-r--r--abs/extra-testing/ccache/PKGBUILD35
1 files changed, 0 insertions, 35 deletions
diff --git a/abs/extra-testing/ccache/PKGBUILD b/abs/extra-testing/ccache/PKGBUILD
deleted file mode 100644
index 81f188b..0000000
--- a/abs/extra-testing/ccache/PKGBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# $Id: PKGBUILD 33524 2009-04-04 13:56:15Z giovanni $
-# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
-# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
-
-pkgname=ccache
-pkgver=3.0.1
-pkgrel=1
-pkgdesc="ccache is a compiler cache"
-url="http://ccache.samba.org/"
-source=(http://samba.org/ftp/${pkgname}/$pkgname-$pkgver.tar.gz)
-license=('GPL')
-arch=('i686' 'x86_64')
-depends=('glibc')
-
-build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr
- make || return 1
- install -Dm 755 ccache ${pkgdir}/usr/bin/ccache
- install -Dm 644 ccache.1 ${pkgdir}/usr/share/man/man1/ccache.1
-
- mkdir -p ${pkgdir}/usr/lib/ccache/bin
- ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/cc
- ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/gcc
- ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/g++
- ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/cpp
- ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/c++
- ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/${CHOST}-cc
- ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/${CHOST}-gcc
- ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/${CHOST}-g++
- ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/${CHOST}-cpp
- ln -sf /usr/bin/ccache ${pkgdir}/usr/lib/ccache/bin/${CHOST}-c++
-}
-
-md5sums=('15f2449899d9e8dc3aff6b86f97ab63e')