summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/community/djmount
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/community/djmount')
-rw-r--r--abs/extra-testing/community/djmount/PKGBUILD25
-rw-r--r--abs/extra-testing/community/djmount/djmount.confd2
-rwxr-xr-xabs/extra-testing/community/djmount/djmount.rcd39
3 files changed, 0 insertions, 66 deletions
diff --git a/abs/extra-testing/community/djmount/PKGBUILD b/abs/extra-testing/community/djmount/PKGBUILD
deleted file mode 100644
index a3648dc..0000000
--- a/abs/extra-testing/community/djmount/PKGBUILD
+++ /dev/null
@@ -1,25 +0,0 @@
-# Contributor: Michele Schäuble <mschaeuble@swissonline.ch>
-
-pkgname=djmount
-pkgver=0.71
-pkgrel=1
-pkgdesc="A UPnP AV client that mounts media server contents as a filesystem."
-arch=('i686')
-url="http://djmount.sourceforge.net/"
-license=('GPL')
-depends=('fuse')
-source=(http://voxel.dl.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz \
- djmount.rcd djmount.confd)
-md5sums=('c922753e706c194bf82a8b6ca77e6a9a' \
- 'f473b5150df385447f2f58049bfb6199' \
- '21de4c947c17e8558f1007a20757f254')
-
-build() {
- cd $startdir/src/$pkgname-$pkgver
- ./configure --prefix=/usr
- make || return 1
- make DESTDIR=$startdir/pkg install
-
- install -D -m755 $startdir/src/djmount.rcd $startdir/pkg/etc/rc.d/djmount
- install -D -m644 $startdir/src/djmount.confd $startdir/pkg/etc/conf.d/djmount
-}
diff --git a/abs/extra-testing/community/djmount/djmount.confd b/abs/extra-testing/community/djmount/djmount.confd
deleted file mode 100644
index 079100e..0000000
--- a/abs/extra-testing/community/djmount/djmount.confd
+++ /dev/null
@@ -1,2 +0,0 @@
-OPTIONS="-o ro,allow_other"
-MOUNTPOINT="/media/upnp"
diff --git a/abs/extra-testing/community/djmount/djmount.rcd b/abs/extra-testing/community/djmount/djmount.rcd
deleted file mode 100755
index 84899dd..0000000
--- a/abs/extra-testing/community/djmount/djmount.rcd
+++ /dev/null
@@ -1,39 +0,0 @@
-#!/bin/bash
-
- . /etc/rc.conf
- . /etc/rc.d/functions
-
-# source application-specific settings
-[ -f /etc/conf.d/djmount ] && . /etc/conf.d/djmount
-
- case "$1" in
-
- start)
- stat_busy "Starting djmount"
- /usr/bin/djmount $OPTIONS $MOUNTPOINT &>/dev/null
- if [ $? -ne 0 ]; then
- stat_fail
- else
- add_daemon djmount
- stat_done
- fi
- ;;
-
- stop)
- stat_busy "Stopping djmount"
- fusermount -u $MOUNTPOINT
- kill -9 `pidof /usr/bin/djmount` &>/dev/null
- rm_daemon djmount
- stat_done
- ;;
-
- restart)
- stat_busy "Restarting djmount ..."
- $0 stop
- $0 start
- stat_done
- ;;
-
- *)
- echo "usage: $0 {start|stop|restart}"
- esac