summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/community/firefox
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/community/firefox')
-rw-r--r--abs/extra-testing/community/firefox/PKGBUILD77
-rw-r--r--abs/extra-testing/community/firefox/browser-app-makefile.patch11
-rw-r--r--abs/extra-testing/community/firefox/browser-defaulturls.patch26
-rw-r--r--abs/extra-testing/community/firefox/firefox-safe.desktop11
-rw-r--r--abs/extra-testing/community/firefox/firefox-version.patch11
-rw-r--r--abs/extra-testing/community/firefox/firefox.desktop83
-rw-r--r--abs/extra-testing/community/firefox/firefox.install24
-rw-r--r--abs/extra-testing/community/firefox/mozconfig35
-rw-r--r--abs/extra-testing/community/firefox/mozilla-firefox-1.0-lang.patch12
9 files changed, 0 insertions, 290 deletions
diff --git a/abs/extra-testing/community/firefox/PKGBUILD b/abs/extra-testing/community/firefox/PKGBUILD
deleted file mode 100644
index 17a70b3..0000000
--- a/abs/extra-testing/community/firefox/PKGBUILD
+++ /dev/null
@@ -1,77 +0,0 @@
-# $Id: PKGBUILD 46468 2009-07-18 13:24:45Z jgc $
-# Contributor: Jakub Schmidtke <sjakub@gmail.com>
-
-pkgname=firefox
-pkgver=3.5.1
-pkgrel=4
-_xulver=1.9.1.1
-pkgdesc="Standalone web browser from mozilla.org"
-arch=(i686 x86_64)
-license=('MPL' 'GPL' 'LGPL')
-depends=("xulrunner>=${_xulver}" 'desktop-file-utils' "nspr>=4.8" gconf)
-makedepends=('zip' 'pkgconfig' 'diffutils' 'libgnomeui>=2.24.1' 'python')
-replaces=('firefox3')
-install=firefox.install
-url="http://www.mozilla.org/projects/firefox"
-source=(http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${pkgver}/source/firefox-${pkgver}-source.tar.bz2
- mozconfig
- firefox.desktop
- firefox-safe.desktop
- mozilla-firefox-1.0-lang.patch
- browser-defaulturls.patch
- firefox-version.patch
- browser-app-makefile.patch
- http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz)
-md5sums=('18169e189785d680827d4fce94524449'
- '3c928b11918d22377eba01de34debc19'
- '68cf02788491c6e846729b2f2913bf79'
- '5e68cabfcf3c021806b326f664ac505e'
- 'bd5db57c23c72a02a489592644f18995'
- '346d74ec560e7bbf453c02ff21f4b868'
- '1dd9a10df0b9e4cf332eadc326d78e07'
- '165c43a5b03a0bf7ad2e7210b0d8c82c'
- '6306980e40a3266b4b6c173bfcfdc946')
-
-build() {
- cd "${srcdir}/mozilla-1.9.1"
- patch -Np1 -i "${srcdir}/mozilla-firefox-1.0-lang.patch" || return 1
- patch -Np0 -i "${srcdir}/browser-defaulturls.patch" || return 1
- patch -Np1 -i "${srcdir}/firefox-version.patch" || return 1
-
- cp "${srcdir}/mozconfig" .mozconfig
- unset CFLAGS
- unset CXXFLAGS
-
- export LDFLAGS="-Wl,-rpath,/usr/lib/firefox-3.5"
-
- make -j1 -f client.mk configure MOZ_MAKE_FLAGS="${MAKEFLAGS}" || return 1
- cd browser/app
- patch -p2 < "${srcdir}/browser-app-makefile.patch" || return 1
- cd ../..
- make -j1 -f client.mk build MOZ_MAKE_FLAGS="${MAKEFLAGS}" || return 1
- make -j1 DESTDIR="${pkgdir}" install || return 1
-
- rm -f ${pkgdir}/usr/lib/firefox-3.5/libjemalloc.so
-
- install -m755 -d ${pkgdir}/usr/share/applications
- install -m755 -d ${pkgdir}/usr/share/pixmaps
- install -m644 ${srcdir}/mozilla-1.9.1/browser/branding/unofficial/default48.png ${pkgdir}/usr/share/pixmaps/firefox.png || return 1
- install -m644 ${srcdir}/firefox.desktop ${pkgdir}/usr/share/applications/ || return 1
- install -m644 ${srcdir}/firefox-safe.desktop ${pkgdir}/usr/share/applications/ || return 1
-
- # Install the flash player plugin.
-
- mkdir -p ${pkgdir}/usr/lib/firefox-3.5/plugins
- install -m755 ${srcdir}/libflashplayer.so ${pkgdir}/usr/lib/firefox-3.5/plugins || return 1
-
- # This is to stop firefox from crashing when the flashplayer (youtube) is
- # set to full screen. To test if it is still necessary with updates to
- # this package, run /usr/bin/firefox.bin without setting the LD_PRELOAD var.
-
- mv ${pkgdir}/usr/bin/firefox ${pkgdir}/usr/bin/firefox.bin
- echo "#!/bin/bash
-/usr/lib/GConf/gconfd-2 &
-export LD_PRELOAD=/usr/lib/libGL.so.1
-/usr/bin/firefox.bin" > ${pkgdir}/usr/bin/firefox
- chmod 755 ${pkgdir}/usr/bin/firefox
-}
diff --git a/abs/extra-testing/community/firefox/browser-app-makefile.patch b/abs/extra-testing/community/firefox/browser-app-makefile.patch
deleted file mode 100644
index 9a02c40..0000000
--- a/abs/extra-testing/community/firefox/browser-app-makefile.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- browser/app/Makefile 2009-07-27 22:41:13.000000000 +0930
-+++ browser-new/app/Makefile 2009-07-27 22:42:51.000000000 +0930
-@@ -279,7 +279,7 @@
-
- ifneq (,$(filter-out OS2 WINNT WINCE,$(OS_ARCH)))
-
--$(MOZ_APP_NAME):: $(topsrcdir)/build/unix/mozilla.in $(GLOBAL_DEPS)
-+$(MOZ_APP_NAME): $(topsrcdir)/build/unix/mozilla.in $(GLOBAL_DEPS)
- cat $< | sed -e "s|%MOZAPPDIR%|$(installdir)|" \
- -e "s|%MOZ_APP_DISPLAYNAME%|$(MOZ_APP_DISPLAYNAME)|" > $@
- chmod +x $@
diff --git a/abs/extra-testing/community/firefox/browser-defaulturls.patch b/abs/extra-testing/community/firefox/browser-defaulturls.patch
deleted file mode 100644
index 42a2e1d..0000000
--- a/abs/extra-testing/community/firefox/browser-defaulturls.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- browser/branding/unofficial/locales/browserconfig.properties~ 2009-06-13 17:04:42.000000000 +0200
-+++ browser/branding/unofficial/locales/browserconfig.properties 2009-06-13 17:05:28.000000000 +0200
-@@ -1,3 +1,3 @@
- # Do NOT localize or otherwise change these values
--browser.startup.homepage=http://www.mozilla.org/projects/shiretoko/
-+browser.startup.homepage=http://www.google.com/firefox
-
---- browser/branding/unofficial/pref/firefox-branding.js~ 2009-06-13 16:57:53.000000000 +0200
-+++ browser/branding/unofficial/pref/firefox-branding.js 2009-06-13 16:59:17.000000000 +0200
-@@ -1,5 +1,5 @@
--pref("startup.homepage_override_url","http://www.mozilla.org/projects/%APP%/%VERSION%/whatsnew/");
--pref("startup.homepage_welcome_url","http://www.mozilla.org/projects/%APP%/%VERSION%/firstrun/");
-+pref("startup.homepage_override_url","http://www.mozilla.com/%APP%/%VERSION%/whatsnew/");
-+pref("startup.homepage_welcome_url","http://www.mozilla.com/%APP%/%VERSION%/firstrun/");
- // The time interval between checks for a new version (in seconds)
- // nightly=8 hours, official=24 hours
- pref("app.update.interval", 28800);
-@@ -11,7 +11,7 @@
- pref("app.update.url.details", "http://www.mozilla.org/projects/%APP%/");
-
- // Release notes URL
--pref("app.releaseNotesURL", "http://www.mozilla.org/projects/%APP%/%VERSION%/releasenotes/");
-+pref("app.releaseNotesURL", "http://www.mozilla.com/%APP%/%VERSION%/releasenotes/");
-
- // Search codes belong only in builds with official branding
- pref("browser.search.param.yahoo-fr", "");
diff --git a/abs/extra-testing/community/firefox/firefox-safe.desktop b/abs/extra-testing/community/firefox/firefox-safe.desktop
deleted file mode 100644
index afb4cdb..0000000
--- a/abs/extra-testing/community/firefox/firefox-safe.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Exec=firefox -safe-mode %u
-Icon=firefox
-Type=Application
-Terminal=false
-MultipleArgs=false
-Name=Firefox - Safe Mode
-GenericName=Web Browser - Safe Mode
-StartupNotify=false
-Categories=Application;Network;
diff --git a/abs/extra-testing/community/firefox/firefox-version.patch b/abs/extra-testing/community/firefox/firefox-version.patch
deleted file mode 100644
index b0a4552..0000000
--- a/abs/extra-testing/community/firefox/firefox-version.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- mozilla-1.9.1/browser/installer/Makefile.in.ver 2009-07-18 13:32:35.000000000 +0200
-+++ mozilla-1.9.1/browser/installer/Makefile.in 2009-07-18 13:33:12.000000000 +0200
-@@ -43,6 +43,8 @@
-
- include $(DEPTH)/config/autoconf.mk
-
-+MOZ_APP_VERSION="3.5"
-+
- NO_PKG_FILES = \
- $(MOZ_APP_NAME)-config \
- $(MOZ_APP_NAME)-bin.elf \
diff --git a/abs/extra-testing/community/firefox/firefox.desktop b/abs/extra-testing/community/firefox/firefox.desktop
deleted file mode 100644
index 2a4b678..0000000
--- a/abs/extra-testing/community/firefox/firefox.desktop
+++ /dev/null
@@ -1,83 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Exec=firefox %u
-Icon=firefox
-Type=Application
-Terminal=false
-MultipleArgs=false
-Name=Firefox
-Name[bn]=ফায়ারফক্স3
-Name[eo]=Fajrovulpo3
-Name[fi]=Firefox3
-Name[pa]=ਫਾਇਰਫੋਕਸ3
-Name[tg]=Рӯбоҳи оташин3
-GenericName=Web Browser
-GenericName[af]=Web Blaaier
-GenericName[ar]=متصفح ويب
-GenericName[az]=Veb Səyyahı
-GenericName[bg]=Браузър
-GenericName[bn]=ওয়েব ব্রাউজার
-GenericName[br]=Furcher ar Gwiad
-GenericName[bs]=WWW Preglednik
-GenericName[ca]=Fullejador web
-GenericName[cs]=WWW prohlížeč
-GenericName[cy]=Porydd Gwe
-GenericName[da]=Browser
-GenericName[de]=Web-Browser
-GenericName[el]=Περιηγητής Ιστού
-GenericName[eo]=TTT-legilo
-GenericName[es]=Navegador web
-GenericName[et]=Veebilehitseja
-GenericName[eu]=Web arakatzailea
-GenericName[fa]=مرورگر وب
-GenericName[fi]=WWW-selain
-GenericName[fo]=Alnótsfar
-GenericName[fr]=Navigateur web
-GenericName[gl]=Navegador Web
-GenericName[he]=דפדפן אינטרנט
-GenericName[hi]=वेब ब्राउज़र
-GenericName[hr]=Web preglednik
-GenericName[hu]=Webböngésző
-GenericName[is]=Vafri
-GenericName[it]=Browser Web
-GenericName[ja]=ウェブブラウザ
-GenericName[ko]=웹 브라우저
-GenericName[lo]=ເວັບບຣາວເຊີ
-GenericName[lt]=Žiniatinklio naršyklė
-GenericName[lv]=Web Pārlūks
-GenericName[mk]=Прелистувач на Интернет
-GenericName[mn]=Веб-Хөтөч
-GenericName[nb]=Nettleser
-GenericName[nds]=Nettkieker
-GenericName[nl]=Webbrowser
-GenericName[nn]=Nettlesar
-GenericName[nso]=Seinyakisi sa Web
-GenericName[pa]=ਵੈਬ ਝਲਕਾਰਾ
-GenericName[pl]=Przeglądarka WWW
-GenericName[pt]=Navegador Web
-GenericName[pt_BR]=Navegador Web
-GenericName[ro]=Navigator de web
-GenericName[ru]=Веб-браузер
-GenericName[se]=Fierpmádatlogan
-GenericName[sk]=Webový prehliadač
-GenericName[sl]=Spletni brskalnik
-GenericName[sr]=Веб претраживач
-GenericName[sr@Latn]=Veb pretraživač
-GenericName[ss]=Ibrawuza yeWeb
-GenericName[sv]=Webbläsare
-GenericName[ta]=வலை உலாவி
-GenericName[tg]=Тафсиргари вэб
-GenericName[th]=เว็บบราวเซอร์
-GenericName[tr]=Web Tarayıcı
-GenericName[uk]=Навігатор Тенет
-GenericName[uz]=Веб-браузер
-GenericName[ven]=Buronza ya Webu
-GenericName[vi]=Trình duyệt Web
-GenericName[wa]=Betchteu waibe
-GenericName[xh]=Umkhangeli zincwadi we Web
-GenericName[zh_CN]=网页浏览器
-GenericName[zh_TW]=網頁瀏覽器
-GenericName[zu]=Umcingi we-Web
-MimeType=text/html
-StartupNotify=true
-Categories=Application;Network;
diff --git a/abs/extra-testing/community/firefox/firefox.install b/abs/extra-testing/community/firefox/firefox.install
deleted file mode 100644
index cd50dec..0000000
--- a/abs/extra-testing/community/firefox/firefox.install
+++ /dev/null
@@ -1,24 +0,0 @@
-post_install() {
- update-desktop-database -q
-
- # For LinHES: check for a fluxbox keys file that doesnt have a mapping
- # for Alt-w and map it to firefox.
-
- if [ -e /home/mythtv/.fluxbox/keys ]
- then
- if ! grep -q "Mod1 w" /home/mythtv/.fluxbox/keys
- then
- echo Adding fluxbox key for firefox.
- echo "Mod1 w :ExecCommand firefox" >> /home/mythtv/.fluxbox/keys
- fi
- fi
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- update-desktop-database -q
-}
-
diff --git a/abs/extra-testing/community/firefox/mozconfig b/abs/extra-testing/community/firefox/mozconfig
deleted file mode 100644
index 030317d..0000000
--- a/abs/extra-testing/community/firefox/mozconfig
+++ /dev/null
@@ -1,35 +0,0 @@
-. $topsrcdir/browser/config/mozconfig
-
-ac_add_options --prefix=/usr
-ac_add_options --libdir=/usr/lib
-ac_add_options --with-system-nspr
-ac_add_options --with-system-nss
-ac_add_options --with-system-jpeg
-ac_add_options --with-system-zlib
-ac_add_options --with-system-png
-ac_add_options --with-pthreads
-ac_add_options --disable-tests
-ac_add_options --disable-debug
-ac_add_options --enable-optimize
-ac_add_options --disable-installer
-ac_add_options --enable-xinerama
-ac_add_options --enable-default-toolkit=cairo-gtk2
-ac_add_options --disable-xprint
-ac_add_options --enable-strip
-ac_add_options --enable-pango
-ac_add_options --enable-system-cairo
-ac_add_options --enable-svg
-ac_add_options --enable-canvas
-ac_add_options --enable-startup-notification
-ac_add_options --enable-libxul
-ac_add_options --disable-crashreporter
-ac_add_options --with-libxul-sdk=/usr/lib/xulrunner-devel-1.9.1.1
-ac_add_options --enable-safe-browsing
-ac_add_options --with-branding=browser/branding/unofficial
-
-export BUILD_OFFICIAL=1
-export MOZILLA_OFFICIAL=1
-export USE_SHORT_LIBNAME=1
-mk_add_options BUILD_OFFICIAL=1
-mk_add_options MOZILLA_OFFICIAL=1
-mk_add_options USE_SHORT_LIBNAME=1
diff --git a/abs/extra-testing/community/firefox/mozilla-firefox-1.0-lang.patch b/abs/extra-testing/community/firefox/mozilla-firefox-1.0-lang.patch
deleted file mode 100644
index f0f7325..0000000
--- a/abs/extra-testing/community/firefox/mozilla-firefox-1.0-lang.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- mozilla/browser/app/profile/firefox.js.lang 2005-01-13 15:32:03.509282726 +0100
-+++ mozilla/browser/app/profile/firefox.js 2005-01-13 15:33:40.220914789 +0100
-@@ -253,6 +253,9 @@
- pref("font.language.group", "chrome://global/locale/intl.properties");
- pref("intl.menuitems.alwaysappendaccesskeys","chrome://global/locale/intl.properties");
-
-+// Use LANG environment variable to choose locale
-+pref("intl.locale.matchOS", true);
-+
- // 0=lines, 1=pages, 2=history , 3=text size
- pref("mousewheel.withcontrolkey.action",3);
- pref("mousewheel.withshiftkey.action",2);