summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/community/xine-lib-vdpau-svn/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/community/xine-lib-vdpau-svn/PKGBUILD')
-rw-r--r--abs/extra-testing/community/xine-lib-vdpau-svn/PKGBUILD47
1 files changed, 0 insertions, 47 deletions
diff --git a/abs/extra-testing/community/xine-lib-vdpau-svn/PKGBUILD b/abs/extra-testing/community/xine-lib-vdpau-svn/PKGBUILD
deleted file mode 100644
index 2d1e887..0000000
--- a/abs/extra-testing/community/xine-lib-vdpau-svn/PKGBUILD
+++ /dev/null
@@ -1,47 +0,0 @@
-# Contributor: Dennis Brendel <buddabrod@gmail.com>
-pkgname=xine-lib-vdpau-svn
-pkgver=222
-pkgrel=2
-pkgdesc="A free video player library for Unix with support for vdpau"
-arch=('i686' 'x86_64')
-url="http://xinehq.de/"
-license=('GPL')
-depends=('libxvmc' 'esound' 'flac>=1.1.4' 'libvorbis' 'sdl' 'libmng' 'libtheora' 'libxcb' 'wavpack' 'ffmpeg>=20080715' 'heimdal>=1.2.1' 'nvidia-utils>=180.22' 'nvidia>=180.22')
-optdepends=('codecs')
-makedepends=('subversion' 'pkgconfig' 'libtool' 'imagemagick' 'smbclient' 'mesa' 'alsa-lib' 'vcdimager' 'jack-audio-connection-kit' 'cvs')
-conflicts=('xine-lib')
-provides=('xine-lib=1.1.16.1' 'xine-lib')
-
-_svntrunk=svn://jusst.de/xine-vdpau
-_svnmod=xine-vdpau
-
-build() {
-
- cd ${srcdir}
-
- if [ -d $_svnmod/.svn ]; then
- (cd $_svnmod && svn up -r $pkgver)
- else
- svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
- fi
-
- msg "SVN checkout done or server timeout"
- msg "Starting make..."
-
- cp -r $_svnmod $_svnmod-build
- cd $_svnmod-build
-
- unset CFLAGS
-
- ./autogen.sh --prefix=/usr --with-w32-path=/usr/lib/codecs \
- --with-xv-path=/usr/lib --with-xxmc-path=/usr/lib --with-xvmc-path=/usr/lib \
- --with-libflac --with-wavpack --with-xcb \
- --without-arts --with-jack --without-speex \
- --disable-gnomevfs --without-pulseaudio --disable-aalib \
- --disable-modplug --with-external-ffmpeg || return 1
-
- make || return 1
- make DESTDIR=$pkgdir install || return 1
-
- rm -rf ${srcdir}/${_svnmod}-build
-}