summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/cpufreqd
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/cpufreqd')
-rw-r--r--abs/extra-testing/cpufreqd/PKGBUILD30
-rw-r--r--abs/extra-testing/cpufreqd/cpufreqd35
-rw-r--r--abs/extra-testing/cpufreqd/cpufreqd.install26
3 files changed, 0 insertions, 91 deletions
diff --git a/abs/extra-testing/cpufreqd/PKGBUILD b/abs/extra-testing/cpufreqd/PKGBUILD
deleted file mode 100644
index fd6d544..0000000
--- a/abs/extra-testing/cpufreqd/PKGBUILD
+++ /dev/null
@@ -1,30 +0,0 @@
-# $Id: PKGBUILD 60269 2009-12-02 16:30:29Z giovanni $
-# Maintainer: Andrea Scarpino <andrea@archlinux.org>
-# Contributor: Kevin Piche <kevin@archlinux.org>
-# Contributor: Manolis Tzanidakis <manolis@archlinux.org>
-
-pkgname=cpufreqd
-pkgver=2.4.2
-pkgrel=1
-pkgdesc="A small daemon to adjust cpu speed (and indeed voltage)"
-arch=('i686' 'x86_64')
-url="http://sourceforge.net/projects/cpufreqd"
-license=('GPL2')
-depends=('cpufrequtils')
-install="$pkgname.install"
-backup=(etc/cpufreqd.conf)
-options=('!libtool')
-source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2
- 'cpufreqd')
-
-build() {
- cd $srcdir/$pkgname-$pkgver
- ./configure --prefix=/usr \
- --sysconfdir=/etc
- make || return 1
- make DESTDIR=$pkgdir install
-
- install -D -m 755 $srcdir/cpufreqd $pkgdir/etc/rc.d/cpufreqd || return 1
-}
-md5sums=('2ca80a77849c9a69b81e27c1843c97f5'
- 'ae7b0ec1e8e9f9e7f05fb83749af4ed4')
diff --git a/abs/extra-testing/cpufreqd/cpufreqd b/abs/extra-testing/cpufreqd/cpufreqd
deleted file mode 100644
index af55456..0000000
--- a/abs/extra-testing/cpufreqd/cpufreqd
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/bin/bash
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-PID=`pidof -o %PPID /usr/sbin/cpufreqd`
-case "$1" in
- start)
- stat_busy "Starting cpufreqd"
- [ -z "$PID" ] && /usr/sbin/cpufreqd
- if [ $? -gt 0 ]; then
- stat_fail
- else
- add_daemon cpufreqd
- stat_done
- fi
- ;;
- stop)
- stat_busy "Stopping cpufreqd"
- [ ! -z "$PID" ] && kill $PID &> /dev/null
- if [ $? -gt 0 ]; then
- stat_fail
- else
- rm_daemon cpufreqd
- stat_done
- fi
- ;;
- restart)
- $0 stop
- $0 start
- ;;
- *)
- echo "usage: $0 {start|stop|restart}"
-esac
-exit 0
diff --git a/abs/extra-testing/cpufreqd/cpufreqd.install b/abs/extra-testing/cpufreqd/cpufreqd.install
deleted file mode 100644
index e56ce57..0000000
--- a/abs/extra-testing/cpufreqd/cpufreqd.install
+++ /dev/null
@@ -1,26 +0,0 @@
-post_install() {
- cat << EOF
-
-NOTE
-----
-In order to use that daemon you need to either patch your
-kernel-2.4.x with cpufreq patch (check
-http://www.codemonkey.org.uk/projects/cpufreq/),
-or use kernel-2.6.x or 2.4.x.-ac.
-
-EOF
-}
-
-post_upgrade() {
- /bin/true
-}
-
-# arg 1: the old package version
-pre_remove() {
- /bin/true
-}
-
-op=$1
-shift
-
-$op $*