summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/evtest
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/evtest')
-rw-r--r--abs/extra-testing/evtest/PKGBUILD24
-rw-r--r--abs/extra-testing/evtest/evtest.diff32
2 files changed, 0 insertions, 56 deletions
diff --git a/abs/extra-testing/evtest/PKGBUILD b/abs/extra-testing/evtest/PKGBUILD
deleted file mode 100644
index 0952c5e..0000000
--- a/abs/extra-testing/evtest/PKGBUILD
+++ /dev/null
@@ -1,24 +0,0 @@
-# Contributor: Andrej Gelenberg <andrej.gelenberg@udo.edu>
-pkgname=evtest
-pkgver=1.25
-pkgrel=2
-pkgdesc="Simple tool for input event debugging."
-arch=('i686' 'x86_64')
-url="http://cgit.freedesktop.org/~whot/evtest/"
-license=('GPL')
-depends=(libxml2)
-makedepends=(xmlto asciidoc)
-optdepends=(libxslt)
-source=("http://cgit.freedesktop.org/~whot/evtest/snapshot/$pkgname-$pkgver.zip" "evtest.diff")
-
-build()
-{
- cd $srcdir/$pkgname-$pkgver
- patch -p1 < ../evtest.diff || return 1
- autoreconf -iv
- ./configure --prefix=/usr
- make || return 1
- make DESTDIR=${startdir}/pkg install
-}
-md5sums=('1edddfcd366bb52490e08cbf1dbaeddf'
- '1753bd5825ca7e5244a1a09029b8a47d')
diff --git a/abs/extra-testing/evtest/evtest.diff b/abs/extra-testing/evtest/evtest.diff
deleted file mode 100644
index 0dc7ba5..0000000
--- a/abs/extra-testing/evtest/evtest.diff
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -ruaN evtest-1.25.orig/evtest-capture.c evtest-1.25/evtest-capture.c
---- evtest-1.25.orig/evtest-capture.c 2009-12-02 22:24:44.000000000 +0000
-+++ evtest-1.25/evtest-capture.c 2010-05-06 08:38:03.000000000 +0000
-@@ -560,16 +560,6 @@
- [ABS_TOOL_WIDTH] = "ABS_TOOL_WIDTH",
- [ABS_VOLUME] = "ABS_VOLUME",
- [ABS_MISC] = "ABS_MISC",
-- [ABS_MT_TOUCH_MAJOR] = "ABS_MT_TOUCH_MAJOR",
-- [ABS_MT_TOUCH_MINOR] = "ABS_MT_TOUCH_MINOR",
-- [ABS_MT_WIDTH_MAJOR] = "ABS_MT_WIDTH_MAJOR",
-- [ABS_MT_WIDTH_MINOR] = "ABS_MT_WIDTH_MINOR",
-- [ABS_MT_ORIENTATION] = "ABS_MT_ORIENTATION",
-- [ABS_MT_POSITION_X] = "ABS_MT_POSITION_X",
-- [ABS_MT_POSITION_Y] = "ABS_MT_POSITION_Y",
-- [ABS_MT_TOOL_TYPE] = "ABS_MT_TOOL_TYPE",
-- [ABS_MT_BLOB_ID] = "ABS_MT_BLOB_ID",
-- [ABS_MT_TRACKING_ID] = "ABS_MT_TRACKING_ID",
- };
-
- const char *misc[MSC_MAX + 1] = {
-diff -ruaN evtest-1.25.orig/evtest.c evtest-1.25/evtest.c
---- evtest-1.25.orig/evtest.c 2009-12-02 22:24:44.000000000 +0000
-+++ evtest-1.25/evtest.c 2010-05-06 08:38:21.000000000 +0000
-@@ -192,7 +192,7 @@
- [BTN_TOOL_MOUSE] = "ToolMouse", [BTN_TOOL_LENS] = "ToolLens",
- [BTN_TOUCH] = "Touch", [BTN_STYLUS] = "Stylus",
- [BTN_STYLUS2] = "Stylus2", [BTN_TOOL_DOUBLETAP] = "Tool Doubletap",
-- [BTN_TOOL_TRIPLETAP] = "Tool Tripletap", [BTN_TOOL_QUADTAP] = "Tool Quadtap",
-+ [BTN_TOOL_TRIPLETAP] = "Tool Tripletap",
- [BTN_GEAR_DOWN] = "WheelBtn",
- [BTN_GEAR_UP] = "Gear up", [KEY_OK] = "Ok",
- [KEY_SELECT] = "Select", [KEY_GOTO] = "Goto",