summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/fakeroot
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/fakeroot')
-rw-r--r--abs/extra-testing/fakeroot/PKGBUILD28
-rw-r--r--abs/extra-testing/fakeroot/fakeroot.install30
2 files changed, 0 insertions, 58 deletions
diff --git a/abs/extra-testing/fakeroot/PKGBUILD b/abs/extra-testing/fakeroot/PKGBUILD
deleted file mode 100644
index 688c3d3..0000000
--- a/abs/extra-testing/fakeroot/PKGBUILD
+++ /dev/null
@@ -1,28 +0,0 @@
-# $Id: PKGBUILD 29508 2009-03-09 17:06:43Z andyrtr $
-# Maintainer: Andreas Radke <andyrtr@archlinux.org>
-# Contributor: Jochem Kossen <j.kossen@home.nl>
-
-pkgname=fakeroot
-pkgver=1.14.4
-pkgrel=1
-pkgdesc="Gives a fake root environment, useful for building packages as a non-privileged user"
-arch=('i686' 'x86_64')
-license=('GPL')
-url="http://packages.debian.org/fakeroot"
-groups=('base-devel')
-install=fakeroot.install
-depends=('glibc' 'filesystem' 'grep' 'sed')
-options=('!libtool')
-source=(http://ftp.debian.org/debian/pool/main/f/$pkgname/${pkgname}_${pkgver}.orig.tar.bz2)
-
-build() {
- cd ${srcdir}/$pkgname-$pkgver
- ./configure --prefix=/usr --libdir=/usr/lib/libfakeroot \
- --disable-static --with-ipc=sysv
- # --with-ipc=tcp is currently broken and no option on smp systems
- make || return 1
- make DESTDIR=${pkgdir} install || return 1
- # install README for sysv/tcp usage
- install -Dm644 $srcdir/$pkgname-$pkgver/README $pkgdir/usr/share/doc/$pkgname/README
-}
-md5sums=('bea628be77838aaa7323a2f7601c2d7e')
diff --git a/abs/extra-testing/fakeroot/fakeroot.install b/abs/extra-testing/fakeroot/fakeroot.install
deleted file mode 100644
index c2f62a7..0000000
--- a/abs/extra-testing/fakeroot/fakeroot.install
+++ /dev/null
@@ -1,30 +0,0 @@
-# arg 1: the new package version
-post_install() {
- if [ ! "`grep /usr/lib/libfakeroot etc/ld.so.conf`" ]; then
- echo -n "updating /etc/ld.so.conf... "
- echo "/usr/lib/libfakeroot" >>etc/ld.so.conf
- sbin/ldconfig -r .
- echo "done."
- fi
-echo "The package is built using sysv ipc. If this causes segfaults"
-echo "see included README file and rebuild the pkg --with-ipc=tcp"
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- post_install $1
-}
-
-# arg 1: the old package version
-pre_remove() {
- echo -ne "\nupdating /etc/ld.so.conf... "
- sed -i -e '/\/usr\/lib\/libfakeroot/d' etc/ld.so.conf
- sbin/ldconfig -r .
- echo "done."
-}
-
-op=$1
-shift
-
-$op $*