summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/gpac/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/gpac/PKGBUILD')
-rwxr-xr-xabs/extra-testing/gpac/PKGBUILD27
1 files changed, 0 insertions, 27 deletions
diff --git a/abs/extra-testing/gpac/PKGBUILD b/abs/extra-testing/gpac/PKGBUILD
deleted file mode 100755
index 04ce3cc..0000000
--- a/abs/extra-testing/gpac/PKGBUILD
+++ /dev/null
@@ -1,27 +0,0 @@
-# $Id: PKGBUILD,v 1.4 2009/04/19 08:06:33 allan Exp $
-# Maintainer: Allan McRae <allan@archlinux.org>
-# Contributor: niQo
-
-pkgname=gpac
-pkgver=0.4.5
-pkgrel=4
-pkgdesc="A multimedia framework based on the MPEG-4 Systems standard"
-arch=('i686' 'x86_64')
-url="http://gpac.sourceforge.net"
-depends=('libxml2' 'wxgtk' 'alsa-lib' 'sdl' 'spidermonkey' 'libmad' \
- 'faad2' 'xvidcore' 'ffmpeg' 'freeglut' 'libjpeg')
-license=('LGPL')
-source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz)
-md5sums=('755e8c438a48ebdb13525dd491f5b0d1')
-
-build() {
- cd "${srcdir}/${pkgname}"
- chmod +x configure
- sed -i 's#osmozilla##g' applications/Makefile
- sed -i 's#"$(prefix)#"$(DESTDIR)$(prefix)#' applications/osmo4_wx/Makefile
- sed -i 's#ldconfig || true##g' Makefile
- ./configure --prefix=/usr --mandir=/usr/share/man --use-js=no
- make || return 1
- make DESTDIR=${pkgdir}/ install-lib
- make DESTDIR=${pkgdir}/ install
-}