summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/ladspa
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/ladspa')
-rw-r--r--abs/extra-testing/ladspa/PKGBUILD25
-rw-r--r--abs/extra-testing/ladspa/hardcode-path.patch28
2 files changed, 0 insertions, 53 deletions
diff --git a/abs/extra-testing/ladspa/PKGBUILD b/abs/extra-testing/ladspa/PKGBUILD
deleted file mode 100644
index c734ca0..0000000
--- a/abs/extra-testing/ladspa/PKGBUILD
+++ /dev/null
@@ -1,25 +0,0 @@
-# $Id: PKGBUILD 18545 2008-11-06 23:58:57Z jgc $
-# Maintainer: damir <damir@archlinux.org>
-
-pkgname=ladspa
-pkgver=1.13
-pkgrel=2
-pkgdesc="Linux Audio Developer's Simple Plugin API (LADSPA)"
-arch=("i686" "x86_64")
-license=('LGPL')
-url="http://www.ladspa.org/"
-depends=('gcc-libs>=4.3')
-source=(http://www.ladspa.org/download/${pkgname}_sdk_${pkgver}.tgz
- hardcode-path.patch)
-md5sums=('671be3e1021d0722cadc7fb27054628e'
- '27743258232d828575d66940e6de2858')
-
-build() {
- cd "${srcdir}/${pkgname}_sdk/src"
- patch -Np1 -i "${srcdir}/hardcode-path.patch" || return 1
- sed -i -e 's/mkdirhier/mkdir -p/' makefile || return 1
- make targets || return 1
- make INSTALL_PLUGINS_DIR="${pkgdir}/usr/lib/ladspa/" \
- INSTALL_INCLUDE_DIR="${pkgdir}/usr/include/" \
- INSTALL_BINARY_DIR="${pkgdir}/usr/bin/" install || return 1
-}
diff --git a/abs/extra-testing/ladspa/hardcode-path.patch b/abs/extra-testing/ladspa/hardcode-path.patch
deleted file mode 100644
index 821c200..0000000
--- a/abs/extra-testing/ladspa/hardcode-path.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/search.c.orig 2008-11-07 00:38:18.000000000 +0100
-+++ src/search.c 2008-11-07 00:50:51.000000000 +0100
-@@ -83,6 +83,8 @@
- dlclose(pcFilename);
- free(pcFilename);
- }
-+ } else {
-+ free(pcFilename);
- }
- }
- }
-@@ -99,13 +101,10 @@
-
- pcLADSPAPath = getenv("LADSPA_PATH");
- if (!pcLADSPAPath) {
-- fprintf(stderr,
-- "Warning: You do not have a LADSPA_PATH "
-- "environment variable set.\n");
-- return;
-+ pcStart = "/usr/lib/ladspa/";
-+ } else {
-+ pcStart = pcLADSPAPath;
- }
--
-- pcStart = pcLADSPAPath;
- while (*pcStart != '\0') {
- pcEnd = pcStart;
- while (*pcEnd != ':' && *pcEnd != '\0')