summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/libpng
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/libpng')
-rw-r--r--abs/extra-testing/libpng/ChangeLog55
-rw-r--r--abs/extra-testing/libpng/PKGBUILD42
2 files changed, 97 insertions, 0 deletions
diff --git a/abs/extra-testing/libpng/ChangeLog b/abs/extra-testing/libpng/ChangeLog
new file mode 100644
index 0000000..98aa66d
--- /dev/null
+++ b/abs/extra-testing/libpng/ChangeLog
@@ -0,0 +1,55 @@
+
+2008-10-06 Douglas Soares de Andrade <douglas@archlinux.org>
+
+ * Updated for i686: 1.2.32
+
+2008-08-23 Douglas Soares de Andrade <douglas@archlinux.org>
+
+ * Updated for i686: 1.2.31
+ * Thanks to Hussam Al-Tayeb
+
+2008-08-17 Douglas Soares de Andrade <douglas@archlinux.org>
+
+ * Had to return to 1.2.29 because xul depends on
+ png with apng patch
+
+2008-08-17 Douglas Soares de Andrade <douglas@archlinux.org>
+
+ * Updated for i686: 1.2.30
+ * Fixes some security issues
+ * Remove the apng patch as there was no compatible version
+ for this version
+
+2008-07-04 Douglas Soares de Andrade <douglas@archlinux.org>
+
+ * Updated for i686 - 1.2.29-1
+ * Updated the apng patch for 1.2.29
+
+2008-05-06 Travis Willard <travis@archlinux.org>
+
+ * 1.2.28-1
+ Upstream update
+ Uses same APNG patchset as 1.2.27
+
+2008-05-01 Jan de Groot <jgc@archlinux.org>
+
+ * 1.2.27-1
+ Upstream update (security update!)
+ Fix APNG patchset to apply to 1.2.27
+ Fix build with newer libtool versions
+
+2008-03-12 Travis Willard <travis@archlinux.org>
+
+ * 1.2.25-1
+ Upstream update
+
+2008-02-18 Travis Willard <travis@archlinux.org>
+
+ * 1.2.24-3
+ Corrected ChangeLog
+
+2008-02-18 Travis Willard <travis@archlinux.org>
+
+ * 1.2.24-2
+ Added ChangeLog
+ Added APNG patchset from <http://littlesvr.ca/apng/>
diff --git a/abs/extra-testing/libpng/PKGBUILD b/abs/extra-testing/libpng/PKGBUILD
new file mode 100644
index 0000000..12515ed
--- /dev/null
+++ b/abs/extra-testing/libpng/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id: PKGBUILD 22148 2008-12-22 12:33:23Z pierre $
+# Maintainer: dorphell <dorphell@archlinux.org>
+# Maintainer: Travis Willard <travis@archlinux.org>
+# Maintainer: Douglas Soares de Andrade <douglas@archlinux.org>
+
+pkgname=libpng
+pkgver=1.2.34
+pkgrel=1
+pkgdesc="A collection of routines used to create PNG format graphics files"
+arch=('i686' 'x86_64')
+url="http://www.libpng.org/pub/png/libpng.html"
+license=('custom')
+depends=('zlib')
+options=('!libtool')
+source=("http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
+ "http://hp.vector.co.jp/authors/VA013651/lib/libpng-${pkgver}-apng.patch.gz")
+options=('!libtool')
+md5sums=('37362876feb21344fd3af1228527db0f'
+ 'a7ee9fd9af34692b75eedd5b03b69ca9')
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+
+ # Add animated PNG (apng) support
+ # see http://hp.vector.co.jp/authors/VA013651/freeSoftware/apng.html
+ patch -p1 -i $srcdir/libpng-${pkgver}-apng.patch || return 1
+
+ libtoolize --force --copy || return 1
+ aclocal || return 1
+ autoconf || return 1
+ automake --add-missing || return 1
+
+ ./configure --prefix=/usr || return 1
+ make ECHO=echo || return 1
+ make ECHO=echo DESTDIR=${startdir}/pkg install || return 1
+
+ cd contrib/pngminus
+ make ECHO=echo PNGLIB="-L${startdir}/pkg/usr/lib -lpng" -f makefile.std png2pnm pnm2png
+ install -m755 png2pnm pnm2png ${startdir}/pkg/usr/bin/
+ install -m755 -d ${startdir}/pkg/usr/share/licenses/${pkgname}
+ install -m644 ../../LICENSE ${startdir}/pkg/usr/share/licenses/${pkgname}/ || return 1
+}