summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/monitorix
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/monitorix')
-rw-r--r--abs/extra-testing/monitorix/PKGBUILD58
-rw-r--r--abs/extra-testing/monitorix/monitorix.install30
-rw-r--r--abs/extra-testing/monitorix/monitorix.rc.d54
3 files changed, 0 insertions, 142 deletions
diff --git a/abs/extra-testing/monitorix/PKGBUILD b/abs/extra-testing/monitorix/PKGBUILD
deleted file mode 100644
index e73fcd1..0000000
--- a/abs/extra-testing/monitorix/PKGBUILD
+++ /dev/null
@@ -1,58 +0,0 @@
-# Maintainer: graysky <da_audiophile yahoo>
-
-pkgname=monitorix
-pkgver=1.4.2
-pkgrel=8
-pkgdesc='A lightweight system monitoring tool that uses rrd databases.'
-arch=(i686)
-url=http://www.$pkgname.org/
-license=(GPL)
-depends=(dcron rrdtool lighttpd )
-optdepends=('lm_sensors: enable support for system temp monitoring'
-'hddtemp: enable support for hdd temp monitoring')
-
-backup=(etc/$pkgname.conf)
-source=($url$pkgname-$pkgver.tar.gz
- monitorix.rc.d)
-md5sums=('6db1bdbeeb0d128622590dfecb9694e4'
-'34e7cb2d78bb4e3ece4aeb4ed26a0d43')
-install=('monitorix.install')
-
-build() {
- cd $pkgname-$pkgver
-
- install -D $pkgname.pl $pkgdir/usr/sbin/$pkgname.pl
- install -D ../$pkgname.rc.d $pkgdir/etc/rc.d/$pkgname
-
-# use LinHES defaults
- sed -e '/^our $OSTYPE/ s,RHFC,Arch,' \
- -e '/^our $TITLE/ s,FIBRANET NSP\, SL,LinHES,' \
- -e '/^our @HDDTEMP_LIST/ s,hda,sda,' \
- -e '/^our $ENABLE_CROND_MAIL/ s,Y,N,' \
- -e '/^our $ENABLE_SERVU/ s,Y,N,' \
- -e '/^our $ENABLE_PORT/ s,Y,N,' \
- -e '/^our $ENABLE_USER/ s,Y,N,' \
- -e '/^our $ENABLE_INT/ s,Y,N,' \
- -e '/^our @HDDTEMP_LIST/ s,hda,sda,' \
- -e '/^our @MNT_LIST/ s,boot,myth,' \
- -e '/^\s*"Linux-Arch"/ s,/var/log/httpd/access.log,/var/log/httpd/access_log,' \
- -e '/^\s*"Linux-Arch"/ s,/var/log/secure,/var/log/auth.log,' \
- -e '/^\s*"Linux-Arch"/ s,/srv/http,/data/srv/httpd/htdocs,' < $pkgname.conf \
- > $pkgdir/etc/$pkgname.conf
-
- mkdir -p $pkgdir/var/lib/$pkgname/usage
- cp -r reports $pkgdir/var/lib/$pkgname
-
- mkdir -p $pkgdir/usr/share/doc/$pkgname
- cp Changes $pkgname-apache.conf $pkgname-alert.sh README README.nginx TODO \
- $pkgdir/usr/share/doc/$pkgname
-
- install -dm777 $pkgdir/data/srv/httpd/htdocs/$pkgname/imgs
- cp {logo_bot,logo_top,${pkgname}ico}.png $pkgdir/data/srv/httpd/htdocs/$pkgname
-
- install -D $pkgname.cgi $pkgdir/data/srv/httpd/htdocs/cgi-bin/$pkgname.cgi
-
- gzip -9 man/man5/$pkgname.conf.5
- install -Dm644 man/man5/$pkgname.conf.5.gz $pkgdir/usr/share/man/man5/$pkgname.conf.5.gz
-}
-
diff --git a/abs/extra-testing/monitorix/monitorix.install b/abs/extra-testing/monitorix/monitorix.install
deleted file mode 100644
index 6c1d1bd..0000000
--- a/abs/extra-testing/monitorix/monitorix.install
+++ /dev/null
@@ -1,30 +0,0 @@
-remove_notes() {
- echo '----------------------------------------------------------------------'
- echo 'To remove all traces of monitorix from your system, you must manually'
- echo 'remove the following dir trees (doing so will delete your databases):'
- echo
- echo '/var/lib/monitorix'
- echo '/srv/http/monitorix'
- echo '----------------------------------------------------------------------'
-}
-
-# $1: The new package version
-# $2: The old package version
-post_upgrade() {
- echo ''
- echo ''
- echo 'now edit /etc/monitorix.conf'
- echo ' our $HOSTNAME - your hostname.'
- echo ' our $ENABLE_LMTEMP - switch this on if you wanna log your temps.'
- echo ' our @HDDTEMP_LIST - If you system has more than one hdd, add it to the array.'
- echo ' stats can be seen at http://$THIS_SYSTEMS_IP/monitorix/'
-
- echo ''
- echo ''
-}
-
-post_install(){
- . /etc/systemconfig
- sed -i "s/^our \$HOSTNAME.*$/our \$HOSTNAME = \"${hostname}\"\; /" /etc/monitorix.conf|
- post_upgrade
-}
diff --git a/abs/extra-testing/monitorix/monitorix.rc.d b/abs/extra-testing/monitorix/monitorix.rc.d
deleted file mode 100644
index 9649519..0000000
--- a/abs/extra-testing/monitorix/monitorix.rc.d
+++ /dev/null
@@ -1,54 +0,0 @@
-#!/bin/bash
-#
-# @(#) Fibranet NSP, SL
-# Copyright (C) 2005-2009 by Jordi Sanfeliu <jordi@fibranet.cat>
-#
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-case $1 in
- start)
- stat_busy "Starting Monitorix"
- if ck_daemon monitorix; then
- if [ -x /etc/cron.hourly/sync-monitorix.sh ]; then
- /etc/cron.hourly/sync-monitorix.sh >/dev/null 2>&1
- fi
- # Creates RRDs files if needed
- /usr/sbin/monitorix.pl create >/dev/null 2>&1 || stat_die $?
- /usr/sbin/monitorix.pl init >/dev/null 2>&1 || stat_die $?
- add_daemon monitorix
- # restart crond so data gets collected
- /sbin/sv restart cron
- stat_done
- else
- stat_fail
- fi
- ;;
-
- stop)
- stat_busy "Stopping Monitorix"
- if ! ck_daemon monitorix; then
- if [ -x /etc/cron.hourly/sync-monitorix.sh ]; then
- /etc/cron.hourly/sync-monitorix.sh >/dev/null 2>&1
- fi
- /usr/sbin/monitorix.pl stop 2>&1 || stat_die $?
- rm_daemon monitorix
- # restart crond data stops getting collected
- /sbin/sv restart cron
- stat_done
- else
- stat_fail
- fi
- ;;
-
- restart)
- $0 stop
- sleep 1
- $0 start
- ;;
- *)
- echo "usage: $0 {start|stop|restart}"
- ;;
-esac
-
-exit 0