summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/sip/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/sip/PKGBUILD')
-rw-r--r--abs/extra-testing/sip/PKGBUILD29
1 files changed, 0 insertions, 29 deletions
diff --git a/abs/extra-testing/sip/PKGBUILD b/abs/extra-testing/sip/PKGBUILD
deleted file mode 100644
index e3486f4..0000000
--- a/abs/extra-testing/sip/PKGBUILD
+++ /dev/null
@@ -1,29 +0,0 @@
-# $Id: PKGBUILD 47992 2009-07-30 10:16:59Z pierre $
-# Maintainer: Douglas Soares de Andrade <douglas@archlinux.org>
-# Contributor: riai <riai@bigfoot.com>, Ben <ben@benmazer.net>
-
-pkgname=sip
-pkgver=4.9
-pkgrel=1
-pkgdesc="A tool that makes it easy to create Python bindings for C and C++ libraries."
-arch=(i686 x86_64)
-url="http://www.riverbankcomputing.com/software/sip/"
-license=('custom:"sip"')
-depends=('python>=2.6' 'gcc-libs')
-source=(http://riverbankcomputing.com/static/Downloads/sip4/${pkgname}-${pkgver}.tar.gz)
-
-build() {
- cd ${srcdir}/${pkgname}-${pkgver}
-
- python configure.py -b /usr/bin \
- -d /usr/lib/python2.6/site-packages \
- -e /usr/include/python2.6 \
- -v /usr/share/sip
-
- make || return 1
- make DESTDIR=${pkgdir} install
- # fix permissions
- chmod 644 ${pkgdir}/usr/lib/python2.6/site-packages/sipdistutils.py
-
- install -m 644 -D LICENSE ${pkgdir}/usr/share/licenses/sip/LICENSE
-}