summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/smpeg
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/smpeg')
-rw-r--r--abs/extra-testing/smpeg/PKGBUILD28
-rw-r--r--abs/extra-testing/smpeg/smpeg-0.4.4-gcc41.patch41
2 files changed, 0 insertions, 69 deletions
diff --git a/abs/extra-testing/smpeg/PKGBUILD b/abs/extra-testing/smpeg/PKGBUILD
deleted file mode 100644
index 1b52434..0000000
--- a/abs/extra-testing/smpeg/PKGBUILD
+++ /dev/null
@@ -1,28 +0,0 @@
-# $Id: PKGBUILD 19615 2008-11-28 13:17:01Z allan $
-# Maintainer: Eric Belanger <eric@archlinux.org>
-# Contributor: Jan de Groot <jgc@archlinux.org>
-
-pkgname=smpeg
-pkgver=0.4.4
-pkgrel=4
-pkgdesc="SDL MPEG Player Library"
-arch=('i686' 'x86_64')
-url="http://icculus.org/smpeg/"
-license=('LGPL')
-depends=('sdl')
-makedepends=('gtk' 'mesa')
-options=('!libtool' '!makeflags')
-source=(http://mirrors.dotsrc.org/lokigames/open-source/smpeg/$pkgname-$pkgver.tar.gz smpeg-0.4.4-gcc41.patch)
-md5sums=('59c76ac704088ef5539210190c4e1fe3' '8b979a58307d7196655758bd3d2466c4')
-sha1sums=('6d7f4449472e6270ab435b2224f3fad951c35259' '7d9a2ad7f6b702dfe3adcb87601d9b55022bbd1e')
-
-build() {
- cd $startdir/src/$pkgname-$pkgver
- patch -p1 < ../smpeg-0.4.4-gcc41.patch
- ./configure --prefix=/usr
- make LDFLAGS+=-lstdc++ || return 1
- make DESTDIR=$startdir/pkg install
-
- #fix aclocal warnings
- sed -i "s#(AM_PATH_SMPEG#([AM_PATH_SMPEG]#" ${pkgdir}/usr/share/aclocal/smpeg.m4
-}
diff --git a/abs/extra-testing/smpeg/smpeg-0.4.4-gcc41.patch b/abs/extra-testing/smpeg/smpeg-0.4.4-gcc41.patch
deleted file mode 100644
index 4a0eeb4..0000000
--- a/abs/extra-testing/smpeg/smpeg-0.4.4-gcc41.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-Index: MPEGaudio.h
-===================================================================
-RCS file: /cvs/cvsroot/smpeg/MPEGaudio.h,v
-retrieving revision 1.23
-diff -u -p -r1.23 MPEGaudio.h
---- smpeg/MPEGaudio.h 17 Jul 2001 19:52:24 -0000 1.23
-+++ smpeg/MPEGaudio.h 6 Dec 2005 06:10:43 -0000
-@@ -151,12 +151,6 @@ private:
- /* The actual MPEG audio class */
- class MPEGaudio : public MPEGerror, public MPEGaudioaction {
-
-- friend void Play_MPEGaudioSDL(void *udata, Uint8 *stream, int len);
-- friend int Play_MPEGaudio(MPEGaudio *audio, Uint8 *stream, int len);
--#ifdef THREADED_AUDIO
-- friend int Decode_MPEGaudio(void *udata);
--#endif
--
- public:
- MPEGaudio(MPEGstream *stream, bool initSDL = true);
- virtual ~MPEGaudio();
-@@ -367,6 +361,20 @@ public:
- #define N_TIMESTAMPS 5
-
- double timestamp[N_TIMESTAMPS];
-+
-+ /* Functions which access MPEGaudio internals */
-+ friend void Play_MPEGaudioSDL(void *udata, Uint8 *stream, int len);
-+ friend int Play_MPEGaudio(MPEGaudio *audio, Uint8 *stream, int len);
-+#ifdef THREADED_AUDIO
-+ friend int Decode_MPEGaudio(void *udata);
-+#endif
- };
-
-+/* Need to duplicate the prototypes, this is not a typo :) */
-+void Play_MPEGaudioSDL(void *udata, Uint8 *stream, int len);
-+int Play_MPEGaudio(MPEGaudio *audio, Uint8 *stream, int len);
-+#ifdef THREADED_AUDIO
-+int Decode_MPEGaudio(void *udata);
-+#endif
-+
- #endif /* _MPEGAUDIO_H_ */