summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/spidermonkey/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/spidermonkey/PKGBUILD')
-rw-r--r--abs/extra-testing/spidermonkey/PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/abs/extra-testing/spidermonkey/PKGBUILD b/abs/extra-testing/spidermonkey/PKGBUILD
index 5e43c96..3a44af3 100644
--- a/abs/extra-testing/spidermonkey/PKGBUILD
+++ b/abs/extra-testing/spidermonkey/PKGBUILD
@@ -1,9 +1,6 @@
-# $Id: PKGBUILD 2200 2008-05-29 03:50:56Z eric $
-# Maintainer: Aaron Griffin <aaron@archlinux.org>
-
pkgname=spidermonkey
pkgver=1.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="Mozilla's C implementation of JavaScript."
arch=("i686" "x86_64")
url="http://www.mozilla.org/js/spidermonkey/"
@@ -11,7 +8,7 @@ license=('MPL' 'GPL' 'LGPL')
depends=('nspr')
options=('!makeflags' 'force')
source=("http://ftp.mozilla.org/pub/mozilla.org/js/js-$pkgver.tar.gz" \
- "spidermonkey-1.7-threadsafe.patch")
+ "spidermonkey-1.7-threadsafe.patch" "header.patch")
md5sums=('5571134c3863686b623ebe4e6b1f6fe6' 'b2ef9be017b6aa1857354b5223975a4f')
build()
@@ -21,6 +18,7 @@ build()
[ "$CARCH" = "x86_64" ] && (sed -i -e "s:lib64:lib:g" config.mk || return 1)
# patch Makefile for threadsafe support with native nspr
patch -p2 -i $startdir/src/spidermonkey-1.7-threadsafe.patch || return 1
+ patch -p2 -i $startdir/src/header.patch || return 1
# build - threadsafe
make -f Makefile.ref BUILD_OPT=1 JS_THREADSAFE=1 DIST=$startdir/pkg/usr all export || return 1
# install