summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/spidermonkey/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/spidermonkey/PKGBUILD')
-rw-r--r--abs/extra-testing/spidermonkey/PKGBUILD27
1 files changed, 0 insertions, 27 deletions
diff --git a/abs/extra-testing/spidermonkey/PKGBUILD b/abs/extra-testing/spidermonkey/PKGBUILD
deleted file mode 100644
index 3a44af3..0000000
--- a/abs/extra-testing/spidermonkey/PKGBUILD
+++ /dev/null
@@ -1,27 +0,0 @@
-pkgname=spidermonkey
-pkgver=1.7.0
-pkgrel=2
-pkgdesc="Mozilla's C implementation of JavaScript."
-arch=("i686" "x86_64")
-url="http://www.mozilla.org/js/spidermonkey/"
-license=('MPL' 'GPL' 'LGPL')
-depends=('nspr')
-options=('!makeflags' 'force')
-source=("http://ftp.mozilla.org/pub/mozilla.org/js/js-$pkgver.tar.gz" \
- "spidermonkey-1.7-threadsafe.patch" "header.patch")
-md5sums=('5571134c3863686b623ebe4e6b1f6fe6' 'b2ef9be017b6aa1857354b5223975a4f')
-
-build()
-{
- cd $startdir/src/js/src
- # fix for the lib location
- [ "$CARCH" = "x86_64" ] && (sed -i -e "s:lib64:lib:g" config.mk || return 1)
- # patch Makefile for threadsafe support with native nspr
- patch -p2 -i $startdir/src/spidermonkey-1.7-threadsafe.patch || return 1
- patch -p2 -i $startdir/src/header.patch || return 1
- # build - threadsafe
- make -f Makefile.ref BUILD_OPT=1 JS_THREADSAFE=1 DIST=$startdir/pkg/usr all export || return 1
- # install
- mkdir -p $startdir/pkg/usr/include/js
- mv $startdir/pkg/usr/include/*.h $startdir/pkg/usr/include/js/
-}