summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/xcb-proto/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing/xcb-proto/PKGBUILD')
-rw-r--r--abs/extra-testing/xcb-proto/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/extra-testing/xcb-proto/PKGBUILD b/abs/extra-testing/xcb-proto/PKGBUILD
new file mode 100644
index 0000000..e59e26b
--- /dev/null
+++ b/abs/extra-testing/xcb-proto/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 17316 2008-10-28 12:25:37Z douglas $
+# Maintainer: Alexander Baldeck <alexander@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=xcb-proto
+pkgver=1.2
+pkgrel=2
+pkgdesc="XML-XCB protocol descriptions"
+arch=(i686 x86_64)
+url="http://xcb.freedesktop.org/"
+license=('custom')
+makedepends=('python' 'libxml2')
+source=(${url}/dist/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('09f912486d8a2353bb4b99ddc28ba3c7')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+ install -m755 -d ${pkgdir}/usr/share/licenses/${pkgname}
+ install -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/ || return 1
+}