summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra-testing')
-rw-r--r--abs/extra-testing/community/mythtv-vdpau/PKGBUILD6
-rw-r--r--abs/extra-testing/fuppes-svn/PKGBUILD (renamed from abs/extra-testing/fuppes/PKGBUILD)22
-rw-r--r--abs/extra-testing/fuppes-svn/fuppes-r634-archlinux.patch93
-rw-r--r--abs/extra-testing/fuppes-svn/fuppes.diff25
-rw-r--r--abs/extra-testing/libmpcdec/PKGBUILD22
-rw-r--r--abs/extra-testing/mkvtoolnix/PKGBUILD9
6 files changed, 161 insertions, 16 deletions
diff --git a/abs/extra-testing/community/mythtv-vdpau/PKGBUILD b/abs/extra-testing/community/mythtv-vdpau/PKGBUILD
index 42a97a6..9c293e2 100644
--- a/abs/extra-testing/community/mythtv-vdpau/PKGBUILD
+++ b/abs/extra-testing/community/mythtv-vdpau/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mythtv-vdpau
pkgver=0.21
-pkgrel=22
+pkgrel=23
pkgdesc="A Homebrew PVR project"
arch=('i686' 'x86_64')
depends=('bash' 'mysql-clients>=5.0' 'qt3' 'lame' 'lirc-utils' 'ffmpeg' \
@@ -10,7 +10,7 @@ backup=(etc/mythtv/mythbackend.conf etc/mythtv/mysql.txt usr/share/mythtv/is.xml
source=(ftp://ftp.knoppmyth.net/R6/sources/mythtv-${pkgver}-fixes.tar.bz2 \
mythbackend myththemedmenu.cpp.patch myththemedmenu.h.patch \
smolt_jump.patch pretty \
- http://www.avenard.org/files/media/vdpau/mythtv-fixes-glvdpau20462.patch.gz mpegpspatch mythbackend.lr mythfrontend.lr)
+ http://www.avenard.org/files/media/vdpau/mythtv-fixes-glvdpau20549.patch.gz mpegpspatch mythbackend.lr mythfrontend.lr)
#md5sums=('e316ed18d7ac837cf8c4af54b1478793' '7ef6de58240e7aad389a0b13d91b1cf6'\
# 'a0ecb7f476cb71c0c1ac90d349fc7695')
@@ -34,7 +34,7 @@ build() {
# patch -p0 < ../pop_be_restart.cpp.patch
patch -p0 < ../smolt_jump.patch
# patch -p0 < ../2.6.28_dvb_api_version.diff
- patch -p1 < ../mythtv-fixes-glvdpau20462.patch
+ patch -p1 < ../mythtv-fixes-glvdpau20549.patch
cd libs/libavformat
patch -p0 < $startdir/src/mpegpspatch
cd -
diff --git a/abs/extra-testing/fuppes/PKGBUILD b/abs/extra-testing/fuppes-svn/PKGBUILD
index 18508b7..82576b1 100644
--- a/abs/extra-testing/fuppes/PKGBUILD
+++ b/abs/extra-testing/fuppes-svn/PKGBUILD
@@ -1,30 +1,33 @@
-pkgname=fuppes
-pkgver=624
+# Contributor: Andrew Krawchyk <krawch_a@denison.edu>
+# patch for svn r634: Ivan Yurasov <vd@vdk.su>
+
+pkgname=fuppes-svn
+pkgver=634
pkgrel=1
pkgdesc="A free, multiplatform Universal Plug and Play A/V MediaServer"
arch=('i686' 'x86_64')
url="http://fuppes.ulrich-voelkel.de/"
license=('GPL2')
-#depends=('pcre' 'libxml2' 'sqlite3' 'gettext' 'taglib' 'imagemagick' 'ffmpeg' 'libmp4v2' 'lame' 'libvorbis' 'libmpcdec' 'flac' 'faad2' 'libmad')
-depends=('pcre' 'libxml2' 'sqlite3' 'gettext' 'taglib' 'imagemagick' 'ffmpeg' 'libmp4v2' 'lame' 'libvorbis' 'flac' 'faad2' 'libmad')
+depends=('pcre' 'libxml2' 'sqlite3' 'gettext' 'taglib' 'imagemagick' 'ffmpeg' 'libmp4v2' 'lame' 'libvorbis' 'libmpcdec' 'flac' 'faad2' 'libmad')
makdepends=('pkgconfig' 'autoconf' 'subversion')
-source=()
-md5sums=()
+source=(fuppes-r634-archlinux.patch fuppes.diff)
+md5sums=('5d9f6331cc91b64aab69449ce327b214' 'c495fa1bd9a870ae36820632434319ee')
-_svntrunk="https://fuppes.svn.sourceforge.net/svnroot/fuppes/trunk"
_svnmod="fuppes"
+_svntrunk="https://fuppes.svn.sourceforge.net/svnroot/fuppes/trunk"
build()
{
cd ${startdir}/src
msg "Getting sources..."
- svn co ${_svntrunk} ${_svnmod}
+ svn co ${_svntrunk} ${_svnmod} -r 634
msg "Done getting sources or failed to connect to server."
cd ${_svnmod}
- # generate ./configure
+ patch -Np0 -i ../fuppes-r634-archlinux.patch
+ patch -Np0 -i ../fuppes.diff
autoreconf -vfi
./configure --prefix=/usr \
@@ -34,3 +37,4 @@ build()
make || return 1
make DESTDIR=$startdir/pkg install || return 1
}
+
diff --git a/abs/extra-testing/fuppes-svn/fuppes-r634-archlinux.patch b/abs/extra-testing/fuppes-svn/fuppes-r634-archlinux.patch
new file mode 100644
index 0000000..feaccfa
--- /dev/null
+++ b/abs/extra-testing/fuppes-svn/fuppes-r634-archlinux.patch
@@ -0,0 +1,93 @@
+Index: src/plugins/ffmpeg/ffmpeg.cpp
+===================================================================
+--- src/plugins/ffmpeg/ffmpeg.cpp (revision 634)
++++ src/plugins/ffmpeg/ffmpeg.cpp (working copy)
+@@ -2190,7 +2190,7 @@
+ p=NULL;
+ for(p = av_codec_next(p); p != NULL; p = av_codec_next(p) ) {
+ #else
+- for(p = first_avcodec; p != NULL; p = p->next) {
++ for(p = av_codec_next(NULL); p != NULL; p = p->next) {
+ #endif
+
+ if((p2==NULL || strcmp(p->name, p2->name)<0) &&
+@@ -2269,7 +2269,7 @@
+ }
+ avformat_opts = av_alloc_format_context();
+ #ifdef HAVE_LIBSWSCALE
+- sws_opts = sws_getContext(16,16,0, 16,16,0, sws_flags, NULL,NULL,NULL);
++ sws_opts = sws_getContext(16,16,(PixelFormat)0, 16,16,(PixelFormat)0, sws_flags, NULL,NULL,NULL);
+ #endif
+
+
+Index: src/plugins/ffmpeg/ffmpeg.h
+===================================================================
+--- src/plugins/ffmpeg/ffmpeg.h (revision 634)
++++ src/plugins/ffmpeg/ffmpeg.h (working copy)
+@@ -38,7 +38,7 @@
+ #include <ctype.h>
+ #include <string.h>
+
+-#if FFMPEG_VERSION >= 52 && !defined(OLD_INCLUDES_PATH)
++/* #if FFMPEG_VERSION >= 52 && !defined(OLD_INCLUDES_PATH) */
+ #include <libavformat/avformat.h>
+ #include <libavutil/avutil.h>
+ #include <libavutil/fifo.h>
+@@ -51,27 +51,27 @@
+ #ifdef HAVE_AVSTRING_H
+ #include <libavutil/avstring.h>
+ #endif
+-#else
++/* #else
+ #include <avformat.h>
+ #include <avutil.h>
+ #include <fifo.h>
+- #include <opt.h>
++ #include <opt.h> */
+
+
+ #ifdef HAVE_LIBSWSCALE
+- #include <swscale.h>
++ #include <libswscale/swscale.h>
+ #endif
+
+ #ifdef HAVE_AVSTRING_H
+- #include <avstring.h>
++ #include <libavutil/avstring.h>
+ #endif
+-#endif
++/* #endif */
+
+
+ #include <math.h>
+ #include <stdlib.h>
+ #include <limits.h>
+- //#include <mem.h>
++ //#include <mem.h>
+
+ }
+ #endif // __cplusplus
+Index: version.sh
+===================================================================
+--- version.sh (revision 634)
++++ version.sh (working copy)
+@@ -1,8 +1,15 @@
+ #!/bin/sh
+
+-svn_revision=`cd "$1" && LC_ALL=C svn info 2> /dev/null | grep Revision | cut -d' ' -f2`
+-test $svn_revision || svn_revision=`cd "$1" && grep revision .svn/entries 2>/dev/null | cut -d '"' -f2`
+-test $svn_revision || svn_revision=`cd "$1" && sed -n -e '/^dir$/{n;p;q}' .svn/entries 2>/dev/null`
++if [ "$1" == "" ]
++then
++DIR="."
++else
++DIR="$1"
++fi
++
++svn_revision=`cd "$DIR" && LC_ALL=C svn info 2> /dev/null | grep Revision | cut -d' ' -f2`
++test $svn_revision || svn_revision=`cd "$DIR" && grep revision .svn/entries 2>/dev/null | cut -d '"' -f2`
++test $svn_revision || svn_revision=`cd "$DIR" && sed -n -e '/^dir$/{n;p;q}' .svn/entries 2>/dev/null`
+ test $svn_revision || svn_revision=UNKNOWN
+
+ NEW_REVISION="#define FUPPES_VERSION \"0.$svn_revision\""
+
diff --git a/abs/extra-testing/fuppes-svn/fuppes.diff b/abs/extra-testing/fuppes-svn/fuppes.diff
new file mode 100644
index 0000000..9b7b6a8
--- /dev/null
+++ b/abs/extra-testing/fuppes-svn/fuppes.diff
@@ -0,0 +1,25 @@
+--- src/plugins/ffmpeg/ffmpeg.cpp.orig 2009-05-29 20:12:09.000000000 +0000
++++ src/plugins/ffmpeg/ffmpeg.cpp 2009-05-29 20:10:01.000000000 +0000
+@@ -1021,19 +1021,9 @@
+ if (subtitle_to_free) {
+ if (subtitle_to_free->rects != NULL) {
+ for (i = 0; i < subtitle_to_free->num_rects; i++) {
+-
+-#ifndef LIBAVCODEC_VERSION_MINOR
+-#define LIBAVCODEC_VERSION_MINOR 0
+-#endif
+-
+-#if LIBAVCODEC_VERSION_MINOR >= 11
+- av_freep(subtitle_to_free->rects[i]->pict.data[0]);
+- av_freep(subtitle_to_free->rects[i]->pict.data[1]);
+- av_freep(subtitle_to_free->rects[i]);
+-#else
+- av_free(subtitle_to_free->rects[i].bitmap);
+- av_free(subtitle_to_free->rects[i].rgba_palette);
+-#endif
++ av_freep(&subtitle_to_free->rects[i]->pict.data[0]);
++ av_freep(&subtitle_to_free->rects[i]->pict.data[1]);
++ av_freep(&subtitle_to_free->rects[i]);
+ }
+ av_freep(&subtitle_to_free->rects);
+ }
diff --git a/abs/extra-testing/libmpcdec/PKGBUILD b/abs/extra-testing/libmpcdec/PKGBUILD
new file mode 100644
index 0000000..feeaf8b
--- /dev/null
+++ b/abs/extra-testing/libmpcdec/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=libmpcdec
+pkgver=1.2.6
+pkgrel=1
+pkgdesc="Musepack decoding library"
+arch=(i686 x86_64)
+license=('custom')
+depends=('glibc')
+options=('!libtool')
+source=(http://files.musepack.net/source/${pkgname}-${pkgver}.tar.bz2)
+url="http://musepack.net/"
+md5sums=('7f7a060e83b4278acf4b77d7a7b9d2c0')
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ ./configure --prefix=/usr --disable-static
+ make || return 1
+ make DESTDIR=${startdir}/pkg install || return 1
+ install -Dm644 COPYING ${startdir}/pkg/usr/share/licenses/${pkgname}/COPYING
+}
diff --git a/abs/extra-testing/mkvtoolnix/PKGBUILD b/abs/extra-testing/mkvtoolnix/PKGBUILD
index ff6f2f0..2e37e8e 100644
--- a/abs/extra-testing/mkvtoolnix/PKGBUILD
+++ b/abs/extra-testing/mkvtoolnix/PKGBUILD
@@ -1,9 +1,9 @@
-# $Id: PKGBUILD 29417 2009-03-08 17:05:04Z giovanni $
+# $Id: PKGBUILD 39931 2009-05-23 08:10:22Z giovanni $
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: 03/08/04 <lefungus@altern.org>
pkgname=mkvtoolnix
-pkgver=2.5.3
+pkgver=2.9.0
pkgrel=1
pkgdesc="Set of tools to create, edit and inspect Matroska files"
arch=('i686' 'x86_64')
@@ -11,11 +11,12 @@ license=('GPL2')
url="http://www.bunkus.org/videotools/mkvtoolnix/index.html"
depends=('libmatroska>=0.8.1' 'flac>=1.1.4' 'libvorbis' 'wxgtk>=2.8.0.1' 'file' 'boost' 'lzo2')
source=("http://www.bunkus.org/videotools/${pkgname}/sources/${pkgname}-${pkgver}.tar.bz2")
-md5sums=('de0b41f0dc9b3c7c59a23be4b6e3ee46')
+md5sums=('4b3afa60ed96a9898e9f598b1694cbef')
build() {
cd ${srcdir}/${pkgname}-${pkgver}/
- ./configure --prefix=/usr --with-boost-libdir=/usr/lib
+ ./configure --prefix=/usr \
+ --with-boost-libdir=/usr/lib
make || return 1
make DESTDIR=${pkgdir}/ install
}