summaryrefslogtreecommitdiffstats
path: root/abs/extra/abs/abs.install
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/abs/abs.install')
-rw-r--r--abs/extra/abs/abs.install15
1 files changed, 15 insertions, 0 deletions
diff --git a/abs/extra/abs/abs.install b/abs/extra/abs/abs.install
new file mode 100644
index 0000000..1b19b4a
--- /dev/null
+++ b/abs/extra/abs/abs.install
@@ -0,0 +1,15 @@
+## arg 1: the new package version
+## arg 2: the old package version
+pre_upgrade() {
+ if [ "$(vercmp $2 2.0-1)" -lt 0 ]; then
+ echo "==> ABS now uses rsync, instead of cvsup, to synchronize your tree."
+ echo "==> Please note the new configuration in /etc/abs.conf"
+ fi
+
+ if [ "$(vercmp $2 2.0-4)" -lt 0 ]; then
+ echo "==> Warning: abs clears out the contents of /var/abs when syncing."
+ echo "==> Keep all local PKGBUILDs in /var/abs/local, or they will disappear"
+ fi
+}
+
+# vim:set ts=2 sw=2 et: