summaryrefslogtreecommitdiffstats
path: root/abs/extra/bash-completion/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/bash-completion/PKGBUILD')
-rw-r--r--abs/extra/bash-completion/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/extra/bash-completion/PKGBUILD b/abs/extra/bash-completion/PKGBUILD
new file mode 100644
index 0000000..575e523
--- /dev/null
+++ b/abs/extra/bash-completion/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id$
+# Maintainer: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=bash-completion
+pkgver=2.4
+pkgrel=1
+pkgdesc="Programmable completion for the bash shell"
+arch=('any')
+url="https://github.com/scop/bash-completion"
+license=('GPL2')
+depends=('bash')
+options=('!emptydirs' '!makeflags')
+source=("https://github.com/scop/bash-completion/releases/download/$pkgver/$pkgname-$pkgver.tar.xz")
+sha1sums=('c02fb9c0f669d178f678c291ea17ddadfd011250')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+
+# bash-completion is sourced in /etc/bash.bashrc so that non-bash shell don't source it
+ rm "${pkgdir}/etc/profile.d/bash_completion.sh"
+
+# remove Slackware's makepkg completion
+ rm "${pkgdir}/usr/share/bash-completion/completions/makepkg"
+
+# remove completions which overlap with util-linux
+ rm "${pkgdir}/usr/share/bash-completion/completions"/{u,}mount
+}