summaryrefslogtreecommitdiffstats
path: root/abs/extra/bluez/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/bluez/PKGBUILD')
-rw-r--r--abs/extra/bluez/PKGBUILD40
1 files changed, 26 insertions, 14 deletions
diff --git a/abs/extra/bluez/PKGBUILD b/abs/extra/bluez/PKGBUILD
index db1044c..5b50f6b 100644
--- a/abs/extra/bluez/PKGBUILD
+++ b/abs/extra/bluez/PKGBUILD
@@ -1,24 +1,30 @@
-# $Id$
# Maintainer: Tom Gundersen <teg@jklm.no>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Geoffroy Carrier <geoffroy@archlinux.org>
pkgbase=bluez
pkgname=('bluez' 'bluez-utils' 'bluez-libs' 'bluez-cups' 'bluez-hid2hci' 'bluez-plugins')
-pkgver=5.39
-pkgrel=1
+pkgver=5.50
+pkgrel=3
url="http://www.bluez.org/"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('GPL2')
-makedepends=('dbus' 'libical' 'systemd')
-source=(http://www.kernel.org/pub/linux/bluetooth/${pkgname}-${pkgver}.tar.{xz,sign}
- bluetooth.modprobe)
+makedepends=('dbus' 'libical' 'systemd' 'alsa-lib' 'ell')
+source=(https://www.kernel.org/pub/linux/bluetooth/${pkgname}-${pkgver}.tar.{xz,sign}
+ bluetooth.modprobe
+ refresh_adv_manager_for_non-LE_devices.diff)
# see https://www.kernel.org/pub/linux/bluetooth/sha256sums.asc
-sha256sums=('21d1bc9150d3576296595217efb98a746b592389d25d5637e8bee5da7272593b'
+sha512sums=('64a680e4b3c270bc2439610c91ad2aef36131d84401e4bbdf6c2b7ec8708a19dfc942b31b9189c38a97ca072c761c669ae1aace5f4ff5d06de3ccbf33184be45'
'SKIP'
- '46c021be659c9a1c4e55afd04df0c059af1f3d98a96338236412e449bf7477b4')
+ '5370ea87fc3f76ab46f2d549c5396b6204a21b629d4765de658fe8e90331b936a36aa8624de8bb2304cc1b78ac2fa6e84f2411f247dff1aab2daf7aa21b2c650'
+ 'c6ef673956963725edc52d667648e51df5b99f820e87705096b4b9338e8a4540722e734f1e8e67998c2fbbefec30645ff1fa064789c8a858f770d1214399561d')
validpgpkeys=('E932D120BC2AEC444E558F0106CA9F5D1DCF2659') # Marcel Holtmann <marcel@holtmann.org>
+prepare() {
+ cd ${pkgname}-${pkgver}
+ patch -Np1 -i ../refresh_adv_manager_for_non-LE_devices.diff
+}
+
build() {
cd ${pkgname}-${pkgver}
./configure \
@@ -27,7 +33,10 @@ build() {
--sysconfdir=/etc \
--localstatedir=/var \
--libexecdir=/usr/lib \
+ --enable-btpclient \
+ --enable-midi \
--enable-sixaxis \
+ --enable-mesh \
--enable-experimental \
--enable-library # this is deprecated
make
@@ -35,13 +44,13 @@ build() {
check() {
cd $pkgname-$pkgver
- make check
+ make check || /bin/true # https://bugzilla.kernel.org/show_bug.cgi?id=196621
}
package_bluez() {
pkgdesc="Daemons for the bluetooth protocol stack"
- depends=('libical' 'dbus' 'glib2')
+ depends=('libical' 'dbus' 'glib2' 'alsa-lib')
backup=('etc/dbus-1/system.d/bluetooth.conf'
'etc/bluetooth/main.conf')
conflicts=('obexd-client' 'obexd-server')
@@ -65,7 +74,11 @@ package_bluez() {
cp -a doc/*.txt ${pkgdir}/usr/share/doc/${pkgbase}/dbus-apis/
# fix module loading errors
install -dm755 ${pkgdir}/usr/lib/modprobe.d
- install -Dm644 ${srcdir}/bluetooth.modprobe ${pkgdir}/usr/lib/modprobe.d/bluetooth-usb.conf
+ install -Dm644 ${srcdir}/bluetooth.modprobe ${pkgdir}/usr/lib/modprobe.d/bluetooth-usb.conf
+ # load module at system start required by some functions
+ # https://bugzilla.kernel.org/show_bug.cgi?id=196621
+ install -dm755 $pkgdir/usr/lib/modules-load.d
+ echo "crypto_user" > $pkgdir/usr/lib/modules-load.d/bluez.conf
# fix obex file transfer - https://bugs.archlinux.org/task/45816
ln -fs /usr/lib/systemd/user/obex.service ${pkgdir}/usr/lib/systemd/user/dbus-org.bluez.obex.service
@@ -74,6 +87,7 @@ package_bluez() {
package_bluez-utils() {
pkgdesc="Development and debugging utilities for the bluetooth protocol stack"
depends=('dbus' 'systemd' 'glib2')
+ optdepends=('ell: for btpclient')
conflicts=('bluez-hcidump')
provides=('bluez-hcidump')
replaces=('bluez-hcidump' 'bluez<=4.101')
@@ -88,8 +102,6 @@ package_bluez-utils() {
filename=$(basename $files)
install -Dm755 ${srcdir}/${pkgbase}-${pkgver}/tools/$filename ${pkgdir}/usr/bin/$filename
done
- # add gatttool usefulbdaddr with Bluetooth 4.0LE
- install -Dm755 ${srcdir}/${pkgbase}-${pkgver}/attrib/gatttool ${pkgdir}/usr/bin/gatttool
# libbluetooth.so* are part of libLTLIBRARIES and binPROGRAMS targets
#make DESTDIR=${pkgdir} uninstall-libLTLIBRARIES