summaryrefslogtreecommitdiffstats
path: root/abs/extra/bluez/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/bluez/PKGBUILD')
-rw-r--r--abs/extra/bluez/PKGBUILD200
1 files changed, 128 insertions, 72 deletions
diff --git a/abs/extra/bluez/PKGBUILD b/abs/extra/bluez/PKGBUILD
index 758e858..9465acb 100644
--- a/abs/extra/bluez/PKGBUILD
+++ b/abs/extra/bluez/PKGBUILD
@@ -3,86 +3,142 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Geoffroy Carrier <geoffroy@archlinux.org>
-pkgname=bluez
-pkgver=4.101
+pkgbase=bluez
+pkgname=('bluez' 'bluez-utils' 'bluez-libs' 'bluez-cups' 'bluez-hid2hci' 'bluez-plugins')
+pkgver=5.15
pkgrel=1
-pkgdesc="Libraries and tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
arch=('i686' 'x86_64')
license=('GPL2')
-depends=('dbus-core' 'python2' 'udev')
-makedepends=('gstreamer0.10-base' 'libusb-compat' 'libsndfile' 'libusb')
-optdepends=("gstreamer0.10-base: bluetooth GStreamer support"
- "alsa-lib: Audio bluetooth devices support"
- "dbus-python: to run bluez-simple-agent"
- "pygobject: to run bluez-simple-agent"
- "libusb-compat: USB adapters support"
- "cups: CUPS backend")
-conflicts=('bluez-libs' 'bluez-utils')
-provides=('bluez-libs' 'bluez-utils')
-replaces=('bluez-libs' 'bluez-utils')
-options=('!libtool')
-backup=(etc/bluetooth/{main,rfcomm,audio,network,input,serial}.conf
- 'etc/conf.d/bluetooth' 'etc/dbus-1/system.d/bluetooth.conf')
-source=("http://www.kernel.org/pub/linux/bluetooth/${pkgname}-${pkgver}.tar.bz2"
- 'bluetooth.conf.d'
- 'org.bluez.service'
- 'audio-streaming.patch')
+makedepends=('dbus' 'libical' 'systemd')
+source=(http://www.kernel.org/pub/linux/bluetooth/${pkgname}-${pkgver}.tar.xz
+ 0001-Allow-using-obexd-without-systemd-in-the-user-session.patch
+ bluetooth.modprobe)
+# see https://www.kernel.org/pub/linux/bluetooth/sha256sums.asc
+sha256sums=('487bd75697e565793bf5bc4fbd5fa6a602788313b0c694f7542b81689fc0aa87'
+ '896a1403d9b7258c4fb0d41f3a6f70fd51eaa1115ab3f4259f3dbbe02b55766b'
+ '46c021be659c9a1c4e55afd04df0c059af1f3d98a96338236412e449bf7477b4')
+
+prepare() {
+ cd $pkgname-$pkgver
+ # patch not upstreamable for obex file transfer - FS#37773 taken from FC
+ # http://www.hadess.net/2013/11/bluetooth-file-sharing-obexpush-in.html
+ patch -Np1 -i ${srcdir}/0001-Allow-using-obexd-without-systemd-in-the-user-session.patch
+ autoreconf -vfi
+}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
-# Add setting that allows audio streaming out-of-the-box
- patch -Np1 -i ${srcdir}/audio-streaming.patch || return 1
-
- cp ../org.bluez.service src/
-
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --libexecdir=/lib \
- --enable-gstreamer \
- --enable-alsa \
- --enable-usb \
- --enable-tools \
- --enable-bccmd \
- --enable-dfutool \
- --enable-hid2hci \
- --enable-hidd \
- --enable-pand \
- --enable-dund \
- --enable-cups \
- --enable-wiimote \
- --disable-test \
- --with-systemdunitdir=/usr/lib/systemd/system
-
- make
+ cd ${pkgname}-${pkgver}
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib \
+ --enable-sixaxis \
+ --enable-library # this is deprecated
+# --enable-experimental \
+
+ make all V=1
+}
+
+check() {
+ cd $pkgname-$pkgver
+ make check
+}
+
+
+package_bluez() {
+ pkgdesc="Daemons for the bluetooth protocol stack"
+ depends=('libical' 'dbus' 'glib2')
+ backup=('etc/dbus-1/system.d/bluetooth.conf'
+ 'etc/bluetooth/main.conf')
+ conflicts=('obexd-client' 'obexd-server')
+
+ cd ${pkgbase}-${pkgver}
+ #make DESTDIR=${pkgdir} install
+ #return 1
+
+ make DESTDIR=${pkgdir} \
+ install-libexecPROGRAMS \
+ install-dbussessionbusDATA \
+ install-systemdsystemunitDATA \
+ install-systemduserunitDATA \
+ install-dbussystembusDATA \
+ install-dbusDATA \
+ install-man8
+
+ # ship upstream main config file
+ install -dm755 ${pkgdir}/etc/bluetooth
+ install -Dm644 ${srcdir}/${pkgbase}-${pkgver}/src/main.conf ${pkgdir}/etc/bluetooth/main.conf
+
+ # add basic documention
+ install -dm755 ${pkgdir}/usr/share/doc/${pkgbase}/dbus-apis
+ cp -a doc/*.txt ${pkgdir}/usr/share/doc/${pkgbase}/dbus-apis/
+ # fix module loading errors
+ install -dm755 ${pkgdir}/usr/lib/modprobe.d
+ install -Dm644 ${srcdir}/bluetooth.modprobe ${pkgdir}/usr/lib/modprobe.d/bluetooth-usb.conf
+}
+
+package_bluez-utils() {
+ pkgdesc="Development and debugging utilities for the bluetooth protocol stack"
+ depends=('dbus' 'systemd')
+ conflicts=('bluez-hcidump')
+ provides=('bluez-hcidump')
+ replaces=('bluez-hcidump' 'bluez<=4.101')
+
+ cd ${pkgbase}-${pkgver}
+ make DESTDIR=${pkgdir} \
+ install-binPROGRAMS \
+ install-man1
+
+ # libbluetooth.so* are part of libLTLIBRARIES and binPROGRAMS targets
+ #make DESTDIR=${pkgdir} uninstall-libLTLIBRARIES
+ #rmdir ${pkgdir}/usr/lib
+ rm -rf ${pkgdir}/usr/lib
+
+ # move the hid2hci man page out
+ mv ${pkgdir}/usr/share/man/man1/hid2hci.1 ${srcdir}/
+}
+
+package_bluez-libs() {
+ pkgdesc="Deprecated libraries for the bluetooth protocol stack"
+ depends=('glibc')
+ license=('LGPL2.1')
+
+ cd ${pkgbase}-${pkgver}
+ make DESTDIR=${pkgdir} \
+ install-includeHEADERS \
+ install-libLTLIBRARIES \
+ install-pkgconfigDATA
}
-package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
+package_bluez-cups() {
+ pkgdesc="CUPS printer backend for Bluetooth printers"
+ depends=('cups')
- install -d ${pkgdir}/etc/bluetooth
- install -m644 network/network.conf \
- input/input.conf \
- audio/audio.conf \
- serial/serial.conf \
- ${pkgdir}/etc/bluetooth/
+ cd ${pkgbase}-${pkgver}
+ make DESTDIR=${pkgdir} install-cupsPROGRAMS
+}
+
+package_bluez-hid2hci() {
+ pkgdesc="Put HID proxying bluetooth HCI's into HCI mode"
+ depends=('systemd')
+
+ cd ${pkgbase}-${pkgver}
+ make DESTDIR=${pkgdir} \
+ install-udevPROGRAMS \
+ install-rulesDATA
- install -Dm644 ${srcdir}/bluetooth.conf.d \
- ${pkgdir}/etc/conf.d/bluetooth
-
- # FS#27630
- install -Dm755 test/simple-agent "${pkgdir}"/usr/bin/bluez-simple-agent
- install -Dm755 test/test-device "${pkgdir}"/usr/bin/bluez-test-device
- install -Dm755 test/test-input "${pkgdir}"/usr/bin/bluez-test-input
- sed -i 's#/usr/bin/python#/usr/bin/python2#' \
- "${pkgdir}"/usr/bin/bluez-simple-agent \
- "${pkgdir}"/usr/bin/bluez-test-device \
- "${pkgdir}"/usr/bin/bluez-test-input
+ install -dm755 ${pkgdir}/usr/share/man/man1
+ mv ${srcdir}/hid2hci.1 ${pkgdir}/usr/share/man/man1/hid2hci.1
+}
+
+package_bluez-plugins() {
+ pkgdesc="bluez plugins (PS3 Sixaxis controller)"
+ depends=('systemd')
+
+ cd ${pkgbase}-${pkgver}
+ make DESTDIR=${pkgdir} \
+ install-pluginLTLIBRARIES
}
-md5sums=('902b390af95c6c5d6d1a17d94c8344ab'
- '7412982b440f29fa7f76a41a87fef985'
- '54c7de598327bf11d56592235d0702f4'
- 'cc9c86af1ced7ad46fc7be114d32adfb')