summaryrefslogtreecommitdiffstats
path: root/abs/extra/bluez/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/bluez/PKGBUILD')
-rw-r--r--abs/extra/bluez/PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/abs/extra/bluez/PKGBUILD b/abs/extra/bluez/PKGBUILD
index c1f675a..e6837e9 100644
--- a/abs/extra/bluez/PKGBUILD
+++ b/abs/extra/bluez/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=bluez
pkgver=4.99
-pkgrel=2
+pkgrel=3
pkgdesc="Libraries and tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
arch=('i686' 'x86_64')
@@ -26,11 +26,15 @@ backup=(etc/bluetooth/{main,rfcomm,audio,network,input,serial}.conf
'etc/conf.d/bluetooth' 'etc/dbus-1/system.d/bluetooth.conf')
install='bluez.install'
source=("http://www.kernel.org/pub/linux/bluetooth/${pkgname}-${pkgver}.tar.bz2"
- 'bluetooth.conf.d')
+ 'bluetooth.conf.d'
+ 'audio-streaming.patch')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+# Add setting that allows audio streaming out-of-the-box
+ patch -Np1 -i ${srcdir}/audio-streaming.patch || return 1
+
./configure --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
@@ -80,4 +84,5 @@ package() {
# rm "${pkgdir}"/usr/lib/udev/rules.d/97-bluetooth.rules
}
md5sums=('2387053eb5a7b02f37df4871df022a02'
- '7412982b440f29fa7f76a41a87fef985')
+ '7412982b440f29fa7f76a41a87fef985'
+ 'cc9c86af1ced7ad46fc7be114d32adfb')