summaryrefslogtreecommitdiffstats
path: root/abs/extra/bmp/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/bmp/PKGBUILD')
-rw-r--r--abs/extra/bmp/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/extra/bmp/PKGBUILD b/abs/extra/bmp/PKGBUILD
new file mode 100644
index 0000000..ffcc1bf
--- /dev/null
+++ b/abs/extra/bmp/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 9914 2008-08-21 00:36:16Z eric $
+# Maintainer: Kevin Piche <kevin@archlinux.org>
+# Contributor: Ben <contrasutra@myrealbox.com>
+
+pkgname=bmp
+pkgver=0.9.7.1
+pkgrel=4
+pkgdesc="gtk2 port of xmms"
+arch=(i686 x86_64)
+url="http://bmp.beep-media-player.org/"
+depends=('esd' 'id3lib' 'libglade' 'libsm' 'libvorbis' 'unzip')
+source=(http://voxel.dl.sourceforge.net/sourceforge/beepmp/bmp-$pkgver.tar.gz $pkgver-visualization.patch bmp-${pkgver}-crossfade-0.3.9.patch)
+md5sums=('c25d5a8d49cc5851d13d525a20023c4c' 'fa1bdf5a8d03e8539a6bed5caa471176'\
+ '42ad4109ddb66024d4c6d1f3e572ab86')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ patch -p0 -i ../${pkgver}-visualization.patch
+ patch -p1 -i ../${pkgname}-${pkgver}-crossfade-0.3.9.patch
+ ./configure --prefix=/usr
+ /usr/bin/make || return 1
+ /usr/bin/make DESTDIR=$startdir/pkg install
+ find $startdir/pkg -name '*.la' -exec rm {} \;
+}
+# vim: ts=2 sw=2 et ft=sh