summaryrefslogtreecommitdiffstats
path: root/abs/extra/boost/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/boost/PKGBUILD')
-rw-r--r--abs/extra/boost/PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/abs/extra/boost/PKGBUILD b/abs/extra/boost/PKGBUILD
index 9c78494..37bb2de 100644
--- a/abs/extra/boost/PKGBUILD
+++ b/abs/extra/boost/PKGBUILD
@@ -11,18 +11,17 @@ _boostver=${pkgver//./_}
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.boost.org/"
-makedepends=('icu' 'python' 'python2' 'bzip2' 'zlib' 'openmpi')
+makedepends=('icu' 'python2' 'bzip2' 'zlib' 'openmpi')
source=(http://downloads.sourceforge.net/sourceforge/${pkgbase}/${pkgbase}_${_boostver}.tar.gz)
license=('custom')
-md5sums=('ff180a5276bec773a7625cac7e2288e8')
_stagedir="${srcdir}/stagedir"
build() {
# set python path for bjam
cd "${srcdir}/${pkgbase}_${_boostver}/tools"
- echo "using python : 2.7 : /usr/bin/python2 ;" >> build/v2/user-config.jam
- echo "using python : 3.2 : /usr/bin/python : /usr/include/python3.2mu : /usr/lib ;" >> build/v2/user-config.jam
+ echo "using python : 2.6 : /usr/bin/python2 ;" >> build/v2/user-config.jam
+ #echo "using python : 3.2 : /usr/bin/python : /usr/include/python3.2mu : /usr/lib ;" >> build/v2/user-config.jam
echo "using mpi ;" >> build/v2/user-config.jam
# build bjam
@@ -74,8 +73,7 @@ build() {
package_boost() {
pkgdesc="Free peer-reviewed portable C++ source libraries - Development"
depends=("boost-libs=${pkgver}")
- optdepends=('python: for python bindings'
- 'python2: for python2 bindings')
+ optdepends=('python2: for python2 bindings')
install -d "${pkgdir}"/usr/{include,lib,share}
# headers/source files
@@ -108,3 +106,4 @@ package_boost-libs() {
install -D -m644 "${srcdir}/${pkgbase}_${_boostver}/LICENSE_1_0.txt" \
"${pkgdir}"/usr/share/licenses/boost-libs/LICENSE_1_0.txt
}
+md5sums=('ff180a5276bec773a7625cac7e2288e8')