summaryrefslogtreecommitdiffstats
path: root/abs/extra/boost
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/boost')
-rw-r--r--abs/extra/boost/0001-date_time-gcc-4.3-fix.patch25
-rw-r--r--abs/extra/boost/PKGBUILD63
-rw-r--r--abs/extra/boost/serialization_gcc43.patch44
3 files changed, 132 insertions, 0 deletions
diff --git a/abs/extra/boost/0001-date_time-gcc-4.3-fix.patch b/abs/extra/boost/0001-date_time-gcc-4.3-fix.patch
new file mode 100644
index 0000000..9f7e016
--- /dev/null
+++ b/abs/extra/boost/0001-date_time-gcc-4.3-fix.patch
@@ -0,0 +1,25 @@
+From 88f7023cc36d82133cfa0e705531a9d73feb4686 Mon Sep 17 00:00:00 2001
+From: Tim Blechmann <tim@klingt.org>
+Date: Sat, 2 Feb 2008 17:22:58 +0100
+Subject: [PATCH] date_time: gcc-4.3 fix
+
+---
+ boost/date_time/tz_db_base.hpp | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/boost/date_time/tz_db_base.hpp b/boost/date_time/tz_db_base.hpp
+index b9c0a8a..03f748e 100644
+--- a/boost/date_time/tz_db_base.hpp
++++ b/boost/date_time/tz_db_base.hpp
+@@ -158,7 +158,7 @@ namespace boost {
+ typedef typename time_zone_type::base_type time_zone_base_type;
+ typedef typename time_zone_type::time_duration_type time_duration_type;
+ typedef time_zone_names_base<char_type> time_zone_names;
+- typedef dst_adjustment_offsets<time_duration_type> dst_adjustment_offsets;
++ typedef boost::date_time::dst_adjustment_offsets<time_duration_type> dst_adjustment_offsets;
+ typedef std::basic_string<char_type> string_type;
+
+ //! Constructs an empty database
+--
+1.5.3.8
+
diff --git a/abs/extra/boost/PKGBUILD b/abs/extra/boost/PKGBUILD
new file mode 100644
index 0000000..1fcfd98
--- /dev/null
+++ b/abs/extra/boost/PKGBUILD
@@ -0,0 +1,63 @@
+# $Id: PKGBUILD 24200 2009-01-15 01:41:45Z douglas $
+# Maintainer: kevin <kevin@archlinux.org>
+# TU: Kritoke <kritoke@gamebox.net>
+# Contributor: Luca Roccia <little_rock@users.sourceforge.net>
+
+pkgname=boost
+pkgver=1.37.0
+_boostver=1_37_0
+pkgrel=1
+pkgdesc="Boost provides free peer-reviewed portable C++ source libraries."
+arch=(i686 x86_64)
+url="http://www.boost.org/"
+depends=('python>=2.5' 'bzip2' 'zlib')
+source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}_${_boostver}.tar.gz 0001-date_time-gcc-4.3-fix.patch)
+license=('custom')
+
+build() {
+ cd ${srcdir}/${pkgname}_${_boostver}
+ export CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ #patch -Np1 -i ${srcdir}/0001-date_time-gcc-4.3-fix.patch || return 1
+
+ # build bjam
+ cd ${srcdir}/${pkgname}_${_boostver}/tools/jam/src
+ ./build.sh cc || return 1
+
+ _bindir="bin.linuxx86"
+ [ "${CARCH}" = "x86_64" ] && _bindir="bin.linuxx86_64"
+
+ install -m755 -d ${pkgdir}/usr/bin
+ install -m755 ${_bindir}/bjam ${pkgdir}/usr/bin/bjam || return 1
+
+ # build bcp
+ cd ${srcdir}/${pkgname}_${_boostver}/tools/bcp
+ ../jam/src/${_bindir}/bjam || return 1
+ install -m755 ${srcdir}/${pkgname}_${_boostver}/dist/bin/bcp \
+ ${pkgdir}/usr/bin/bcp || return 1
+
+ # build libs
+ cd ${srcdir}/${pkgname}_${_boostver}
+ # default "debug release <runtime-link>static/dynamic <threading>single/multi"
+ # --layout=system removes the -gcc suffix from libraries and installs
+ # includes in /usr/include/boost.
+ ./tools/jam/src/${_bindir}/bjam \
+ release debug-symbols=off threading=single,multi \
+ runtime-link=shared link=shared,static \
+ --prefix=${pkgdir}/usr \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=2.5 \
+ -sTOOLS=gcc \
+ --layout=system \
+ install || return 1
+
+ # build pyste
+ cd ${srcdir}/${pkgname}_${_boostver}/libs/python/pyste/install
+ python setup.py install --root=${pkgdir} || return 1
+
+ # license
+ install -m755 -d ${pkgdir}/usr/share/licenses/${pkgname}
+ install -m644 ${srcdir}/${pkgname}_${_boostver}/LICENSE_1_0.txt \
+ ${pkgdir}/usr/share/licenses/${pkgname}/ || return 1
+}
+md5sums=('c38b88bb4ebc6d0d9193f432842273d2'
+ 'd7f821056540ef08eb1d5ebd5ed017f1')
diff --git a/abs/extra/boost/serialization_gcc43.patch b/abs/extra/boost/serialization_gcc43.patch
new file mode 100644
index 0000000..13dbf5d
--- /dev/null
+++ b/abs/extra/boost/serialization_gcc43.patch
@@ -0,0 +1,44 @@
+Index: /home/maik/workspace/boost/boost/archive/polymorphic_iarchive.hpp
+===================================================================
+--- /home/maik/workspace/boost/boost/archive/polymorphic_iarchive.hpp (Revision 43953)
++++ /home/maik/workspace/boost/boost/archive/polymorphic_iarchive.hpp (Arbeitskopie)
+@@ -17,6 +17,7 @@
+ // See http://www.boost.org for updates, documentation, and revision history.
+
+ #include <cstddef> // std::size_t
++#include <climits> // ULONG_MAX
+ #include <boost/config.hpp>
+
+ #if defined(BOOST_NO_STDC_NAMESPACE)
+@@ -38,6 +39,9 @@
+ // i.e. that its not a synonym for (unsigned) long
+ // if there is no 64 bit int or if its the same as a long
+ // we shouldn't define separate functions for int64 data types.
++#ifndef ULONG_MAX
++# error "ULONG_MAX is not defined"
++#endif
+ #if defined(BOOST_NO_INT64_T) \
+ || (ULONG_MAX != 0xffffffff && ULONG_MAX == 18446744073709551615u) // 2**64 - 1
+ # define BOOST_NO_INTRINSIC_INT64_T
+Index: /home/maik/workspace/boost/boost/archive/polymorphic_oarchive.hpp
+===================================================================
+--- /home/maik/workspace/boost/boost/archive/polymorphic_oarchive.hpp (Revision 43953)
++++ /home/maik/workspace/boost/boost/archive/polymorphic_oarchive.hpp (Arbeitskopie)
+@@ -18,6 +18,7 @@
+
+ #include <cstddef> // size_t
+ #include <string>
++#include <climits> // ULONG_MAX
+
+ #include <boost/config.hpp>
+ #if defined(BOOST_NO_STDC_NAMESPACE)
+@@ -37,6 +38,9 @@
+ // i.e. that its not a synonym for (unsigned) long
+ // if there is no 64 bit int or if its the same as a long
+ // we shouldn't define separate functions for int64 data types.
++#ifndef ULONG_MAX
++# error "ULONG_MAX is not defined"
++#endif
+ #if defined(BOOST_NO_INT64_T) \
+ || (ULONG_MAX != 0xffffffff && ULONG_MAX == 18446744073709551615u) // 2**64 - 1
+ # define BOOST_NO_INTRINSIC_INT64_T