summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/codecs/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/community/codecs/PKGBUILD')
-rw-r--r--abs/extra/community/codecs/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/extra/community/codecs/PKGBUILD b/abs/extra/community/codecs/PKGBUILD
new file mode 100644
index 0000000..8cf80be
--- /dev/null
+++ b/abs/extra/community/codecs/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 27228 2009-02-17 05:58:02Z thayer $
+# Contributor: Thomas Baechler <thomas@archlinux.org>
+# Maintainer: Thayer Williams <thayer@archlinux.org>
+
+pkgname=codecs
+pkgver=20071007
+pkgrel=3
+pkgdesc="Non-linux native codec pack. (Win32, Real9, QuickTime)"
+arch=('i686' 'x86_64')
+license=('unknown')
+# The codec packages are different
+# only the 32 bit package needs legacy libstdc++
+[ "$CARCH" = "i686" ] && depends=('libstdc++5')
+[ "$CARCH" = "x86_64" ] && depends=('gcc-libs')
+options=('!strip')
+url="http://www.mplayerhq.hu/design7/dload.html"
+
+md5sums=('4ea9c2dbd0945c83af1a8d0dd363993c')
+_arch=""
+if [ "${CARCH}" = "x86_64" ]; then
+ _arch="-amd64"
+ md5sums=('8e1ceeec51469f5baac65e56fac709e8')
+fi
+source=(http://www.mplayerhq.hu/MPlayer/releases/codecs/essential${_arch}-${pkgver}.tar.bz2)
+
+build() {
+ mkdir -p ${pkgdir}/usr/lib/codecs
+ cd ${pkgdir}/usr/lib
+ ln -s codecs win32
+ install -m755 ${srcdir}/essential${_arch}-${pkgver}/* ${pkgdir}/usr/lib/codecs
+ rm ${pkgdir}/usr/lib/codecs/README
+}
+