summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/curlftpfs/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/community/curlftpfs/PKGBUILD')
-rw-r--r--abs/extra/community/curlftpfs/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/abs/extra/community/curlftpfs/PKGBUILD b/abs/extra/community/curlftpfs/PKGBUILD
new file mode 100644
index 0000000..242e28f
--- /dev/null
+++ b/abs/extra/community/curlftpfs/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id$
+# Maintainer: Chris Brannon <cmbrannon79@gmail.com>
+# Contributor: Allan McRae <mcrae_allan@hotmail.com>
+# Contributor: Philip Nilsson <leffeman@gmail.com>
+
+pkgname=curlftpfs
+pkgver=0.9.2
+pkgrel=4
+pkgdesc="A filesystem for acessing FTP hosts based on FUSE and libcurl."
+url="http://curlftpfs.sourceforge.net/"
+license=('GPL')
+depends=('curl>=7.15.4' 'fuse' 'glib2')
+makedepends=('pkgconfig>=0.9.0')
+arch=('i686' 'x86_64')
+source=(http://downloads.sourceforge.net/sourceforge/curlftpfs/$pkgname-$pkgver.tar.gz
+ ioerror.patch)
+md5sums=('b452123f755114cd4461d56c648d9f12'
+ '7a8db686293463ba3148c7032871c883')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 < "$srcdir/ioerror.patch"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}