summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/curlftpfs
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/community/curlftpfs')
-rw-r--r--abs/extra/community/curlftpfs/PKGBUILD30
-rw-r--r--abs/extra/community/curlftpfs/ioerror.patch11
2 files changed, 0 insertions, 41 deletions
diff --git a/abs/extra/community/curlftpfs/PKGBUILD b/abs/extra/community/curlftpfs/PKGBUILD
deleted file mode 100644
index 242e28f..0000000
--- a/abs/extra/community/curlftpfs/PKGBUILD
+++ /dev/null
@@ -1,30 +0,0 @@
-# $Id$
-# Maintainer: Chris Brannon <cmbrannon79@gmail.com>
-# Contributor: Allan McRae <mcrae_allan@hotmail.com>
-# Contributor: Philip Nilsson <leffeman@gmail.com>
-
-pkgname=curlftpfs
-pkgver=0.9.2
-pkgrel=4
-pkgdesc="A filesystem for acessing FTP hosts based on FUSE and libcurl."
-url="http://curlftpfs.sourceforge.net/"
-license=('GPL')
-depends=('curl>=7.15.4' 'fuse' 'glib2')
-makedepends=('pkgconfig>=0.9.0')
-arch=('i686' 'x86_64')
-source=(http://downloads.sourceforge.net/sourceforge/curlftpfs/$pkgname-$pkgver.tar.gz
- ioerror.patch)
-md5sums=('b452123f755114cd4461d56c648d9f12'
- '7a8db686293463ba3148c7032871c883')
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
- patch -p1 < "$srcdir/ioerror.patch"
- ./configure --prefix=/usr
- make
-}
-
-package() {
- cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
-}
diff --git a/abs/extra/community/curlftpfs/ioerror.patch b/abs/extra/community/curlftpfs/ioerror.patch
deleted file mode 100644
index 6ca1afb..0000000
--- a/abs/extra/community/curlftpfs/ioerror.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- curlftpfs-0.9.2.orig/ftpfs.c 2008-04-30 03:05:47.000000000 +0400
-+++ curlftpfs-0.9.2.orig/ftpfs.c 2011-01-20 20:33:38.000000000 +0300
-@@ -503,7 +503,7 @@ static void *ftpfs_write_thread(void *da
-
- curl_easy_setopt_or_die(fh->write_conn, CURLOPT_URL, fh->full_path);
- curl_easy_setopt_or_die(fh->write_conn, CURLOPT_UPLOAD, 1);
-- curl_easy_setopt_or_die(fh->write_conn, CURLOPT_INFILESIZE, -1);
-+ curl_easy_setopt_or_die(fh->write_conn, CURLOPT_INFILESIZE, (curl_off_t)-1);
- curl_easy_setopt_or_die(fh->write_conn, CURLOPT_READFUNCTION, write_data_bg);
- curl_easy_setopt_or_die(fh->write_conn, CURLOPT_READDATA, fh);
- curl_easy_setopt_or_die(fh->write_conn, CURLOPT_LOW_SPEED_LIMIT, 1);