summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/deluge/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/community/deluge/PKGBUILD')
-rw-r--r--abs/extra/community/deluge/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/extra/community/deluge/PKGBUILD b/abs/extra/community/deluge/PKGBUILD
new file mode 100644
index 0000000..6a1a971
--- /dev/null
+++ b/abs/extra/community/deluge/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 26558 2009-02-09 16:10:09Z hugo $
+# Maintainer: Hugo Doria <hugo@archlinux.org>
+
+pkgname=deluge
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="A bittorrent client written with python and pygtk"
+arch=('i686' 'x86_64')
+url="http://deluge-torrent.org/"
+license=('GPL3')
+depends=('pygtk' 'boost>=1.37.0' 'pyxdg' 'dbus-python' 'librsvg' 'setuptools')
+makedepends=('subversion' 'intltool')
+options=('!emptydirs')
+source=(http://download.deluge-torrent.org/source/${pkgver}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('c9d56e266e5cb3024f2dbd72c952e182')
+
+build() {
+
+ cd ${srcdir}/${pkgname}-${pkgver}/
+ python setup.py build
+ python setup.py install --prefix=/usr --root=${pkgdir}
+
+ install -D -m644 deluge/data/pixmaps/deluge.svg ${pkgdir}/usr/share/pixmaps/deluge.svg
+}
+