summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/flashplugin/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/community/flashplugin/PKGBUILD')
-rw-r--r--abs/extra/community/flashplugin/PKGBUILD41
1 files changed, 14 insertions, 27 deletions
diff --git a/abs/extra/community/flashplugin/PKGBUILD b/abs/extra/community/flashplugin/PKGBUILD
index 1e68f40..7d7e65f 100644
--- a/abs/extra/community/flashplugin/PKGBUILD
+++ b/abs/extra/community/flashplugin/PKGBUILD
@@ -1,40 +1,27 @@
-# $Id: PKGBUILD 21951 2008-12-18 13:25:19Z thomas $
+# $Id: PKGBUILD 60911 2009-12-09 11:51:09Z andrea $
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=flashplugin
-_licensefile='Reader_Player_WWEULA-Combined-20060724_1430.pdf'
-if [ "${CARCH}" = 'i686' ]; then
- pkgver=10.0.15.3
- pkgrel=1
- source=('http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz'
- "http://www.adobe.com/products/eulas/pdfs/${_licensefile}")
- md5sums=('afab0b40b0ae11445e2e90a4a9224a8a'
- '844cea6c9afc13d9e27f28ce1a6e20f3')
-elif [ "${CARCH}" = 'x86_64' ]; then
- pkgver=10.0.d21.1
- pkgrel=1
- source=("http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-${pkgver}.linux-x86_64.so.tar.gz"
- "http://www.adobe.com/products/eulas/pdfs/${_licensefile}")
- md5sums=('c165af9d4e324bfaf6d1cfbdbe959fbb'
- '844cea6c9afc13d9e27f28ce1a6e20f3')
-else
- error Unknown architecture.
- exit 1
-fi
+_licensefile='Reader_Player_AIR_WWEULA-Combined-20080204_1313.pdf'
+pkgver=10.1.53.64
+pkgrel=1
pkgdesc='Adobe Flash Player'
-url='http://www.adobe.com/go/getflash'
+url='http://get.adobe.com/flashplayer'
arch=('i686' 'x86_64')
depends=('mozilla-common' 'libxt' 'gtk2' 'nss' 'curl')
replaces=('flashplugin-beta')
provides=('flashplayer')
license=('custom')
+source=('http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz'
+ "http://www.adobe.com/products/eulas/pdfs/${_licensefile}")
+[ "${CARCH}" = "x86_64" ] && source[0]="http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-${pkgver}.linux-${CARCH}.so.tar.gz"
+[ "${CARCH}" = "x86_64" ] && md5sums[0]='8b427c2991c0447af56a951c653ee383'
build() {
install -d -m755 ${pkgdir}/usr/lib/mozilla/plugins/ || return 1
- if [ "${CARCH}" = 'i686' ]; then
- install -m755 ${srcdir}/install_flash_player_10_linux/libflashplayer.so ${pkgdir}/usr/lib/mozilla/plugins/ || return 1
- elif [ "${CARCH}" = 'x86_64' ]; then
- install -m755 ${srcdir}/libflashplayer.so ${pkgdir}/usr/lib/mozilla/plugins/ || return 1
- fi
+ install -m755 ${srcdir}/libflashplayer.so ${pkgdir}/usr/lib/mozilla/plugins/ || return 1
install -d -m755 ${pkgdir}/usr/share/licenses/${pkgname}/ || return 1
- install -m644 "${_licensefile}" ${pkgdir}/usr/share/licenses/${pkgname}/ || return 1
+ install -m644 "${_licensefile}" ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.pdf || return 1
}
+md5sums=('e4cb4d26124605a54c3d498cc440368f'
+ '1636037610ee2aa35c5fb736a697b7e0')