summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/gstreamer0.10-base/revert-decodebin-playbin-removal.patch
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/community/gstreamer0.10-base/revert-decodebin-playbin-removal.patch')
-rw-r--r--abs/extra/community/gstreamer0.10-base/revert-decodebin-playbin-removal.patch122
1 files changed, 0 insertions, 122 deletions
diff --git a/abs/extra/community/gstreamer0.10-base/revert-decodebin-playbin-removal.patch b/abs/extra/community/gstreamer0.10-base/revert-decodebin-playbin-removal.patch
deleted file mode 100644
index 2e59139..0000000
--- a/abs/extra/community/gstreamer0.10-base/revert-decodebin-playbin-removal.patch
+++ /dev/null
@@ -1,122 +0,0 @@
-From fece626254e3b250e4514d1c92ac8289421d9511 Mon Sep 17 00:00:00 2001
-From: Sebastian Dröge <sebastian.droege@collabora.co.uk>
-Date: Thu, 15 Mar 2012 11:34:22 +0000
-Subject: Disable old playbin and decodebin
-
----
-diff --git a/gst/playback/Makefile.am b/gst/playback/Makefile.am
-index a0f1abc..700f581 100644
---- a/gst/playback/Makefile.am
-+++ b/gst/playback/Makefile.am
-@@ -6,19 +6,15 @@ glib_gen_basename = gstplay
- built_sources = gstplay-marshal.c
- built_headers = gstplay-marshal.h
-
--plugin_LTLIBRARIES = libgstplaybin.la libgstdecodebin.la libgstdecodebin2.la
-+plugin_LTLIBRARIES = libgstplaybin.la libgstdecodebin2.la
-
- csp_cflags = -DCOLORSPACE=\"ffmpegcolorspace\"
-
- libgstplaybin_la_SOURCES = \
- gstplayback.c \
-- gstplaybin.c \
- gstplaybin2.c \
- gstplaysink.c \
-- gstplaybasebin.c \
- gstplay-enum.c \
-- gststreaminfo.c \
-- gststreamselector.c \
- gstsubtitleoverlay.c \
- gstplaysinkvideoconvert.c \
- gstplaysinkaudioconvert.c \
-@@ -37,17 +33,6 @@ if !GST_PLUGIN_BUILD_STATIC
- libgstplaybin_la_LIBTOOLFLAGS = --tag=disable-static
- endif
-
--libgstdecodebin_la_SOURCES = gstdecodebin.c
--nodist_libgstdecodebin_la_SOURCES = $(built_sources)
--libgstdecodebin_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) $(csp_cflags)
--libgstdecodebin_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
--libgstdecodebin_la_LIBADD = \
-- $(top_builddir)/gst-libs/gst/pbutils/libgstpbutils-@GST_MAJORMINOR@.la \
-- $(GST_LIBS)
--if !GST_PLUGIN_BUILD_STATIC
--libgstdecodebin_la_LIBTOOLFLAGS = --tag=disable-static
--endif
--
- libgstdecodebin2_la_SOURCES = gstdecodebin2.c gsturidecodebin.c gstplay-enum.c
- nodist_libgstdecodebin2_la_SOURCES = $(built_sources)
- libgstdecodebin2_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) $(csp_cflags)
-@@ -61,11 +46,8 @@ endif
-
- noinst_HEADERS = \
- gstplayback.h \
-- gstplaybasebin.h \
- gstplaysink.h \
-- gststreaminfo.h \
- gstplay-enum.h \
-- gststreamselector.h \
- gstrawcaps.h \
- gstsubtitleoverlay.h \
- gstplaysinkvideoconvert.h \
-@@ -83,18 +65,6 @@ include $(top_srcdir)/common/gst-glib-gen.mak
-
- Android.mk: Makefile.am $(BUILT_SOURCES)
- androgenizer \
-- -:PROJECT libgstdecodebin -:SHARED libgstdecodebin \
-- -:TAGS eng debug \
-- -:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
-- -:SOURCES $(libgstdecodebin_la_SOURCES) \
-- $(nodist_libgstdecodebin_la_SOURCES) \
-- -:CFLAGS $(DEFS) $(DEFAULT_INCLUDES) $(libgstdecodebin_la_CFLAGS) $(csp_cflags) \
-- -:LDFLAGS $(libgstdecodebin_la_LDFLAGS) \
-- $(libgstdecodebin_la_LIBADD) \
-- -ldl \
-- -:PASSTHROUGH LOCAL_ARM_MODE:=arm \
-- LOCAL_MODULE_PATH:='$$(TARGET_OUT)/lib/gstreamer-0.10' \
-- \
- -:PROJECT libgstdecodebin2 -:SHARED libgstdecodebin2 \
- -:TAGS eng debug \
- -:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
-diff --git a/gst/playback/gstplayback.c b/gst/playback/gstplayback.c
-index 5b74786..f99df6e 100644
---- a/gst/playback/gstplayback.c
-+++ b/gst/playback/gstplayback.c
-@@ -29,8 +29,6 @@
-
- #include "gstplayback.h"
- #include "gstplaysink.h"
--#include "gststreamselector.h"
--#include "gststreaminfo.h"
- #include "gstsubtitleoverlay.h"
-
- static gboolean
-@@ -47,13 +45,7 @@ plugin_init (GstPlugin * plugin)
- bind_textdomain_codeset (GETTEXT_PACKAGE, "UTF-8");
- #endif /* ENABLE_NLS */
-
-- /* ref class from a thread-safe context to work around missing bit of
-- * thread-safety in GObject */
-- g_type_class_ref (GST_TYPE_STREAM_INFO);
-- g_type_class_ref (GST_TYPE_STREAM_SELECTOR);
--
-- res = gst_play_bin_plugin_init (plugin);
-- res &= gst_play_bin2_plugin_init (plugin);
-+ res = gst_play_bin2_plugin_init (plugin);
- res &= gst_play_sink_plugin_init (plugin);
- res &= gst_subtitle_overlay_plugin_init (plugin);
-
-diff --git a/gst/playback/gstplayback.h b/gst/playback/gstplayback.h
-index 4be121c..5981cdd 100644
---- a/gst/playback/gstplayback.h
-+++ b/gst/playback/gstplayback.h
-@@ -24,7 +24,6 @@
- #include <gst/gst.h>
-
- gboolean gst_decode_bin_plugin_init (GstPlugin * plugin);
--gboolean gst_play_bin_plugin_init (GstPlugin * plugin);
- gboolean gst_play_bin2_plugin_init (GstPlugin * plugin);
-
-
---
-cgit v0.9.0.2-2-gbebe