summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/gstreamer0.10/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/community/gstreamer0.10/PKGBUILD')
-rw-r--r--abs/extra/community/gstreamer0.10/PKGBUILD50
1 files changed, 0 insertions, 50 deletions
diff --git a/abs/extra/community/gstreamer0.10/PKGBUILD b/abs/extra/community/gstreamer0.10/PKGBUILD
deleted file mode 100644
index d856335..0000000
--- a/abs/extra/community/gstreamer0.10/PKGBUILD
+++ /dev/null
@@ -1,50 +0,0 @@
-# $Id$
-# Maintainer: Jan de Groot <jgc@archlinux.org>
-
-pkgname=gstreamer0.10
-pkgver=0.10.36
-pkgrel=4
-pkgdesc="GStreamer Multimedia Framework"
-arch=('i686' 'x86_64')
-license=('LGPL')
-url="http://gstreamer.com"
-depends=('libxml2' 'glib2')
-makedepends=('intltool' 'pkgconfig' 'gobject-introspection' 'git')
-source=("git://anongit.freedesktop.org/gstreamer-sdk/gstreamer#commit=3ddc31eaa18c3be1613e43430eca78a3e445639e"
- tests-remove-silly-test_fail_abstract_new-check.patch
- bison3.patch)
-sha256sums=('SKIP'
- 'd3d3f4f04453831fdb4244bfe174a38c4e6f9f4da5c8c9050dcfa1a6097aad52'
- 'ed154e280abf59b24d98a8ab0fe868b449b26aa61f7ae3813fab8ac615fcaefa')
-
-prepare() {
- cd gstreamer
- patch -Np1 -i ../tests-remove-silly-test_fail_abstract_new-check.patch
- patch -Np1 -i ../bison3.patch
- sed -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' -i configure.ac
-}
-build() {
- cd gstreamer
- NOCONFIGURE=1 ./autogen.sh
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib \
- --with-package-name="GStreamer (Archlinux)" \
- --with-package-origin="http://www.archlinux.org/" \
- --disable-gtk-doc --disable-static
- make
-}
-
-check() {
- cd gstreamer
- make check
-}
-
-package() {
- cd gstreamer
- make DESTDIR="${pkgdir}" install
-
- #Remove unversioned gst-* binaries to get rid of conflicts
- cd "${pkgdir}/usr/bin"
- for bins in `ls *-0.10`; do
- rm -f ${bins/-0.10/}
- done
-}