summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/lua/lua-arch.patch
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/community/lua/lua-arch.patch')
-rw-r--r--abs/extra/community/lua/lua-arch.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/abs/extra/community/lua/lua-arch.patch b/abs/extra/community/lua/lua-arch.patch
index 7d6d331..cc1f3ce 100644
--- a/abs/extra/community/lua/lua-arch.patch
+++ b/abs/extra/community/lua/lua-arch.patch
@@ -35,7 +35,7 @@ diff -ur lua-5.1.orig/src/Makefile lua-5.1/src/Makefile
$(RANLIB) $@
+$(LUA_SO): $(CORE_O) $(LIB_O)
-+ $(CC) -shared -ldl -Wl,-soname,liblua.so -o $@.5.1 $? $(MYLDFLAGS)
++ $(CC) -shared -ldl -Wl,-soname,liblua.so -o $@.5.1 $? -lm $(MYLDFLAGS)
+ ln -s $@.5.1 $@
+
$(LUA_T): $(LUA_O) $(LUA_A)