summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/twisted/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/community/twisted/PKGBUILD')
-rw-r--r--abs/extra/community/twisted/PKGBUILD29
1 files changed, 0 insertions, 29 deletions
diff --git a/abs/extra/community/twisted/PKGBUILD b/abs/extra/community/twisted/PKGBUILD
deleted file mode 100644
index 13fca6b..0000000
--- a/abs/extra/community/twisted/PKGBUILD
+++ /dev/null
@@ -1,29 +0,0 @@
-# $Id: PKGBUILD 94591 2010-10-08 12:55:33Z ibiru $
-# Maintainer : Ionut Biru <ibiru@archlinux.org>
-# Contributor: Juergen Hoetzel <juergen@archlinux.org>
-# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
-
-pkgname=twisted
-pkgver=10.1.0
-pkgrel=3
-pkgdesc="Asynchronous networking framework written in Python."
-arch=('i686' 'x86_64')
-url="http://twistedmatrix.com/"
-license=('MIT')
-depends=('python2' 'pycrypto' 'zope-interface')
-optdepends=('pyopenssl'
- 'python-soappy:for twisted.web.soap')
-install=twisted.install
-source=(http://tmrc.mit.edu/mirror/twisted/Twisted/${pkgver%.*}/Twisted-${pkgver}.tar.bz2)
-md5sums=('04cca97506e830074cffc1965297da3f')
-build() {
- cd "${srcdir}/Twisted-${pkgver}"
-
- python2 setup.py install --prefix=/usr --root=$pkgdir --optimize=1
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
-
- sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' \
- -i ${pkgdir}/usr/lib/python2.6/site-packages/twisted/trial/test/scripttest.py
- sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' \
- -i ${pkgdir}/usr/lib/python2.6/site-packages/twisted/mail/test/pop3testserver.py
-}