summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/unrar/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/community/unrar/PKGBUILD')
-rw-r--r--abs/extra/community/unrar/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/extra/community/unrar/PKGBUILD b/abs/extra/community/unrar/PKGBUILD
new file mode 100644
index 0000000..6b68616
--- /dev/null
+++ b/abs/extra/community/unrar/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 18913 2008-11-10 11:16:31Z giovanni $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: dorphell <dorphell@gmx.net>
+
+pkgname=unrar
+pkgver=3.8.5
+pkgrel=1
+pkgdesc="The RAR uncompression program"
+arch=('i686' 'x86_64')
+depends=('gcc-libs')
+url="http://rarlab.com"
+license=('custom')
+replaces=('rar')
+source=(http://www.rarlab.com/rar/unrarsrc-${pkgver}.tar.gz)
+md5sums=('875688e6a144a3f75d2a6a0da3e43f8b')
+
+build() {
+ cd ${srcdir}/${pkgname}
+ make -f makefile.unix
+ install -Dm755 unrar ${pkgdir}/usr/bin/unrar
+ # install license
+ install -Dm644 license.txt ${pkgdir}/usr/share/licenses/$pkgname/license.txt
+}