summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/xbmc
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/community/xbmc')
-rw-r--r--abs/extra/community/xbmc/ChangeLog64
-rw-r--r--abs/extra/community/xbmc/PKGBUILD118
-rw-r--r--abs/extra/community/xbmc/xbmc.install9
3 files changed, 191 insertions, 0 deletions
diff --git a/abs/extra/community/xbmc/ChangeLog b/abs/extra/community/xbmc/ChangeLog
new file mode 100644
index 0000000..59f2370
--- /dev/null
+++ b/abs/extra/community/xbmc/ChangeLog
@@ -0,0 +1,64 @@
+2009-03-07 [vEX] <niechift.dot.vex.at.gmail.dot.com>
+
+ * 8.10-10 :
+ Try and fix some autoconf issues (thanks Gentoo ebuild).
+
+2009-02-08 [vEX] <niechift.dot.vex.at.gmail.dot.com>
+
+ * 8.10-9 :
+ Replace some libtool 'ltmain.sh' scripts with the one from libtool
+ installed with Arch.
+ Make sure XBMCTex isn't linked to OpenGL libraries or it will segfault
+ on systems using the nvidia driver.
+
+2009-01-30 [vEX] <niechift.dot.vex.at.gmail.dot.com>
+
+ * 8.10-8 :
+ Fix some include's so that gcc 4.3.x is happy, shouldn't complain about
+ undefined '::realloc' anymore.
+ Remove Mac OS X specific files.
+
+2009-01-25 [vEX] <niechift.dot.vex.at.gmail.dot.com>
+
+ * 8.10-7 :
+ Moved libcdio, pmount, smbclient and unrar to optdepends.
+ Removed unneeded dependency on sdl_gfx.
+ Removed dependency on libpng as sdl_image depends on it.
+
+2008-12-14 [vEX] <niechift.dot.vex.at.gmail.dot.com>
+
+ * 8.10-6 :
+ Added libpng to dependency list.
+ Added gawk to dependency list.
+ Removed '--disable-mms' and '--enable-halmount' configure flags as they
+ are not mentioned as supported in the configure script.
+
+2008-12-06 [vEX] <niechift.dot.vex.at.gmail.dot.com>
+
+ * 8.10-5 :
+ Added libmad to the dependency list.
+ Streamripper 1.64.0+ does not include tre anymore, removed streamripper
+ and added tre instead.
+ Removed subversion from makedepends.
+
+2008-12-06 [vEX] <niechift.dot.vex.at.gmail.dot.com>
+
+ * 8.10-4 :
+ Fix permissions for some more scripts, ffmpeg/texi2doc.pl should not
+ fail any longer.
+
+2008-12-05 [vEX] <niechift.dot.vex.at.gmail.dot.com>
+
+ * 8.10-3 :
+ Added lirc to the optdepends array.
+
+2008-11-26 [vEX] <niechift.dot.vex.at.gmail.dot.com>
+
+ * 8.10-2 :
+ Added install file which informs users that a display depth of at
+ least 24-bit is required.
+
+2008-11-17 [vEX] <niechift.dot.vex.at.gmail.dot.com>
+
+ * 8.10-1 :
+ Initial package, based on previous work by Zeqadious.
diff --git a/abs/extra/community/xbmc/PKGBUILD b/abs/extra/community/xbmc/PKGBUILD
new file mode 100644
index 0000000..950d704
--- /dev/null
+++ b/abs/extra/community/xbmc/PKGBUILD
@@ -0,0 +1,118 @@
+# Contributor: [vEX] <niechift.dot.vex.at.gmail.dot.com>
+# Contributor: Zeqadious <zeqadious.at.gmail.dot.com>
+
+pkgname=xbmc
+pkgver=8.10
+pkgrel=10
+pkgdesc="XBMC Media Center"
+arch=('i686' 'x86_64')
+url="http://xbmc.org"
+license=('GPL' 'custom')
+depends=('alsa-lib' 'curl' 'enca' 'faac' 'freetype2' 'fribidi' 'gawk' 'glew' \
+ 'hal' 'jasper' 'libgl' 'libjpeg>=6b-5' 'libmad' 'libmysqlclient' \
+ 'libxinerama' 'libxrandr' 'lzo2' 'sdl_image' 'sdl_mixer' 'sqlite3' \
+ 'tre' 'unzip' 'x-server')
+makedepends=('autoconf' 'automake' 'boost' 'cmake' 'gcc' 'gperf'
+ 'libtool>=2.2.6a-1' 'make' 'nasm' 'patch' 'pkgconfig' 'zip')
+optdepends=('libcdio: optical disc support'
+ 'lirc: remote controller support'
+ 'pmount: mount removable devices as normal user'
+ 'smbclient: access windows shares'
+ 'unrar: access compressed files without unpacking them')
+install=("${pkgname}.install")
+source=("http://downloads.sourceforge.net/${pkgname}/XBMC-${pkgver}.src.tar.gz")
+md5sums=('2d20d255a211223eaa47f1c6bcf4be8e')
+
+build() {
+ cd "${srcdir}/XBMC"
+
+ # Remove Mac OS X specific files
+ rm -rf system/python/lib-osx/
+ rm system/players/dvdplayer/*-osx*
+
+ # Fix permissions for the configure scripts
+ find -type f -name "configure"|xargs chmod a+x || return 1
+
+ # Fix other permissions
+ find -type f -name "*.pl"|xargs chmod a+x || return 1
+
+ # Make it gcc 4.3.x compatible
+ sed '92i#include <stdlib.h>' -i guilib/system.h || return 1
+
+ # Clean up the configure files and make sure they support C++.
+ for file in `find . -type f -name configure.in -or -name configure.ac`; do
+ echo 'AC_PROG_CXX' >> "${file}"
+ sed -e '/AM_PATH_XMMS/ c\echo' \
+ -e '/AM_PATH_SDL2/ c\echo' \
+ -i ${file} || return 1
+ done
+ sed -e 's/test_libFLAC++//g' \
+ -i "${srcdir}/XBMC/xbmc/cores/paplayer/flac-1.2.1/src/Makefile.am" || return 1
+
+ # Fix some autoconf issues
+ touch ${srcdir}/XBMC/xbmc/cores/dvdplayer/Codecs/libmad/{NEWS,AUTHORS,ChangeLog} || return 1
+ touch ${srcdir}/XBMC/xbmc/visualizations/Goom/goom2k4-0/ylwrap || return 1
+ touch ${srcdir}/XBMC/xbmc/lib/libid3tag/libid3tag/{NEWS,README,AUTHORS,ChangeLog} || return 1
+ for dir in \
+ . \
+ xbmc/cores/dvdplayer/Codecs/libDVDCSS \
+ xbmc/cores/dvdplayer/Codecs/libdts \
+ xbmc/cores/dvdplayer/Codecs/libdvdnav \
+ xbmc/cores/dvdplayer/Codecs/libfaad2 \
+ xbmc/cores/dvdplayer/Codecs/libmad \
+ xbmc/cores/dvdplayer/Codecs/libmpeg2 \
+ xbmc/cores/paplayer/flac-1.2.1 \
+ xbmc/cores/paplayer/vorbisfile/libvorbis \
+ xbmc/cores/paplayer/vorbisfile/ogg \
+ xbmc/visualizations/Goom/goom2k4-0 \
+ xbmc/lib/libass \
+ xbmc/lib/libid3tag/libid3tag
+ do
+ autoreconf --install "${srcdir}/XBMC/${dir}" || return 1
+ done
+
+ cd "${srcdir}/XBMC/"
+
+ # Configure XBMC
+ ./configure --prefix=/usr \
+ --disable-debug || return 1
+
+ # Fix false negative detections of realloc that happens some times
+ if grep -q 'HAVE_REALLOC 0' config.h; then
+ sed -e 's|#define HAVE_REALLOC 0|#define HAVE_REALLOC 1|' \
+ -e 's|#define realloc rpl_realloc|/* #define realloc rpl_realloc */|' \
+ -i config.h || return 1
+ fi
+
+ # XBMCTex will segfault on systems with nvidia instaleld if linked to OpenGL
+ sed -e 's/-lGLU -lGLEW -lGL//' \
+ -i ${srcdir}/XBMC/tools/XBMCTex/Makefile
+
+ # Now (finally) build
+ make || return 1
+ make prefix=${pkgdir}/usr install || return 1
+
+ # Fix the shell script
+ sed -i '4iexport SDL_AUDIODRIVER=alsa' ${pkgdir}/usr/bin/xbmc
+
+ # Xrandr
+ install -Dm755 ${srcdir}/XBMC/xbmc-xrandr \
+ ${pkgdir}/usr/share/xbmc/xbmc-xrandr || return 1
+
+ # Menu item
+ install -Dm644 ${srcdir}/XBMC/tools/Linux/xbmc.desktop \
+ ${pkgdir}/usr/share/applications/xbmc.desktop || return 1
+ install -Dm644 ${srcdir}/XBMC/tools/Linux/xbmc.png \
+ ${pkgdir}/usr/share/pixmaps/xbmc.png || return 1
+
+ # XBMCTex
+ install -Dm755 ${srcdir}/XBMC/tools/XBMCTex/XBMCTex \
+ ${pkgdir}/usr/share/xbmc/tools/xbmctex || return 1
+
+ # License(s)
+ install -dm755 ${pkgdir}/usr/share/licenses/${pkgname}
+ for licensef in LICENSE.GPL README.linux copying.txt; do
+ mv ${pkgdir}/usr/share/xbmc/${licensef} \
+ ${pkgdir}/usr/share/licenses/${pkgname} || return 1
+ done
+}
diff --git a/abs/extra/community/xbmc/xbmc.install b/abs/extra/community/xbmc/xbmc.install
new file mode 100644
index 0000000..9316bc8
--- /dev/null
+++ b/abs/extra/community/xbmc/xbmc.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ">> If XBMC won't start, but just segfaults, double check your X.Org config"
+ echo ">> so that your display depth is at least 24-bit. Eg: change "
+ echo ">> \"DefaultDepth 16\" under the \"Screen\" section so it says 24 instead"
+ echo ">> of 16."
+ /bin/true
+}
+
+# vim:set ts=2 sw=2 et: