summaryrefslogtreecommitdiffstats
path: root/abs/extra/cups/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/cups/PKGBUILD')
-rw-r--r--abs/extra/cups/PKGBUILD161
1 files changed, 98 insertions, 63 deletions
diff --git a/abs/extra/cups/PKGBUILD b/abs/extra/cups/PKGBUILD
index 9a55d2f..63bb641 100644
--- a/abs/extra/cups/PKGBUILD
+++ b/abs/extra/cups/PKGBUILD
@@ -1,66 +1,104 @@
-# $Id: PKGBUILD 161774 2012-06-13 17:38:37Z andyrtr $
+# $Id$
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
pkgbase="cups"
pkgname=('libcups' 'cups')
-pkgver=1.5.3
-pkgrel=5
+pkgver=1.7.1
+pkgrel=4
arch=('i686' 'x86_64')
license=('GPL')
url="http://www.cups.org/"
-makedepends=('libtiff>=4.0.0' 'libpng>=1.5.7' 'acl' 'openslp' 'pam' 'xdg-utils' 'krb5' 'gnutls>=2.8.3' 'cups-filters' 'bc'
- 'xinetd' 'gzip' 'autoconf' 'libusb' 'dbus-core' 'avahi' 'hicolor-icon-theme' 'systemd')
-source=(ftp://ftp.easysw.com/pub/cups/${pkgver}/cups-${pkgver}-source.tar.bz2
- cups-avahi-1-config.patch
- cups-avahi-2-backend.patch
- cups-avahi-3-timeouts.patch
- cups-avahi-4-poll.patch
- cups-avahi-5-services.patch
+makedepends=('libtiff>=4.0.0' 'libpng>=1.5.7' 'acl' 'pam' 'xdg-utils' 'krb5' 'openssl'
+ 'cups-filters' 'bc' 'colord' 'xinetd' 'gzip' 'autoconf' 'libusb' 'dbus'
+ 'avahi' 'hicolor-icon-theme' 'systemd' 'inetutils' 'libpaper' 'valgrind')
+source=(#http://mirror.easysw.com/pub/cups/${pkgver}/cups-${pkgver}-source.tar.bz2
+ http://www.cups.org/software/${pkgver}/cups-${pkgver}-source.tar.bz2
+ cups.logrotate cups.pam
+ # improve build and linking
cups-no-export-ssllibs.patch
cups-no-gcrypt.patch
cups-no-gzip-man.patch
+ # FC
cups-systemd-socket.patch
- cups cups.logrotate cups.pam)
-#options=('!emptydirs')
-md5sums=('e1ad15257aa6f162414ea3beae0c5df8'
- '12c8af5bcd3b8f84240280b3dfaf9e89'
- 'cdc1322c8014297ae349e2db78a03c5a'
- '1a5112f63958643f2888abc9418dbcac'
- 'c37d1bf1bb76acc3fe93362c80d91b7c'
- '5d302860559960042f3b47a91b97c5fe'
- '9b8467a1e51d360096b70e2c3c081e6c'
- '3733c23e77eb503bd94cc368e02830dc'
- 'c9159ba1233902ba6ddbbe6885a46b72'
- '4505b8b2c57a7c28ea79e08388bbbbb9'
- '9657daa21760bb0b5fa3d8b51d5e01a1'
+ cups-res_init.patch
+ cups-avahi-address.patch
+ cups-enum-all.patch
+ cups-final-content-type.patch
+ # Gentoo
+ cups-1.6.0-fix-install-perms.patch
+ cups-1.6.2-statedir.patch
+ # Debian
+ cupsd-no-crash-on-avahi-threaded-poll-shutdown.patch
+ get-ppd-file-for-statically-configured-ipp-shared-queues.patch
+ ppd-poll-with-client-conf.patch)
+md5sums=('55277c40fd4b7183dc3671d39c5c42b7'
'f861b18f4446c43918c8643dcbbd7f6d'
- '96f82c38f3f540b53f3e5144900acf17')
+ '96f82c38f3f540b53f3e5144900acf17'
+ '3ba9e3410df1dc3015463d615ef91b3b'
+ 'cc4101beccb5ed6deb1c92707a575925'
+ '90c30380d4c8cd48a908cfdadae1ea24'
+ 'cf2f881967b0531ec49bcb5d0e9573a8'
+ '8fe27d4248cacbc02824e7937cab4088'
+ 'df0c367c0022e3c7d8e01827e8a6c5e7'
+ 'f30c2a161caaf27854581507cde8cac6'
+ 'a31b64ba25a985fbae65d8ddf311b08c'
+ '5117f65342fcc69c6a506529e4daca9e'
+ '451609db34f95209d64c38474de27ce1'
+ 'cb58bf4e0b80eaee383712e5c84a1ab4'
+ 'b578bcd17949a7203237ba1e31f78ef9'
+ '0becd6ab8782b97f19a02c1dc174c75e')
-build() {
- cd ${srcdir}/${pkgbase}-${pkgver}
- # http://www.cups.org/str.php?L3066
- # Avahi support in the dnssd backend. patches from upstream/FC RawHide
- patch -Np1 -i ${srcdir}/cups-avahi-1-config.patch
- patch -Np1 -i ${srcdir}/cups-avahi-2-backend.patch
- patch -Np1 -i ${srcdir}/cups-avahi-3-timeouts.patch
- patch -Np1 -i ${srcdir}/cups-avahi-4-poll.patch
- patch -Np1 -i ${srcdir}/cups-avahi-5-services.patch
+prepare() {
+ cd ${pkgbase}-${pkgver}
+
# add systemd socket support - Fedora patch, also used in Gentoo
+ # modified now to the changes done by Gentoo in their svn ebuild
+ # http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/net-print/cups/files/cups-1.5.0-systemd-socket.patch?revision=1.1
patch -Np1 -i ${srcdir}/cups-systemd-socket.patch
-
+
# Do not export SSL libs in cups-config
patch -Np1 -i "${srcdir}/cups-no-export-ssllibs.patch"
patch -Np1 -i "${srcdir}/cups-no-gcrypt.patch"
+
# don't zip man pages in make install, let makepkg do that / Fedora
patch -Np1 -i ${srcdir}/cups-no-gzip-man.patch
+
+
+ # various bugfixes (upstream reports/SVN or Fedora/Debian
+
+ # Fixed crash which sometimes happens on shutdown of the CUPS daemon, caused by a wrong shutdown sequence for shutting down the Avahi threaded poll.
+# patch -Np1 -i ${srcdir}/cupsd-no-crash-on-avahi-threaded-poll-shutdown.patch
+ # Applications could not get the PPD file for statically-configured IPP-shared print queues
+ patch -Np1 -i ${srcdir}/get-ppd-file-for-statically-configured-ipp-shared-queues.patch
+ # If an external server is used via client.conf and the DNS is inconsistent (ex: DNS gives "noname" for many IPs, reverse DNS gives one of these IPs
+ # for "noname") local PPDs can get polled for print queues instead of the PPDs of the external server Bug: http://www.cups.org/str.php?L2763
+# patch -Np1 -i ${srcdir}/ppd-poll-with-client-conf.patch
+ # fix permissions on some files - alternative: cups-0755.patch by FC
+ patch -Np0 -i ${srcdir}/cups-1.6.0-fix-install-perms.patch
+ # move /var/run -> /run for pid file
+ patch -Np1 -i ${srcdir}/cups-1.6.2-statedir.patch
+ # Re-initialise the resolver on failure in httpAddrGetList()
+ patch -Np1 -i ${srcdir}/cups-res_init.patch
+ # Use IP address when resolving DNSSD URIs
+ patch -Np1 -i ${srcdir}/cups-avahi-address.patch
+ # Return from cupsEnumDests() once all records have been returned.
+ patch -Np1 -i ${srcdir}/cups-enum-all.patch
- # Rebuild configure script for --enable-avahi.
+ # Fix printing to some network printers fails - https://bugs.archlinux.org/task/37605
+ patch -Np1 -i ${srcdir}/cups-final-content-type.patch
+
+ # Rebuild configure script for not zipping man-pages.
aclocal -I config-scripts
autoconf -I config-scripts
+}
+
+build() {
+ cd ${pkgbase}-${pkgver}
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --sbindir=/usr/bin \
--libdir=/usr/lib \
--with-systemdsystemunitdir=/usr/lib/systemd/system \
--with-logdir=/var/log/cups \
@@ -68,32 +106,30 @@ build() {
--with-cups-user=daemon \
--with-cups-group=lp \
--enable-pam=yes \
- --disable-ldap \
--enable-raw-printing \
--enable-dbus --with-dbusdir=/etc/dbus-1 \
- --enable-ssl=yes --enable-gnutls \
+ --enable-ssl=yes --enable-openssl \
--enable-threads \
--enable-avahi\
+ --enable-libpaper \
--with-php=/usr/bin/php-cgi \
- --with-pdftops=pdftops \
--with-optim="$CFLAGS"
make
}
check() {
- cd "$srcdir/$pkgbase-$pkgver"
- #httpAddrGetList(workstation64): FAIL
- #1 TESTS FAILED!
- #make[1]: *** [testhttp] Error 1
+ cd ${pkgbase}-${pkgver}
+#./run-stp-tests.sh: line 782: 6307 Aborted (core dumped) $VALGRIND ../scheduler/cupsd -c /tmp/cups-$user/cupsd.conf -f > /tmp/cups-$user/log/debug_log 2>&1
+#FAIL: 87 error messages, expected 33.
make -k check || /bin/true
}
package_libcups() {
pkgdesc="The CUPS Printing System - client libraries and headers"
-depends=('gnutls>=2.8.3' 'libtiff>=4.0.0' 'libpng>=1.5.7' 'krb5' 'avahi')
+depends=('openssl' 'libtiff>=4.0.0' 'libpng>=1.5.7' 'krb5' 'avahi')
backup=(etc/cups/client.conf)
- cd ${srcdir}/${pkgbase}-${pkgver}
+ cd ${pkgbase}-${pkgver}
make BUILDROOT=${pkgdir} install-headers install-libs
# put this into the libs pkg to make other software find the libs(no pkg-config file included)
mkdir -p ${pkgdir}/usr/bin
@@ -101,13 +137,12 @@ backup=(etc/cups/client.conf)
# install client.conf man page and config file
install -dm755 ${pkgdir}/usr/share/man/man5
- #install -Dm644 ${srcdir}/${pkgbase}-${pkgver}/man/client.conf.5.gz ${pkgdir}/usr/share/man/man5/
install -Dm644 ${srcdir}/${pkgbase}-${pkgver}/man/client.conf.5 ${pkgdir}/usr/share/man/man5/
- install -dm755 ${pkgdir}/etc/cups
+ install -dm755 -g lp ${pkgdir}/etc/cups
touch ${pkgdir}/etc/cups/client.conf
echo "# see 'man client.conf'" >> ${pkgdir}/etc/cups/client.conf
echo "ServerName /var/run/cups/cups.sock # alternative: ServerName hostname-or-ip-address[:port] of a remote server" >> ${pkgdir}/etc/cups/client.conf
- chgrp lp ${pkgdir}/etc/cups/client.conf
+ chgrp -R lp ${pkgdir}/etc/cups
}
package_cups() {
@@ -117,16 +152,17 @@ backup=(etc/cups/cupsd.conf
etc/cups/snmp.conf
etc/cups/printers.conf
etc/cups/classes.conf
+ etc/cups/cups-files.conf
etc/cups/subscriptions.conf
etc/dbus-1/system.d/cups.conf
etc/logrotate.d/cups
etc/pam.d/cups
etc/xinetd.d/cups-lpd)
-depends=('acl' 'openslp' 'pam' "libcups>=${pkgver}" 'cups-filters' 'bc' 'libusb' 'dbus-core' 'libsystemd' 'hicolor-icon-theme')
-optdepends=('php: for included phpcups.so module'
- 'xdg-utils: xdg .desktop file support')
+depends=('acl' 'pam' "libcups>=${pkgver}" 'cups-filters' 'bc' 'colord'
+ 'libusb' 'dbus' 'systemd' 'libpaper' 'hicolor-icon-theme')
+optdepends=('xdg-utils: xdg .desktop file support')
- cd ${srcdir}/${pkgbase}-${pkgver}
+ cd ${pkgbase}-${pkgver}
make BUILDROOT=${pkgdir} install-data install-exec
# this one we ship in the libcups pkg
@@ -135,24 +171,23 @@ optdepends=('php: for included phpcups.so module'
# kill the sysv stuff
rm -rf ${pkgdir}/etc/rc*.d
rm -rf ${pkgdir}/etc/init.d
- install -D -m755 ../cups ${pkgdir}/etc/rc.d/cupsd
install -D -m644 ../cups.logrotate ${pkgdir}/etc/logrotate.d/cups
install -D -m644 ../cups.pam ${pkgdir}/etc/pam.d/cups
# fix perms on /var/spool and /etc
chmod 755 ${pkgdir}/var/spool
chmod 755 ${pkgdir}/etc
-
+
# install ssl directory where to store the certs, solves some samba issues
install -dm700 -g lp ${pkgdir}/etc/cups/ssl
- # remove directory from package, we create it in cups rc.d file
- rm -rf ${pkgdir}/var/run
+ # remove directory from package, it will be recreated at each server start
+ rm -rf ${pkgdir}/run
# install some more configuration files that will get filled by cupsd
touch ${pkgdir}/etc/cups/printers.conf
touch ${pkgdir}/etc/cups/classes.conf
touch ${pkgdir}/etc/cups/subscriptions.conf
- chgrp lp ${pkgdir}/etc/cups/{printers.conf,classes.conf,subscriptions.conf}
+ chgrp -R lp ${pkgdir}/etc/cups
# fix .desktop file
sed -i 's|^Exec=htmlview http://localhost:631/|Exec=xdg-open http://localhost:631/|g' ${pkgdir}/usr/share/applications/cups.desktop
@@ -163,12 +198,12 @@ optdepends=('php: for included phpcups.so module'
# remove client.conf man page
rm -f ${pkgdir}/usr/share/man/man5/client.conf.5
- # remove files now part of cups-filters - check cups-filters INSTALL for packagers instructions
- rm -v ${pkgdir}/usr/lib/cups/backend/{parallel,serial}
- rm -v ${pkgdir}/usr/lib/cups/filter/{bannertops,commandtoescpx,commandtopclx,imagetops,imagetoraster,pdftops,rastertoescpx,rastertopclx,texttops}
+ # remove files now part of cups-filters
rm -v ${pkgdir}/usr/share/cups/banners/*
- rm -v ${pkgdir}/usr/share/cups/data/{testprint,psglyphs}
- rm -v ${pkgdir}/usr/share/cups/fonts/*
+ rm -v ${pkgdir}/usr/share/cups/data/testprint
# comment out all conversion rules which use any of the removed filters
- perl -p -i -e 's:^(.*\s+(pdftops|texttops|imagetops|bannertops|imagetoraster)\s*)$:#\1:' ${pkgdir}/usr/share/cups/mime/mime.convs
+ perl -p -i -e 's:^(.*\s+bannertops\s*)$:#\1:' $pkgdir/usr/share/cups/mime/mime.convs
+
+ # Provide native service for arch-daemons generator
+ ln -s cups.service "$pkgdir/usr/lib/systemd/system/cupsd.service"
}