summaryrefslogtreecommitdiffstats
path: root/abs/extra/cups/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/cups/PKGBUILD')
-rw-r--r--abs/extra/cups/PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/abs/extra/cups/PKGBUILD b/abs/extra/cups/PKGBUILD
index e1f13b7..730bed3 100644
--- a/abs/extra/cups/PKGBUILD
+++ b/abs/extra/cups/PKGBUILD
@@ -1,9 +1,9 @@
-# $Id: PKGBUILD 82848 2010-06-18 06:18:19Z andyrtr $
+# $Id: PKGBUILD 98719 2010-11-12 22:23:13Z andyrtr $
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
pkgbase="cups"
pkgname=('libcups' 'cups')
-pkgver=1.4.4
+pkgver=1.4.5
pkgrel=1
arch=('i686' 'x86_64')
license=('GPL')
@@ -14,8 +14,8 @@ source=(ftp://ftp.easysw.com/pub/cups/${pkgver}/cups-${pkgver}-source.tar.bz2
cups-avahi.patch
cups cups.logrotate cups.pam)
#options=('!emptydirs')
-md5sums=('8776403ad60fea9e85eab9c04d88560d'
- '3388dbe3fc20f16f37912e60a8ec46bc'
+md5sums=('50729f6fc46ba54223e0eaf5009f3419'
+ '8ebd390197501ffd709f0ee546937fd5'
'5c85b7d8d2ddd02c2c64955cebbf55ea'
'f861b18f4446c43918c8643dcbbd7f6d'
'96f82c38f3f540b53f3e5144900acf17')
@@ -24,23 +24,23 @@ build() {
cd ${srcdir}/${pkgbase}-${pkgver}
# Avahi support in the dnssd backend. patch from Fedora
patch -Np1 -i ${srcdir}/cups-avahi.patch || return 1
+
# Rebuild configure script for --enable-avahi.
aclocal -I config-scripts
autoconf -I config-scripts
+
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--with-logdir=/var/log/cups -with-docdir=/usr/share/cups/doc \
--with-cups-user=daemon --with-cups-group=lp --enable-pam=yes \
--disable-ldap --libdir=/usr/lib --enable-raw-printing \
- --enable-dbus --with-dbusdir=/etc/dbus-1 --enable-ssl=yes --enable-gnutls --disable-threads --enable-dnssd\
+ --enable-dbus --with-dbusdir=/etc/dbus-1 --enable-ssl=yes --enable-gnutls --disable-threads --enable-avahi\
--with-php=/usr/bin/php-cgi --with-pdftops=pdftops --with-optim="$CFLAGS"
make || return 1
}
package_libcups() {
pkgdesc="The CUPS Printing System - client libraries and headers"
-depends=('gnutls>=2.8.3' 'libtiff>=3.9.2-2' 'libpng>=1.4.0' 'heimdal>=1.3.1')
-optdepends=('avahi: for the "dnssd" CUPS backend')
-
+depends=('gnutls>=2.8.3' 'libtiff>=3.9.2-2' 'libpng>=1.4.0' 'heimdal>=1.3.1' 'avahi')
cd ${srcdir}/${pkgbase}-${pkgver}
make BUILDROOT=${pkgdir} install-headers install-libs || return 1
@@ -83,6 +83,9 @@ optdepends=('php: for included phpcups.so module')
# fix perms on /var/spool and /etc
chmod 755 ${pkgdir}/var/spool
chmod 755 ${pkgdir}/etc
+
+ # serial backend needs to run as root (http://bugs.archlinux.org/task/20396)
+ chmod 700 ${pkgdir}/usr/lib/cups/backend/serial
# install ssl directory where to store the certs, solves some samba issues
install -dm700 -g lp ${pkgdir}/etc/cups/ssl