summaryrefslogtreecommitdiffstats
path: root/abs/extra/cups/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/cups/PKGBUILD')
-rw-r--r--abs/extra/cups/PKGBUILD42
1 files changed, 19 insertions, 23 deletions
diff --git a/abs/extra/cups/PKGBUILD b/abs/extra/cups/PKGBUILD
index 08a3e19..3975850 100644
--- a/abs/extra/cups/PKGBUILD
+++ b/abs/extra/cups/PKGBUILD
@@ -1,17 +1,18 @@
-# $Id: PKGBUILD 199750 2013-11-15 15:38:18Z andyrtr $
+# $Id: PKGBUILD 218449 2014-07-31 13:11:09Z andyrtr $
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
pkgbase="cups"
pkgname=('libcups' 'cups')
-pkgver=1.7.0
-pkgrel=2
+pkgver=1.7.5
+pkgrel=1
arch=('i686' 'x86_64')
license=('GPL')
url="http://www.cups.org/"
-makedepends=('libtiff>=4.0.0' 'libpng>=1.5.7' 'acl' 'pam' 'xdg-utils' 'krb5' 'gnutls>=2.8.3' 'cups-filters' 'bc'
- 'colord' 'xinetd' 'gzip' 'autoconf' 'libusb' 'dbus-core' 'avahi' 'hicolor-icon-theme' 'systemd')
+makedepends=('libtiff>=4.0.0' 'libpng>=1.5.7' 'acl' 'pam' 'xdg-utils' 'krb5' 'openssl'
+ 'cups-filters' 'bc' 'colord' 'xinetd' 'gzip' 'autoconf' 'libusb' 'dbus'
+ 'avahi' 'hicolor-icon-theme' 'systemd' 'inetutils' 'libpaper' 'valgrind')
source=(#http://mirror.easysw.com/pub/cups/${pkgver}/cups-${pkgver}-source.tar.bz2
- http://www.cups.org/software/${pkgver}/cups-${pkgver}-source.tar.bz2
+ http://www.cups.org/software/${pkgver}/cups-${pkgver}-source.tar.bz2{,.sig}
cups.logrotate cups.pam
# improve build and linking
cups-no-export-ssllibs.patch
@@ -19,7 +20,6 @@ source=(#http://mirror.easysw.com/pub/cups/${pkgver}/cups-${pkgver}-source.tar.b
cups-no-gzip-man.patch
# FC
cups-systemd-socket.patch
- cups-dbus-utf8.patch
cups-res_init.patch
cups-avahi-address.patch
cups-enum-all.patch
@@ -31,14 +31,14 @@ source=(#http://mirror.easysw.com/pub/cups/${pkgver}/cups-${pkgver}-source.tar.b
cupsd-no-crash-on-avahi-threaded-poll-shutdown.patch
get-ppd-file-for-statically-configured-ipp-shared-queues.patch
ppd-poll-with-client-conf.patch)
-md5sums=('5ab496a2ce27017fcdb3d7ec4818a75a'
- 'f861b18f4446c43918c8643dcbbd7f6d'
+md5sums=('5d893edc2957005f78e2b2423fdace2e'
+ 'SKIP'
+ '26e9b4e65c0a4d76db5737c9b156fd80'
'96f82c38f3f540b53f3e5144900acf17'
'3ba9e3410df1dc3015463d615ef91b3b'
'cc4101beccb5ed6deb1c92707a575925'
'90c30380d4c8cd48a908cfdadae1ea24'
- '555a1c71151ce990e176315b46e3de2f'
- 'a2a88b3a3257c3b5fd3edcc169e6aca4'
+ '8162e1d05947bd59fa29ba40ac565fec'
'8fe27d4248cacbc02824e7937cab4088'
'df0c367c0022e3c7d8e01827e8a6c5e7'
'f30c2a161caaf27854581507cde8cac6'
@@ -52,7 +52,7 @@ md5sums=('5ab496a2ce27017fcdb3d7ec4818a75a'
prepare() {
cd ${pkgbase}-${pkgver}
-
+#return 1
# add systemd socket support - Fedora patch, also used in Gentoo
# modified now to the changes done by Gentoo in their svn ebuild
# http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/net-print/cups/files/cups-1.5.0-systemd-socket.patch?revision=1.1
@@ -69,9 +69,6 @@ prepare() {
# various bugfixes (upstream reports/SVN or Fedora/Debian
- # Ensure attributes are valid UTF-8 in dbus notifier
- patch -Np1 -i ${srcdir}/cups-dbus-utf8.patch
-
# Fixed crash which sometimes happens on shutdown of the CUPS daemon, caused by a wrong shutdown sequence for shutting down the Avahi threaded poll.
# patch -Np1 -i ${srcdir}/cupsd-no-crash-on-avahi-threaded-poll-shutdown.patch
# Applications could not get the PPD file for statically-configured IPP-shared print queues
@@ -112,9 +109,10 @@ build() {
--enable-pam=yes \
--enable-raw-printing \
--enable-dbus --with-dbusdir=/etc/dbus-1 \
- --enable-ssl=yes --enable-gnutls \
+ --enable-ssl=yes --enable-openssl \
--enable-threads \
--enable-avahi\
+ --enable-libpaper \
--with-php=/usr/bin/php-cgi \
--with-optim="$CFLAGS"
make
@@ -122,15 +120,12 @@ build() {
check() {
cd ${pkgbase}-${pkgver}
- #httpAddrGetList(workstation64): FAIL
- #1 TESTS FAILED!
- #make[1]: *** [testhttp] Error 1
make -k check || /bin/true
}
package_libcups() {
pkgdesc="The CUPS Printing System - client libraries and headers"
-depends=('gnutls>=2.8.3' 'libtiff>=4.0.0' 'libpng>=1.5.7' 'krb5' 'avahi')
+depends=('openssl' 'libtiff>=4.0.0' 'libpng>=1.5.7' 'krb5' 'avahi')
backup=(etc/cups/client.conf)
cd ${pkgbase}-${pkgver}
@@ -162,7 +157,8 @@ backup=(etc/cups/cupsd.conf
etc/logrotate.d/cups
etc/pam.d/cups
etc/xinetd.d/cups-lpd)
-depends=('acl' 'pam' "libcups>=${pkgver}" 'cups-filters' 'bc' 'colord' 'libusb' 'dbus-core' 'libsystemd' 'hicolor-icon-theme')
+depends=('acl' 'pam' "libcups>=${pkgver}" 'cups-filters' 'bc' 'colord'
+ 'libusb' 'dbus' 'systemd' 'libpaper' 'hicolor-icon-theme')
optdepends=('xdg-utils: xdg .desktop file support')
cd ${pkgbase}-${pkgver}
@@ -183,8 +179,8 @@ optdepends=('xdg-utils: xdg .desktop file support')
# install ssl directory where to store the certs, solves some samba issues
install -dm700 -g lp ${pkgdir}/etc/cups/ssl
- # remove directory from package, we create it in cups rc.d file
- rm -rf ${pkgdir}/var/run
+ # remove directory from package, it will be recreated at each server start
+ rm -rf ${pkgdir}/run
# install some more configuration files that will get filled by cupsd
touch ${pkgdir}/etc/cups/printers.conf