summaryrefslogtreecommitdiffstats
path: root/abs/extra/cups/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/cups/PKGBUILD')
-rw-r--r--abs/extra/cups/PKGBUILD119
1 files changed, 40 insertions, 79 deletions
diff --git a/abs/extra/cups/PKGBUILD b/abs/extra/cups/PKGBUILD
index 3975850..e82a2f1 100644
--- a/abs/extra/cups/PKGBUILD
+++ b/abs/extra/cups/PKGBUILD
@@ -1,94 +1,59 @@
-# $Id: PKGBUILD 218449 2014-07-31 13:11:09Z andyrtr $
+# $Id$
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
pkgbase="cups"
pkgname=('libcups' 'cups')
-pkgver=1.7.5
-pkgrel=1
+pkgver=2.1.2
+pkgrel=3
arch=('i686' 'x86_64')
license=('GPL')
url="http://www.cups.org/"
-makedepends=('libtiff>=4.0.0' 'libpng>=1.5.7' 'acl' 'pam' 'xdg-utils' 'krb5' 'openssl'
+makedepends=('libtiff>=4.0.0' 'libpng>=1.5.7' 'acl' 'pam' 'xdg-utils' 'krb5' 'gnutls'
'cups-filters' 'bc' 'colord' 'xinetd' 'gzip' 'autoconf' 'libusb' 'dbus'
'avahi' 'hicolor-icon-theme' 'systemd' 'inetutils' 'libpaper' 'valgrind')
-source=(#http://mirror.easysw.com/pub/cups/${pkgver}/cups-${pkgver}-source.tar.bz2
- http://www.cups.org/software/${pkgver}/cups-${pkgver}-source.tar.bz2{,.sig}
+source=(http://www.cups.org/software/${pkgver}/cups-${pkgver}-source.tar.bz2{,.sig}
cups.logrotate cups.pam
# improve build and linking
cups-no-export-ssllibs.patch
cups-no-gcrypt.patch
cups-no-gzip-man.patch
- # FC
- cups-systemd-socket.patch
- cups-res_init.patch
- cups-avahi-address.patch
- cups-enum-all.patch
- cups-final-content-type.patch
- # Gentoo
- cups-1.6.0-fix-install-perms.patch
cups-1.6.2-statedir.patch
- # Debian
- cupsd-no-crash-on-avahi-threaded-poll-shutdown.patch
- get-ppd-file-for-statically-configured-ipp-shared-queues.patch
- ppd-poll-with-client-conf.patch)
-md5sums=('5d893edc2957005f78e2b2423fdace2e'
+ cups-1.6.0-fix-install-perms.patch
+ # bugfixes
+)
+md5sums=('b3ba0ca676d56857bbd9b182ef4b14b3'
'SKIP'
- '26e9b4e65c0a4d76db5737c9b156fd80'
+ 'fc8286f185e2cc5f7e1f6843bf193e2b'
'96f82c38f3f540b53f3e5144900acf17'
'3ba9e3410df1dc3015463d615ef91b3b'
- 'cc4101beccb5ed6deb1c92707a575925'
+ '1beb4896f217bc241bc08a422274ec0c'
'90c30380d4c8cd48a908cfdadae1ea24'
- '8162e1d05947bd59fa29ba40ac565fec'
- '8fe27d4248cacbc02824e7937cab4088'
- 'df0c367c0022e3c7d8e01827e8a6c5e7'
- 'f30c2a161caaf27854581507cde8cac6'
- 'a31b64ba25a985fbae65d8ddf311b08c'
- '5117f65342fcc69c6a506529e4daca9e'
'451609db34f95209d64c38474de27ce1'
- 'cb58bf4e0b80eaee383712e5c84a1ab4'
- 'b578bcd17949a7203237ba1e31f78ef9'
- '0becd6ab8782b97f19a02c1dc174c75e')
+ '5117f65342fcc69c6a506529e4daca9e')
+validpgpkeys=('3737FD0D0E63B30172440D2DDBA3A7AB08D76223') # CUPS.org (CUPS.org PGP key) <security@cups.org>
prepare() {
cd ${pkgbase}-${pkgver}
-#return 1
- # add systemd socket support - Fedora patch, also used in Gentoo
- # modified now to the changes done by Gentoo in their svn ebuild
- # http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/net-print/cups/files/cups-1.5.0-systemd-socket.patch?revision=1.1
- patch -Np1 -i ${srcdir}/cups-systemd-socket.patch
-
+
+ # improve build and linking
# Do not export SSL libs in cups-config
- patch -Np1 -i "${srcdir}/cups-no-export-ssllibs.patch"
-
- patch -Np1 -i "${srcdir}/cups-no-gcrypt.patch"
-
+ patch -Np1 -i ${srcdir}/cups-no-export-ssllibs.patch
+ # https://www.cups.org/str.php?L4399
+ patch -Np1 -i ${srcdir}/cups-no-gcrypt.patch
# don't zip man pages in make install, let makepkg do that / Fedora
patch -Np1 -i ${srcdir}/cups-no-gzip-man.patch
-
-
- # various bugfixes (upstream reports/SVN or Fedora/Debian
-
- # Fixed crash which sometimes happens on shutdown of the CUPS daemon, caused by a wrong shutdown sequence for shutting down the Avahi threaded poll.
-# patch -Np1 -i ${srcdir}/cupsd-no-crash-on-avahi-threaded-poll-shutdown.patch
- # Applications could not get the PPD file for statically-configured IPP-shared print queues
- patch -Np1 -i ${srcdir}/get-ppd-file-for-statically-configured-ipp-shared-queues.patch
- # If an external server is used via client.conf and the DNS is inconsistent (ex: DNS gives "noname" for many IPs, reverse DNS gives one of these IPs
- # for "noname") local PPDs can get polled for print queues instead of the PPDs of the external server Bug: http://www.cups.org/str.php?L2763
-# patch -Np1 -i ${srcdir}/ppd-poll-with-client-conf.patch
- # fix permissions on some files - alternative: cups-0755.patch by FC
- patch -Np0 -i ${srcdir}/cups-1.6.0-fix-install-perms.patch
# move /var/run -> /run for pid file
patch -Np1 -i ${srcdir}/cups-1.6.2-statedir.patch
- # Re-initialise the resolver on failure in httpAddrGetList()
- patch -Np1 -i ${srcdir}/cups-res_init.patch
- # Use IP address when resolving DNSSD URIs
- patch -Np1 -i ${srcdir}/cups-avahi-address.patch
- # Return from cupsEnumDests() once all records have been returned.
- patch -Np1 -i ${srcdir}/cups-enum-all.patch
+ # fix permissions on some files (by Gentoo) - alternative: cups-0755.patch by FC
+ patch -Np0 -i ${srcdir}/cups-1.6.0-fix-install-perms.patch
+
+ # bug fixes
- # Fix printing to some network printers fails - https://bugs.archlinux.org/task/37605
- patch -Np1 -i ${srcdir}/cups-final-content-type.patch
+ # set MaxLogSize to 0 to prevent using cups internal log rotation
+ sed -i -e '5i\ ' conf/cupsd.conf.in
+ sed -i -e '6i# Disable cups internal logging - use logrotate instead' conf/cupsd.conf.in
+ sed -i -e '7iMaxLogSize 0' conf/cupsd.conf.in
# Rebuild configure script for not zipping man-pages.
aclocal -I config-scripts
@@ -97,11 +62,11 @@ prepare() {
build() {
cd ${pkgbase}-${pkgver}
-
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
--sbindir=/usr/bin \
--libdir=/usr/lib \
- --with-systemdsystemunitdir=/usr/lib/systemd/system \
--with-logdir=/var/log/cups \
--with-docdir=/usr/share/cups/doc \
--with-cups-user=daemon \
@@ -109,23 +74,23 @@ build() {
--enable-pam=yes \
--enable-raw-printing \
--enable-dbus --with-dbusdir=/etc/dbus-1 \
- --enable-ssl=yes --enable-openssl \
+ --enable-ssl=yes \
--enable-threads \
--enable-avahi\
--enable-libpaper \
--with-php=/usr/bin/php-cgi \
- --with-optim="$CFLAGS"
+ --with-optim="$CFLAGS" #--help
make
}
check() {
cd ${pkgbase}-${pkgver}
- make -k check || /bin/true
+ #make -k check || /bin/true
}
package_libcups() {
pkgdesc="The CUPS Printing System - client libraries and headers"
-depends=('openssl' 'libtiff>=4.0.0' 'libpng>=1.5.7' 'krb5' 'avahi')
+depends=('gnutls' 'libtiff>=4.0.0' 'libpng>=1.5.7' 'krb5' 'avahi' 'libusb')
backup=(etc/cups/client.conf)
cd ${pkgbase}-${pkgver}
@@ -140,7 +105,7 @@ backup=(etc/cups/client.conf)
install -dm755 -g lp ${pkgdir}/etc/cups
touch ${pkgdir}/etc/cups/client.conf
echo "# see 'man client.conf'" >> ${pkgdir}/etc/cups/client.conf
- echo "ServerName /var/run/cups/cups.sock # alternative: ServerName hostname-or-ip-address[:port] of a remote server" >> ${pkgdir}/etc/cups/client.conf
+ echo "ServerName /run/cups/cups.sock # alternative: ServerName hostname-or-ip-address[:port] of a remote server" >> ${pkgdir}/etc/cups/client.conf
chgrp -R lp ${pkgdir}/etc/cups
}
@@ -155,10 +120,9 @@ backup=(etc/cups/cupsd.conf
etc/cups/subscriptions.conf
etc/dbus-1/system.d/cups.conf
etc/logrotate.d/cups
- etc/pam.d/cups
- etc/xinetd.d/cups-lpd)
+ etc/pam.d/cups)
depends=('acl' 'pam' "libcups>=${pkgver}" 'cups-filters' 'bc' 'colord'
- 'libusb' 'dbus' 'systemd' 'libpaper' 'hicolor-icon-theme')
+ 'dbus' 'systemd' 'libpaper' 'hicolor-icon-theme')
optdepends=('xdg-utils: xdg .desktop file support')
cd ${pkgbase}-${pkgver}
@@ -197,12 +161,9 @@ optdepends=('xdg-utils: xdg .desktop file support')
# remove client.conf man page
rm -f ${pkgdir}/usr/share/man/man5/client.conf.5
- # remove files now part of cups-filters
- rm -v ${pkgdir}/usr/share/cups/banners/*
- rm -v ${pkgdir}/usr/share/cups/data/testprint
- # comment out all conversion rules which use any of the removed filters
+ # comment out all conversion rules which use any of the removed filters that are now part of cups-filters
perl -p -i -e 's:^(.*\s+bannertops\s*)$:#\1:' $pkgdir/usr/share/cups/mime/mime.convs
-
- # Provide native service for arch-daemons generator
- ln -s cups.service "$pkgdir/usr/lib/systemd/system/cupsd.service"
+
+ # comment out unnecessary PageLogFormat entry
+ sed -i -e 's:PageLogFormat:#PageLogFormat:' $pkgdir/etc/cups/cupsd.conf*
}